software-center crashed with IndexError in _on_total_size_calculation_done(): list index out of range

Bug #1225885 reported by sunsik on 2013-09-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

I don't know

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: software-center 13.08-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-7.13-generic 3.11.0
Uname: Linux 3.11.0-7-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
CrashCounter: 1
Date: Thu Sep 12 15:33:05 2013
ExecutablePath: /usr/share/software-center/software-center
ExecutableTimestamp: 1375903486
InstallationDate: Installed on 2013-05-17 (118 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
InterpreterPath: /usr/bin/python2.7
LocalLibraries: /usr/local/lib/python2.7/dist-packages/lxml/etree.so
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center /home/username/Downloads/robomongo-0.8.2-x86_64.deb
ProcCwd: /home/sunsik
PythonArgs: ['/usr/bin/software-center', '/home/username/Downloads/robomongo-0.8.2-x86_64.deb']
SourcePackage: software-center
Title: software-center crashed with IndexError in _on_total_size_calculation_done(): list index out of range
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 591, in _on_total_size_calculation_done
     pkgname = trans.packages[0][0]
 IndexError: list index out of range
UpgradeStatus: Upgraded to saucy on 2013-09-12 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

sunsik (sunsik) wrote :

This crash has the same stack trace characteristics as bug #1062641. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
importance: Undecided → Medium
tags: added: regression-retracer
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.10-0ubuntu4

---------------
software-center (13.10-0ubuntu4) trusty; urgency=low

  [ Robert Ancell ]
  * debian/patches/04_bzr_r3322_lp1281317.patch
    - merge upstream rev3322 to fix LP: #1281317

  [ Michael Vogt ]
  * debian/patches/05_lp225885.patch:
    - cherry pick lp:~mvo/software-center/lp1225885 to fix LP: #1225885
 -- Michael Vogt <email address hidden> Thu, 10 Apr 2014 18:21:54 +0200

Changed in software-center (Ubuntu):
status: New → Fix Released
Adolfo Jayme (fitojb) on 2014-04-11
information type: Private → Public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers