software-center crashed with TypeError in __init__(): must be type, not classobj

Bug #1198822 reported by Jackson Doak on 2013-07-08
164
This bug affects 33 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Critical
dobey

Bug Description

When opening software center in xubuntu 13.03 AMD64, it crashed before anything opened.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: software-center 13.05-0ubuntu2
ProcVersionSignature: Ubuntu 3.10.0-2.10-generic 3.10.0
Uname: Linux 3.10.0-2-generic x86_64
ApportVersion: 2.10.2-0ubuntu3
Architecture: amd64
Date: Mon Jul 8 17:33:26 2013
ExecutablePath: /usr/share/software-center/software-center
InstallationDate: Installed on 2013-05-31 (38 days ago)
InstallationMedia: Xubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with TypeError in __init__(): must be type, not classobj
UpgradeStatus: Upgraded to saucy on 2013-07-06 (1 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Jackson Doak (noskcaj) wrote :
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1198822

tags: added: iso-testing
dobey (dobey) on 2013-07-12
Changed in software-center (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Rodney Dawes (dobey)
Doug McMahon (mc3man) wrote :

At least here in 13.10 S-c (13.05-0ubuntu2) is failing to start with this error due to python-configparser not being installed

Doug McMahon (mc3man) wrote :

Just noticed a proper fix in saucy-proposed that works fine in absence of python-configparser, ect.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.07-0ubuntu2

---------------
software-center (13.07-0ubuntu2) saucy; urgency=low

  * debian/patches/01_bzr-test-fixes.patch:
    - Remove the bad tests files instead of renaming them.
 -- Rodney Dawes <email address hidden> Tue, 16 Jul 2013 14:11:34 -0400

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
wayward4now (wayward4now) wrote :

Sorry, still have the same problem. Running 13.04 XFCE AMD-64. It's now October.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers