Previews for applications are really slow to display anything

Bug #1192081 reported by Didier Roche on 2013-06-18
130
This bug affects 29 people
Affects Status Importance Assigned to Milestone
unity-lens-applications
Medium
Unassigned
software-center (Ubuntu)
Critical
eduardo
unity-lens-applications (Ubuntu)
Critical
Unassigned

Bug Description

I'm seeing rightly on forums and generally the Internet that 100scopes previews are slow, combined with the fact that we now have the left click showing the preview by default frustrate a lot of users.

On my beefy machine (i7, 8G of rams), the preview for an application takes 3/4s to show, you can't do anything meanwhile as there is no button to launch the application (because you didn't double click, just left click and thought "argh, I should have double click").

Because of this, we are making the 1st landing of 100 scopes experience bad and we should fix it (at least, in that applicatoin lens) by either preloading the software-center-dbus (/usr/share/software-center/software-center-dbus) daemon (we can't have it always running as it's taking over 100MB of memory) when hovering an app lens result, or when it's the first result (so can be directly triggered by pressing [Enter])

description: updated
Didier Roche (didrocks) on 2013-06-18
description: updated
Changed in unity-lens-applications:
status: New → Triaged
importance: Undecided → Critical
Changed in software-center (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2013-06-18
Changed in software-center (Ubuntu):
importance: Undecided → Critical
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Critical
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Changed in unity-lens-applications (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2013-06-18
description: updated
description: updated
Thomas Strehl (strehl-t) on 2013-06-25
tags: added: 100scopes
Changed in unity-lens-applications:
assignee: nobody → Pawel Stolowski (stolowski)
Changed in unity-lens-applications:
status: Triaged → In Progress
Paweł Stołowski (stolowski) wrote :

The attached lp:~stolowski/unity-lens-applications/sc-startup branch may or may not improve the situation by activating software-center-dbus on every search, thus giving it a slight edge over preview request. It helps in typical cases, but there are still cases where it won't help (e.g. search string doesn't change and Dash is re-opened after a few minutes - software-center-dbus is no longer alive and won't be started until preview request). Therefore I don't dare to call it a proper fix. The real fix requires significant re-work of software-center-dbus to make it more robust (e.g. load data lazily, instead of loading everything + doing network queries on startup) or abandon software-center-dbus in app-scope and obtain all the data directly.

Samson (mickaelsamson22) on 2013-07-01
Changed in software-center:
assignee: nobody → Samson (mickaelsamson22)
assignee: Samson (mickaelsamson22) → nobody
Changed in unity-lens-applications:
status: In Progress → Triaged
importance: Critical → Medium
assignee: Pawel Stolowski (stolowski) → nobody
Paweł Stołowski (stolowski) wrote :

According to https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1189088, we will revert to the old behavior for applications scope results (left-click activates installed apps immediately). The performance of app previews is the same as in 13.04, but since app previews will only be displayed on right-click again, this is no longer a critical problem, thus lowering its severity.

Dave Morley (davmor2) on 2013-07-09
tags: added: u1-notrack
Jeb E. (jebeld17) wrote :

The Software Center is extremely slow to open, compared to other programs. Maybe there is a correlation?

Changed in software-center:
status: New → Confirmed
Darlan Alves (darlan) wrote :

I think a small improvement would be at least show some feedback to click action. I've been using Application lens for a long time, and I always think I'm doing something wrong when I click on a result.

When I do a search for a given app name and click on a resulting app, nothing happens for a while. The software is doing some initialization under the hood or searching online for more info about that app. It will take 2~4 seconds, leaving me stuck into search results.

If the desired/expected action is to open the details panel for that app, then at least a 'loading' animation will help to indicate that I've done the right thing clicking the icon, or open the panel and let it empty on screen until the app data arrives.

The feel I have using the application lens is that I'm searching for apps, looking for results, but the "install/open details" feature is not implemented yet.

tags: added: scopes-s
eduardo (lalo7america) on 2014-02-10
Changed in software-center (Ubuntu):
assignee: nobody → eduardo (lalo7america)
status: Triaged → In Progress
Roger fidèle (z-roger) on 2014-02-20
Changed in unity-lens-applications:
status: Triaged → New
Anders (eddiedog988) on 2014-03-13
Changed in unity-lens-applications:
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu):
status: Triaged → Confirmed
Changed in software-center (Ubuntu):
status: In Progress → Confirmed
madbiologist (me-again) wrote :

Official support for Ubuntu 13.10 "Saucy Salamander" has ended. Is this still occurring on Ubuntu 15.04 "Vivid Vervet"?

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Incomplete
Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Jeb E. (jebeld17) on 2015-04-24
Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Changed in unity-lens-applications (Ubuntu):
status: Incomplete → Confirmed
chaya (chaya-d-14) on 2015-11-19
Changed in software-center:
assignee: nobody → chaya (chaya-d-14)
dobey (dobey) on 2015-12-18
no longer affects: software-center

same problem
and one more
Ubuntu software center crashes

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers