Software center fails to start in ubuntu 13.04 64bit

Bug #1184890 reported by Wouter Vandenneucker on 2013-05-28
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Dave Morley

Bug Description

things I did to try and fix it:
"sudo apt-get install --reinstall software-center"
and
"sudo dpkg-reconfigure software-center"

Output when I start software-center now via terminal:

2013-05-28 10:48:07,826 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 338, in __init__
    self.icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/appmanager.py", line 66, in __init__
    self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/ubuntusso.py", line 141, in find_oauth_token_sync
    sso.find_credentials()
  File "/usr/share/software-center/softwarecenter/backend/login_impl/login_sso.py", line 75, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Dave Morley (davmor2) wrote :

I am unable to replicate this, can I get some more information please:
1. Are you on a fresh install or an upgrade from Quantal?
2. Has it ever worked?
3. Can you try removing ~/.cache/software-center and ~/.config/software-center and let me know if it then works?

Many thanks.

Changed in software-center:
status: New → Incomplete
importance: Undecided → Low
assignee: nobody → Dave Morley (davmor2)
tags: added: u1-by-user u1-on-production

I upgraded from Quantal.
It didn't work after the update, however, after 3 days it fixed itself, I have no idea how or why...

So the issue is fixed here, but if I can help you with providing data to find out why it happened, I'd be glad to.

kind regards.

Wouter

Surya (surya-akasam) wrote :

I am facing a similar issue with 14.04 LTS 64-bit version.
I believe it stopped wroking after I updated the python from v2.7 to v3.4.

Regards,
Surya

dobey (dobey) on 2015-12-18
affects: software-center → software-center (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers