software-center returns error

Bug #1173764 reported by Tim Johnson on 2013-04-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Debian)
Fix Released
Unknown
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

1) Ubuntu 13.04
2) tim@tim-desktop:~$ apt-cache policy software-center
software-center:
  Installed: 5.6.0-0ubuntu2
  Candidate: 5.6.0-0ubuntu2
  Version table:
 *** 5.6.0-0ubuntu2 0
        500 http://za.archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status
3) I expected Software Center to launch when I clicked the icon in the Unity Launcher. When it did not, I expected it to launch after entering "software-center" in the terminal.
4) On clicking Unity launcher, icon flashed; Software Center did not launch. On trying to start from terminal, the attached error report was generated.
tim@tim-desktop:~$ software-center
2013-04-27 22:14:17,302 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 291, in __init__
    self.cache = get_pkg_info()
  File "/usr/share/software-center/softwarecenter/db/pkginfo.py", line 245, in get_pkg_info
    from softwarecenter.db.pkginfo_impl.aptcache import AptCache
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 30, in <module>
    from aptdaemon.client import AptClient
  File "/usr/lib/python2.7/dist-packages/aptdaemon/client.py", line 70, in <module>
    class MemoizedMixInMeta(MemoizedTransaction, GObject.GObjectMeta):
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 316, in __getattr__
    return getattr(self._introspection_module, name)
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 135, in __getattr__
    self.__name__, name))
AttributeError: 'gi.repository.GObject' object has no attribute 'GObjectMeta'

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Debian):
status: Unknown → New
Changed in software-center (Debian):
status: New → Confirmed
Changed in software-center (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.