update-software-center AttributeError during upgrade from 12.10 to 13.04

Bug #1173249 reported by Evan on 2013-04-26
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Undecided
Unassigned
Quantal
High
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned
pygobject (Ubuntu)
Undecided
Martin Pitt
Quantal
Undecided
Unassigned
Raring
Undecided
Iain Lane
Saucy
Undecided
Martin Pitt
software-center (Ubuntu)
High
dobey
Quantal
Undecided
Unassigned
Raring
Critical
Unassigned
Saucy
High
dobey

Bug Description

During upgrade from Ubuntu 12.10 to Ubuntu 13.04, this can happen when update-software-center is run by triggers:

Traceback (most recent call last):
  File "/usr/sbin/update-software-center", line 170, in <module>
    result = rebuild_database(pathname)
  File "/usr/share/software-center/softwarecenter/db/update.py", line 1108, in rebuild_database
    cache = get_pkg_info()
  File "/usr/share/software-center/softwarecenter/db/pkginfo.py", line 240, in get_pkg_info
    from softwarecenter.db.pkginfo_impl.aptcache import AptCache
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 30, in <module>
    from aptdaemon.client import AptClient
  File "/usr/lib/python2.7/dist-packages/aptdaemon/client.py", line 70, in <module>
    class MemoizedMixInMeta(MemoizedTransaction, GObject.GObjectMeta):
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 316, in __getattr__
    return getattr(self._introspection_module, name)
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 135, in __getattr__
    self.__name__, name))
AttributeError: 'gi.repository.GObject' object has no attribute 'GObjectMeta'

dobey (dobey) on 2013-04-26
description: updated
Changed in aptdaemon (Ubuntu Raring):
status: New → Fix Released
Changed in aptdaemon (Ubuntu):
status: New → Fix Released
no longer affects: aptdaemon
Changed in pygobject (Ubuntu Quantal):
status: New → Invalid
Changed in pygobject (Ubuntu Raring):
assignee: nobody → Iain Lane (laney)
status: New → Triaged
Changed in pygobject (Ubuntu Saucy):
status: New → Triaged
Iain Lane (laney) on 2013-04-26
Changed in pygobject (Ubuntu Raring):
milestone: none → ubuntu-13.04-month-6
dobey (dobey) on 2013-04-26
Changed in software-center (Ubuntu Raring):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Critical
status: New → Triaged
Changed in software-center (Ubuntu Saucy):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
status: New → Triaged
Changed in aptdaemon (Ubuntu Quantal):
importance: Undecided → High
status: New → Triaged
dobey (dobey) on 2013-04-26
summary: - /usr/share/software-center/update-software-
- center:AttributeError:/usr/sbin/update-software-
- center@170:rebuild_database:get_pkg_info:/usr/share/software-
- center/softwarecenter/db/pkginfo_impl/aptcache.py@30:/usr/lib/python2.7
- /dist-packages/aptdaemon/client.py@70:__getattr__:__getattr__
+ update-software-center AttributeError during upgrade from 12.10 to 13.04
dobey (dobey) wrote :

Here is a debdiff of changes to pygobject to add Breaks of old aptdaemon and software-center (older than the version currently uploaded to raring-proposed, to fix postinst to deal with this issue), to avoid running the postinst with the old code which causes this issue.

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu Quantal):
status: New → Confirmed
Iain Lane (laney) wrote :

Uploaded pygobject to raring with slightly modified breaks to be << the-new-version rather than <= the-current-version. Don't accept it without accepting software-center first, please. :-)

Rodney, this bug will need an SRU description - description, test case, regression potential.

Iain Lane (laney) wrote :

Oh, and please inform pitti so that he can integrate the patch upstream if desired.

Martin Pitt (pitti) wrote :

pygobject raring is already in the queue

Changed in pygobject (Ubuntu Raring):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

I incorporate the pygobject change for saucy into my 3.9.1 upload.

Changed in pygobject (Ubuntu Saucy):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Actually, I can't upload pygobject to saucy yet, as software-center hasn't been updated there yet, and thus the Breaks: makes it uninstallable.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.6.0-0ubuntu4

---------------
software-center (5.6.0-0ubuntu4) saucy; urgency=low

  * debian/patches/saucy-known-series.patch: Add new patch to know about
    (Ubuntu) 'saucy', fixing FTBFS.

software-center (5.6.0-0ubuntu3) raring-proposed; urgency=low

  * debian/software-center.postinst:
    - Only run update-software-center if python-aptdaemon is configured,
      to avoid crashing on upgrade, and to work around Debian 671711.
      (LP: #1173249)
 -- Iain Lane <email address hidden> Wed, 01 May 2013 18:52:16 +0100

Changed in software-center (Ubuntu Saucy):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pygobject - 3.9.1-0ubuntu1

---------------
pygobject (3.9.1-0ubuntu1) saucy; urgency=low

  [ Martin Pitt ]
  * New upstream release.
  * Bump g-i and glib requirements according to configure.ac.

  [ Rodney Dawes ]
  * debian/control*:
    - Add Breaks for older python-aptdaemon and software-center to avoid
      potential crash casued by new python-gi with old python-aptdaemon,
      during upgrade of Ubuntu 12.10 to 13.04. (LP: #1173249)
 -- Martin Pitt <email address hidden> Wed, 01 May 2013 08:01:00 -0700

Changed in pygobject (Ubuntu Saucy):
status: Fix Committed → Fix Released

Hello Evan, or anyone else affected,

Accepted pygobject into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/pygobject/3.8.0-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pygobject (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in software-center (Ubuntu Raring):
status: Triaged → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Evan, or anyone else affected,

Accepted software-center into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.6.0-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of software-center from raring-proposed was performed and bug 1183182 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1183182 "bot-stop-nagging". Thanks!

tags: added: verification-failed
dobey (dobey) wrote :

That crash is certainly independent of this SRU. The crash in bug #1183182 appears to be the result of corrupted cache data or similar, causing Python to segfault when trying to load the data into memory.

tags: removed: verification-failed
Iain Lane (laney) on 2013-11-14
Changed in pygobject (Ubuntu Raring):
status: Fix Committed → Fix Released
dobey (dobey) on 2014-01-29
Changed in software-center (Ubuntu Raring):
assignee: Rodney Dawes (dobey) → nobody
tags: added: raring
dobey (dobey) on 2014-05-17
tags: removed: raring
Changed in software-center (Ubuntu Raring):
status: Fix Committed → Won't Fix
Mathew Hodson (mathew-hodson) wrote :

pygobject is released and software-center is won't fix for raring, so removing verification-needed tag.

tags: removed: verification-needed
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in aptdaemon (Ubuntu Quantal):
status: Triaged → Won't Fix
Rolf Leggewie (r0lf) on 2014-12-05
Changed in software-center (Ubuntu Quantal):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers