Hidden Microsoft ULA when installing Ubuntu Restricted Extras

Bug #1133107 reported by Ernie 07 on 2013-02-26
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
debconf (Ubuntu)
Medium
Unassigned
software-center (Ubuntu)
Medium
Unassigned

Bug Description

64-bit 3.8.0-7-generic #15-Ubuntu SMP Thu Feb 21 20:07:18 UTC 2013

1. Launch Unbuntu Software Center.
2. Begin installation of Ubuntu Restricted Extras.
3. Application will appear to hang after a while.
4. Popup displaying the Microsoft ULA is not being brought to the top so the app waits patiently for user input.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1133107/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → msttcorefonts (Ubuntu)
summary: - Hidden MicroSHAFT ULA when installing Ubuntu Restricted Extras
+ Hidden Microsoft ULA when installing Ubuntu Restricted Extras
description: updated
Brian Murray (brian-murray) wrote :

This is actually an issue with software-center as it is not presenting the debconf dialog in the foreground.

tags: added: raring
Changed in msttcorefonts (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
affects: msttcorefonts (Ubuntu) → software-center (Ubuntu)
tags: added: iso-testing
Ernie 07 (ernestboyd) wrote :

64-bit Desktop 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013

This bug has NOT been fixed and can be reproduced 100% of the time using the released version of Ubuntu 13.04
It may prove particularly vexing to those windoze users who may be trying Ubuntu for the first time and require restricted extras such as TrueType fonts.

To make matters worse, the file system will produce symptoms of corruption after a restart because Ubuntu 12.10 and 13.04 will NOT shut down properly if Enable Networking is checked and the connection to the ISP is via Ethernet. Those accustomed to a windoze environment will deal with the hanging problem (Waiting for the user to respond to the hidden ULA) via a restart.

Ernie 07 (ernestboyd) wrote :

YEA!

Fixed in 64-bit 1310 3.9.0-0-generic #4-Ubuntu SMP Thu May 2 21:43:59 UTC 2013

Ernie 07 (ernestboyd) wrote :

BROKEN in 64-bit 1310 3.11.0-5-generic #11-Ubuntu SMP Fri Sep 6 19:01:31 UTC 2013

Question mark is displayed in the launcher but the installation "appears" to be hung.

Someone unfamiliar with Unity might miss the question mark due to the ABUNDANCE of clutter.
EVERY partition on the drive containing the OS is locked to the launcher with no way to turn that behavior off.
What Ph.D on his FIRST work assignment designed that behavior?

Matthew Paul Thomas (mpt) wrote :

Ernie, that is one of the more creative insults I've seen in a bug report. Joking aside, though, it's obvious that nobody "designed that behavior". Nothing on the system knows that USC and the Debconf window are related to each other: USC doesn't, Debconf doesn't, and the window manager doesn't. So the window manager treats the Debconf window the same way as it would treat any other surprisingly-opening window, sometimes focusing it and sometimes not.

If you would like to help more constructively, you can consult the design <https://wiki.ubuntu.com/ErrorTracker#debconf> and guidelines for contributing. <https://wiki.ubuntu.com/ErrorTracker/Contributing/Debconf>

dino99 (9d9) wrote :

That version is no more maintained

Changed in software-center (Ubuntu):
status: Triaged → Invalid
Changed in debconf (Ubuntu):
status: New → Invalid
Adolfo Jayme (fitojb) on 2015-05-05
Changed in debconf (Ubuntu):
status: Invalid → Confirmed
importance: Undecided → Medium
Changed in software-center (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Triaged
dino99 (9d9) on 2015-05-05
tags: removed: raring
lolo (loloadam373) on 2017-07-24
Changed in debconf (Ubuntu):
status: Confirmed → Incomplete
Changed in software-center (Ubuntu):
status: Triaged → Incomplete
Changed in debconf (Ubuntu):
status: Incomplete → Confirmed
Changed in software-center (Ubuntu):
status: Incomplete → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers