Software Center hangs selecting Installed view

Bug #1118655 reported by Robert Thorneycroft on 2013-02-07
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
oneconf (Ubuntu)
Undecided
Unassigned
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

When selecting the 'Installed' button in Software Center on a fresh installation of the latest Daily build the application hangs and never returns any information to the screen.

I have investigated what the issue is by running the application from a terminal and I received the following output to the terminal when attempting to selected the 'Installed' button:

...
  File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 278, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /usr/share/oneconf/oneconf-service: Success

From this it seems the issue is related to oneconf being missing from the default installation. I ran the following and it resolved the problem with Software Center hanging:
 sudo apt-get install software-center oneconf

I think oneconf needs to be added into the default installation as without it the Software Center is non-functional.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Kelly Hyde (polarimetric) wrote :

I can confirm that installing oneconf resolves the issue.

tags: added: software-center
tags: added: ca-escalated
removed: software-center
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu):
status: New → Confirmed
DanielAttard (daniel-7) wrote :

I am also experiencing this bug of the Software Center hanging whenever I try to display the "Installed" tab. I tried to do:

sudo apt-get install software-center oneconf

But this reports that oneconf is already the newest version and software-center is already the newest version.

I continue to experience the hanging. Any idea what else I can try? Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers