package software-center 2.0.7 failed to install/upgrade: subprocess installed post-removal script returned error exit status 1

Bug #1055398 reported by Kenji Kikawada on 2012-09-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Software Center fails to start, even after a reinstall, and an uninstall/reinstall. Additionally, an error is encountered when I attempt to reinstall software-center.

~$software-center
Traceback (most recent call last):
  File "/usr/bin/software-center", line 78, in <module>
    from softwarecenter.app import SoftwareCenterApp
  File "/usr/share/software-center/softwarecenter/app.py", line 31, in <module>
    import xapian
ValueError: bad marshal data

~$sudo apt-get install software-center
...
Setting up software-center (2.0.7) ...
Traceback (most recent call last):
  File "/usr/sbin/update-software-center", line 29, in <module>
    import xapian
ValueError: bad marshal data
...

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: software-center 2.0.7
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
AptOrdering:
 ubuntu-desktop: Purge
 software-center: Purge
Architecture: i386
Date: Mon Sep 24 02:33:12 2012
ErrorMessage: subprocess installed post-removal script returned error exit status 1
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
PackageArchitecture: all
SourcePackage: software-center
Title: package software-center 2.0.7 failed to install/upgrade: subprocess installed post-removal script returned error exit status 1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers