RecoverableError dialog from software-center

Bug #1051829 reported by Akshar Patel on 2012-09-17
332
This bug affects 72 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt
Quantal
Undecided
Unassigned

Bug Description

TEST CASE:- regression test enough, install a application and verify that it still works

- for a real test you will have to get into a situation where there is a real transaction failure like logging into a system that has no policykit-authentication-agent running. this can be done via xfce and killall polkit-gnome-authentication-agent-1

(I'd imagine you could also install a package of bad quality (I believe Google Chrome is one based off another SRU I looked at today.) and inspect the .crash file in /var/crash to see what the DuplicateSignature looks like.)

REGRESSION POTENTIAL: low, this code is triggered if there is a error already, the point of it is to make it easier to detect the error class via errors.ubuntu.com

triggered when I started the computer.

ProblemType: RecoverableProblemDistroRelease: Ubuntu 12.10
Package: software-center 5.3.13
ProcVersionSignature: Ubuntu 3.5.0-14.19-generic 3.5.3
Uname: Linux 3.5.0-14-generic i686
ApportVersion: 2.5.1-0ubuntu7
Architecture: i386
Date: Mon Sep 17 12:04:09 2012
ExecutablePath: /usr/share/software-center/software-center
ExecutableTimestamp: 1347609407
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120912)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcCwd: /home/matang
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bashSourcePackage: software-center
Title: software-center crashed with in _run_transaction()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Akshar Patel (akshar-patel-47) wrote :
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
visibility: private → public
Carla Sella (carla-sella) wrote :

I was installing Google Talk plugin.

Occurred while installing a (bad quality package of ) CUPS Driver for Brother MultiFunctional

Hanine HAMZIOUI (hanynowsky) wrote :

Occured when installing deb of bad quality!

Hanine HAMZIOUI (hanynowsky) wrote :

Occured when installing deb of bad quality!
 Ubuntu 12.10 AMD64

To reproduce for me

Go to: http://www.skype.com/intl/en-us/get-skype/on-your-computer/linux/
Download Ubuntu 10.04 64bit
Run in software center
Install
"The package is of bad quality", click OK
Ignore and Install

The bug will happen when the bad package message comes up

Dennis van der Staal (dvdstaal) wrote :

trying to install aftershottpro (corel)

Msirdian (arena7) wrote :

i got this error report while installing skype

Ant Dickens (antonydickens) wrote :

I also experienced the crash when I received the installing a package of 'bad quality' dialogue. Whilst installing Opera-Next.

Linux 3.5.0-15-generic #23-Ubuntu 12.10 i686 GNU/Linux - Virtual Box on Mac Pro

Charles Lease (mellowchuck-y) wrote :

Occured when installing deb of "bad quality!"

Ubuntu 12.10 AMD64 Mac

Kernel Linux 3.5.0-16-generic

Daniel Lawrence (dannyla) wrote :

Occured when installing deb of "bad quality!" (dropbox)

Ubuntu 12.10 AMD64

Kernel Linux 3.5.0-16-generic

Occured when installing skype

Ubuntu 12.10 PC AMD64

Changed in software-center (Ubuntu):
assignee: nobody → Duong Tung Lam (duonglam966)
status: Confirmed → In Progress
tags: added: ca-escalated

I was installing Google Earth.

Gary Lasker (gary-lasker) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1041008, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: ca-escalated
Changed in software-center (Ubuntu):
status: In Progress → Confirmed
Gary Lasker (gary-lasker) wrote :

Changed to correct duplicate bug 1049000.

Installing packages from Humble Indie Bundle, each deb install crashed the installer.

David Pitkin (dpitkin) on 2012-10-02
tags: added: ca-escalated
Changed in software-center (Ubuntu):
importance: Medium → High
David Pitkin (dpitkin) on 2012-10-02
Changed in software-center (Ubuntu):
assignee: Duong Tung Lam (duonglam966) → Michael Vogt (mvo)
Dave Morley (davmor2) on 2012-10-02
Changed in software-center (Ubuntu):
importance: High → Critical
Michael Vogt (mvo) wrote :

From looking at the actual errors on http://errors.ubuntu.com this bug seems to conflate a bunch of independent issues:
- packages with incorrect dependencies failures (like this one)
- downloaded deb packages that lintian complains about

To reproduce you can do "software-center google-chrome-stable.deb" and it will appear

Occurred while installing a (bad quality package of ) CUPS Driver for Brother MultiFunctional

Michael Vogt (mvo) wrote :

Its worth noting that its of: "ProblemType: RecoverableProblem" something we added to gather data about what kind of transaction failure we see (most of which we ignore like lintian issue, size-calculation failures etc).

Gary Lasker (gary-lasker) wrote :

Hi mvo! Per your comment #18, I also noticed this and so when trying to triage about 15-20 or so duplicates of these two bugs yesterday I tried to organize those that correspond to failures in a debian package ("of bad quality") separated into bug 1041008.

But as you point out, errors.ubuntu.com appears to be funneling all of these types of failures to this current bug. Does it make sense at this point to just set bug 1041008 as duplicate of this one as well?

Thanks!

suspect76 (gareth-suspect76) wrote :

Same thing occured for me trying to download Teamviewer 7.0.9360 64 bit

Ubuntu: 12.10 Beta 2
Processor Intel® Core™2 Duo CPU E6550 @ 2.33GHz × 2

suspect76 (gareth-suspect76) wrote :

Also google chrome

Ubuntu: 12.10 Beta 2
Processor Intel® Core™2 Duo CPU E6550 @ 2.33GHz × 2

Giuseppe Fierro (gspe) wrote :

Occurred while installing a (bad quality package of ) google-chrome-stable and google-talk-plugin

I got this while trying to install ubuntu-tweak_0.7.3-1~precise1_all.deb

Peter Golden (peter-golden) wrote :

I got his error (bad quality package) during installing deb package for MoneyDance

Carla Sella (carla-sella) wrote :

It happened to me while trying to install skype downloading the .deb from skype's site and installing it with Software Center.

Michael Vogt (mvo) wrote :

Note that this error is a "recoverable error". I did look over the reports from errors.ubuntu.com and so far have:

lintian error: 97
generic dependency error (archive churn ? or custom PPAs?): 9

summary: - software-center crashed with in _run_transaction()
+ RecoverableError dialog from software-center
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.4

---------------
software-center (5.4) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp1044141:
    - fix unicode error crash on a transaction error
      (LP: #1044141)
  * lp:~mvo/software-center/fix-size-calc-race:
    - fix crash due to a race in the size calculation code
      in the details view (LP: #1041004)
  * lp:~mvo/software-center/fix-crash-1048886:
    - No longer call GLib.init_threads() as this will cause
      LP: #1048886 later. Many thanks to Albert Astals Cid
  * lp:~mvo/software-center/dbus-idle-timeout:
    - stop the dbus data provider after 5min of inactivity
      (LP: #1058567)
  * lp:~mvo/software-center/lp1051829:
    - Do not report deb packages with lintian errors via the
      recoverable errors mechanism. This removes 97 out of 104
      instances of my sample of the recoverable error report
      for LP: #1051829. Other types of failures will still be
      reported as recoverable failures though (as we do want
      to know about them).

  [ Gary Lakser ]
  * lp:~gary-lasker/software-center/lp1041004:
    - ensure that app_details is valid before using it (LP: #1041004)
  * lp:~gary-lasker/software-center/fix-crash-lp1021308:
    - send synthetic "style-updated" signals to ensure that the signal
      handlers are called on themes that do not send this signal (like
      oxygen-gtk3). This fixes a crash and broken drawing LP: #1021308

  [ Nicolas Delvaux ]
  * lp:~malizor/software-center/fix-lp1050036:
    - fix crash in get_label() (LP: #1050036) and drop the i18n for the
      yes/no symbols that were not translated in any language (as a result
      test_regression_lp1047281.py can also be dropped)
 -- Michael Vogt <email address hidden> Fri, 05 Oct 2012 10:58:20 +0200

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Michael Vogt (mvo) wrote :

Reopen for errors.ubuntu.com - this bug is a catchall bucket right now to see what issues people have when trying to install software.

Changed in software-center (Ubuntu):
status: Fix Released → Triaged
importance: Critical → High
Barry Morrison (basketcase) wrote :

Was installing Google's Chrome .deb pkg via Software Center.

Ubuntu 12.10 beta 2 64-bit

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.5.0

---------------
software-center (5.5.0) raring; urgency=low

  [ Andrew Hayzen ]
  * lp:~andrew-hayzen/software-center/accelerator-fix-lp744655:
    - fixes missing accelerator for a11y (LP: #744655)

software-center (5.4.1.3) UNRELEASED; urgency=low

  * lp:~mvo/software-center/fix-for-unusual-deb-lp1067634:
    - fix crash in deb packages without a description (LP: #1067634)
  * lp:~mvo/software-center/lp1009967:
    - fix the "top rated" display to match the spec by also showing
      the already installed items (LP: #1009967)
  * lp:~mvo/software-center/recoverable-errors-lp1051829:
    - send a custom duplicate signature so that the recoverable errors
      on transaction failures are broken down by error_code instead
      of all put into the same bucket (LP: #1051829)
 -- Michael Vogt <email address hidden> Mon, 05 Nov 2012 13:56:26 +0100

Changed in software-center (Ubuntu):
status: Triaged → Fix Released

I could not make out whether problem python 2.7.3 is solved?

On Mon, Nov 5, 2012 at 7:37 PM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package software-center - 5.5.0
>
> ---------------
> software-center (5.5.0) raring; urgency=low
>
> [ Andrew Hayzen ]
> * lp:~andrew-hayzen/software-center/accelerator-fix-lp744655:
> - fixes missing accelerator for a11y (LP: #744655)
>
> software-center (5.4.1.3) UNRELEASED; urgency=low
>
> * lp:~mvo/software-center/fix-for-unusual-deb-lp1067634:
> - fix crash in deb packages without a description (LP: #1067634)
> * lp:~mvo/software-center/lp1009967:
> - fix the "top rated" display to match the spec by also showing
> the already installed items (LP: #1009967)
> * lp:~mvo/software-center/recoverable-errors-lp1051829:
> - send a custom duplicate signature so that the recoverable errors
> on transaction failures are broken down by error_code instead
> of all put into the same bucket (LP: #1051829)
> -- Michael Vogt <email address hidden> Mon, 05 Nov 2012 13:56:26
> +0100
>
> ** Changed in: software-center (Ubuntu)
> Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1052563).
> https://bugs.launchpad.net/bugs/1051829
>
> Title:
> RecoverableError dialog from software-center
>
> Status in “software-center” package in Ubuntu:
> Fix Released
>
> Bug description:
> triggered when I started the computer.
>
> ProblemType: RecoverableProblem
> DistroRelease: Ubuntu 12.10
> Package: software-center 5.3.13
> ProcVersionSignature: Ubuntu 3.5.0-14.19-generic 3.5.3
> Uname: Linux 3.5.0-14-generic i686
> ApportVersion: 2.5.1-0ubuntu7
> Architecture: i386
> Date: Mon Sep 17 12:04:09 2012
> ExecutablePath: /usr/share/software-center/software-center
> ExecutableTimestamp: 1347609407
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120912)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/software-center
> ProcCwd: /home/matang
> ProcEnviron:
> LANGUAGE=en_IN:en
> PATH=(custom, no user)
> LANG=en_IN
> SHELL=/bin/bash
> SourcePackage: software-center
> Title: software-center crashed with in _run_transaction()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1051829/+subscriptions
>

Michael Vogt (mvo) on 2012-11-22
description: updated
Michael Vogt (mvo) on 2012-11-28
Changed in software-center (Ubuntu Quantal):
status: New → In Progress

Hello Akshar, or anyone else affected,

Accepted software-center into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.4.1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in software-center (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Worked fine. Also installed Chrome via a .deb, although that doesn't generate a crash anymore as the python-dbus bug got fixed.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.4.1.3

---------------
software-center (5.4.1.3) quantal-proposed; urgency=low

  * lp:~mvo/software-center/fix-for-unusual-deb-lp1067634:
    - fix crash in deb packages without a description (LP: #1067634)
  * lp:~mvo/software-center/lp1009967:
    - fix the "top rated" display to match the spec by also showing
      the already installed items (LP: #1009967)
  * lp:~mvo/software-center/recoverable-errors-lp1051829:
    - send a custom duplicate signature so that the recoverable errors
      on transaction failures are broken down by error_code instead
      of all put into the same bucket (LP: #1051829)
  * lp:~mvo/software-center/5.4-fix-threading
    - Properly init threads now that the pygobject crash is fixed.
      This will fix the slow and unreliable submit of reviews
      (LP: #1083694)
 -- Michael Vogt <email address hidden> Wed, 28 Nov 2012 09:31:41 +0100

Changed in software-center (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu Quantal):
assignee: nobody → Deepak Dahiya (dapsdahiya)
dobey (dobey) on 2013-04-26
Changed in software-center (Ubuntu Quantal):
assignee: Deepak Dahiya (dapsdahiya) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers