software-center doesn't display all apps on a fresh install

Bug #1050594 reported by Dave Morley on 2012-09-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

I've done manual updates and restarted the machine and software-center serveral times.

When starting USC from the terminal I get the following:

davmor2@stryder:~$ software-center
2012-09-13 21:01:58,073 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-09-13 21:01:58,081 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-09-13 21:01:58,082 - softwarecenter.db.database - ERROR - failed to add apt-xapian-index
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/database.py", line 183, in _get_new_xapiandb
    softwarecenter.paths.APT_XAPIAN_INDEX_DB_PATH)
  File "/usr/lib/python2.7/dist-packages/xapian/__init__.py", line 3666, in __init__
    _xapian.Database_swiginit(self,_xapian.new_Database(*args))
DatabaseOpeningError: Couldn't stat '/var/lib/apt-xapian-index/index' (No such file or directory)

(software-center:2506): Gtk-WARNING **: Theme parsing error: softwarecenter.css:34:20: Not using units is deprecated. Assuming 'px'.

(software-center:2506): Gtk-WARNING **: Theme parsing error: softwarecenter.css:34:22: Not using units is deprecated. Assuming 'px'.

(software-center:2506): Gtk-WARNING **: Theme parsing error: softwarecenter.css:56:20: Not using units is deprecated. Assuming 'px'.

(software-center:2506): Gtk-WARNING **: Theme parsing error: softwarecenter.css:56:22: Not using units is deprecated. Assuming 'px'.

(software-center:2506): Gtk-WARNING **: Theme parsing error: softwarecenter.css:60:20: Not using units is deprecated. Assuming 'px'.

(software-center:2506): Gtk-WARNING **: Theme parsing error: softwarecenter.css:60:22: Not using units is deprecated. Assuming 'px'.
2012-09-13 21:01:58,133 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.Geoclue.Error.notAvailable: Geoclue master client has no usable Address providers'
2012-09-13 21:01:58,373 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-09-13 21:01:58,381 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2012-09-13 21:01:58,381 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2012-09-13 21:01:58,500 - softwarecenter.ui.gtk3.app - INFO - show_available_packages: search_text is '', app is None.
2012-09-13 21:01:58,511 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2012-09-13 21:01:59,615 - softwarecenter.db.categories - WARNING - sort by cataloged time requested but your a-x-i does not seem to support that yet
2012-09-13 21:02:03,227 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
2012-09-13 21:02:03,228 - softwarecenter.db.database - INFO - reopen() database
2012-09-13 21:02:03,228 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-09-13 21:02:03,233 - softwarecenter.db.database - ERROR - failed to add apt-xapian-index
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/database.py", line 183, in _get_new_xapiandb
    softwarecenter.paths.APT_XAPIAN_INDEX_DB_PATH)
  File "/usr/lib/python2.7/dist-packages/xapian/__init__.py", line 3666, in __init__
    _xapian.Database_swiginit(self,_xapian.new_Database(*args))
DatabaseOpeningError: Couldn't stat '/var/lib/apt-xapian-index/index' (No such file or directory)
2012-09-13 21:02:03,258 - softwarecenter.db.database - ERROR - failed to add apt-xapian-index
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/database.py", line 183, in _get_new_xapiandb
    softwarecenter.paths.APT_XAPIAN_INDEX_DB_PATH)
  File "/usr/lib/python2.7/dist-packages/xapian/__init__.py", line 3666, in __init__
    _xapian.Database_swiginit(self,_xapian.new_Database(*args))
DatabaseOpeningError: Couldn't stat '/var/lib/apt-xapian-index/index' (No such file or directory)
No handlers could be found for logger "softwarecenter.db.database"

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: software-center 5.3.12
ProcVersionSignature: Ubuntu 3.5.0-14.16-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
Date: Thu Sep 13 21:04:05 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120913.3)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Dave Morley (davmor2) wrote :
Changed in software-center (Ubuntu):
importance: Undecided → High
Dave Morley (davmor2) wrote :

It's also not displaying the what's new section I'm assuming due to the db issues.

Dave Morley (davmor2) wrote :

(process:2385): GLib-GIO-WARNING **: Missing callback called fullpath = /var/lib/apt-xapian-index/update-timestamp

(software-center:2347): GLib-GIO-WARNING **: Missing callback called fullpath = /var/lib/apt-xapian-index/update-timestamp

Dave Morley (davmor2) wrote :

There is a possibility that .13 fixed this issue, I will endeavour to ensure that the iso update has this version on it and try a fresh install over the weekend

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :

The above was taken on Sunday from a fresh 64bit install

tags: added: ca-escalated
Michael Vogt (mvo) on 2012-09-17
Changed in software-center (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

The apt-xapian-index is missing on a fresh install, that is why there is no whats-new information its a bit odd that this is only happening on amd64 and not on i386. To simulate this, you can move away /var/lib/apt-xapian-index/values

Michael Vogt (mvo) wrote :

For me, this is happening on the fresh i386 install as well (which is good).

Johan (oortjies) wrote :

Gents, I am having similar problem, here is my printout when started with terminal.
 ~$ software-center
2012-09-26 08:25:19,961 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-09-26 08:25:20,021 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True

(software-center:4266): Gtk-WARNING **: Theme parsing error: softwarecenter.css:34:20: Not using units is deprecated. Assuming 'px'.

(software-center:4266): Gtk-WARNING **: Theme parsing error: softwarecenter.css:34:22: Not using units is deprecated. Assuming 'px'.

(software-center:4266): Gtk-WARNING **: Theme parsing error: softwarecenter.css:56:20: Not using units is deprecated. Assuming 'px'.

(software-center:4266): Gtk-WARNING **: Theme parsing error: softwarecenter.css:56:22: Not using units is deprecated. Assuming 'px'.

(software-center:4266): Gtk-WARNING **: Theme parsing error: softwarecenter.css:60:20: Not using units is deprecated. Assuming 'px'.

(software-center:4266): Gtk-WARNING **: Theme parsing error: softwarecenter.css:60:22: Not using units is deprecated. Assuming 'px'.
2012-09-26 08:25:20,602 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Geoclue.Master was not provided by any .service files'
2012-09-26 08:25:21,616 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-09-26 08:25:21,639 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2012-09-26 08:25:21,639 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2012-09-26 08:25:21,811 - softwarecenter.ui.gtk3.app - INFO - show_available_packages: search_text is '', app is None.
2012-09-26 08:25:21,813 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2012-09-26 08:25:23,200 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2012-09-26 08:25:23,200 - root - ERROR - Could not find any typelib for Gst

Roberto Alsina (ralsina) on 2013-01-22
Changed in software-center (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
dobey (dobey) on 2014-01-29
Changed in software-center (Ubuntu):
assignee: Rodney Dawes (dobey) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers