Software center shows multiple entries for banshee & rhythmbox

Bug #1049835 reported by Adam Bruce
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
app-install-data-ubuntu (Ubuntu)
Fix Released
Undecided
Unassigned
software-center (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

To reproduce banshee entries:

- Open software center
- Search 'Banshee'

Result: Three entries for Banshee, all the same. Installing one of them shows an install progress bar for them all. See screenshot

To reproduce Rhythmbox entries:

- Open software center
- Search 'Rhythmbox'

Result: Two entries for Rythmbox

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: software-center 5.3.12
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
Date: Wed Sep 12 14:57:02 2012
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to quantal on 2012-09-09 (2 days ago)

Revision history for this message
Adam Bruce (brucey-99-deactivatedaccount) wrote :
Revision history for this message
Kiwinote (kiwinote) wrote :

This is because app-install-data ships multiple desktop files per pkgname:

$ ls /usr/share/app-install/desktop | grep rhythmbox:
rhythmbox:rhythmbox.desktop
rhythmbox:rhythmbox-device.desktop
$ ls /usr/share/app-install/desktop | grep banshee:
banshee:banshee-audiocd.desktop
banshee:banshee.desktop
banshee:banshee-media-player.desktop

Either app-install-data should restrict itself to one desktop file per pkgname, or s-c should enforce this.

Changed in app-install-data-ubuntu (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
status: New → Confirmed
Revision history for this message
Robert Roth (evfool) wrote :

The same bug is reported for "Files", aka nautilus in bug #1068444. The problem is not the fact that there are more desktop files from the same package, but that there are multiple ones without NoDisplay=true set. E.g. for nautilus out of the five, three have NoDisplay set, but the remaining two cause nautilus to be displayed twice.

I don't agree with enforcing only one desktop file/package neither on app-install-data, nor on software-center side, as there are apps which ship more gui applications (like gtk and qt version of the GUI in the same package, or different GUI apps in one package).

Rhythmbox is strange, as it has two desktop entries, but for rhythmbox-device NoDisplay is set, but still, it is displayed. I guess desktop entries with NoDisplay set shouldn't be shown in software-center, but that needs some confirmation.

Revision history for this message
Adam Bruce (brucey-99-deactivatedaccount) wrote :

Should we just dup these into one bug report and just list the effected applications? bug 1068444 & bug 999204

Revision history for this message
Ma Hsiao-chun (mahsiaochun) wrote :
no longer affects: hundredpapercuts
Changed in software-center (Ubuntu):
status: Confirmed → Invalid
Changed in app-install-data-ubuntu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers