First startup: Lobby view layout issues

Bug #1044033 reported by Dave Morley on 2012-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

Bug Description:
There is no What's new section on initial startup so the empty recommender box fills the bulk of the lobby landing page.
If you enable recommends it only ever allow 9 apps to appear meaning the bulk remains empty still.

SCA Version:
n/a

OS:
64bit Quantal

USC Version:
5.3.10

Steps To Reproduce:
1. Do a fresh install
2. Open USC

Expected Results:
I expect that the whole of the space would fill with apps or that the What's new section would be there even if it is empty on intial startup or that the lobby recommender window remained a fixed size.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: software-center 5.3.10
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu3
Architecture: amd64
Date: Thu Aug 30 17:44:41 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120830)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Dave Morley (davmor2) wrote :
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Michael Vogt (mvo) on 2012-09-03
tags: added: ca-escalated
Changed in software-center (Ubuntu):
status: New → Confirmed
assignee: nobody → Gary Lasker (gary-lasker)
Gary Lasker (gary-lasker) wrote :

This is a visual side-effect after we swapped the locations of the Top Rated and Recommended For You panels, and it's due to the fact that the Recommended for You panel resizes after its loaded, and the upper Box area doesn't handle it well. This should be fairly straightforward to fix.

Gary Lasker (gary-lasker) wrote :

Ignore my previous comment, it refers to a visual glitch on startup and not to the specific symptoms described by Dave in this bug.

summary: - Software centers lobby page is ugly on initial startup
+ First startup: Lobby view layout issues
Changed in software-center (Ubuntu):
importance: Medium → Low
assignee: Gary Lasker (gary-lasker) → nobody
Michael Vogt (mvo) wrote :

Gary and I discussed this today and one suggesiton was to use the space for the "our favorites" until there is data for "whats new" available.

Michael Vogt (mvo) wrote :

This really looks like a deeper problem with the CD install, it appears that the complete apt-xapian-index is missing which causes the lack of whats-new data. I am doing a fresh install to verify and will ask the distro for help if that is the case.

Michael Vogt (mvo) on 2012-09-27
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.14.3

---------------
software-center (5.3.14.3) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/downloader-fix-race839462-again:
    - fix a race condition in the SimpleFileDownloader when the file
      is downloaded but the signal did not get delivered yet by the
      gtk event loop (LP: #1055441)
  * lp:~mvo/software-center/thumbnail-test-fixes:
    - fix the get_test_screenshot_thumbnail_window() function and
      ensure that its properly used in the automatic test
  * lp:~mvo/software-center/support-multiple-exhibit-images:
    - add support for multiple images in the exhibit banners
      (LP: #920542)
  * lp:~mvo/software-center/robustness-lp1054070:
    - extends the recovery mechanism for corrupted berkeley
      DB files to MemoryErrors as well to catch LP: #1054070
  * lp:~mvo/software-center/whats-new-lp1044033:
    - ensure that there is a fallback xapian value that can be
      used if the apt-xapian-index has not been created
      (LP: #1044033)
  * lp:~mvo/software-center/exact-match-duplication-lp891613:
    - fix the duplication of packages during a search if there
      is an exact pkgname match in the apt-xapian-index and
      also in the software-center-agent (LP: #891613)
  * lp:~mvo/software-center/lp1047494:
    - fix AttributeError crash in _on_reviews_ready_callback()
      (LP: #1047494)
  * lp:~mvo/software-center/de-duplication-multiple-pkgnames-lp1043159:
    - fix duplication for multiple package lists (LP: #1043159)

  [ Stéphane Graber ]
  * lp:~stgraber/software-center/fix-weblive-isinstance:
    - sync weblive_pristine.py to the latest upstream version,
      this includes porting to be pep8 and python 3 ready and
      restores correct weblive operation

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/de-duplication-multiple-pkgnames-lp1043159-tweak
    - pass DB to the recommendations categories
 -- Michael Vogt <email address hidden> Tue, 02 Oct 2012 10:02:51 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers