software-center crashed with TypeError in call_async(): Don't know which D-Bus type to use to encode type "NoneType"

Bug #1043752 reported by Ozgur Kucuktekin on 2012-08-30
94
This bug affects 17 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Test case:
- Launch the software-center
- Double-click on a deb file inside a unicode-named folder (such as "ää")

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: software-center 5.3.9
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.5.1-0ubuntu3
Architecture: i386
CrashCounter: 1
Date: Mon Aug 27 18:56:27 2012
ExecutablePath: /usr/share/software-center/software-center
ExecutableTimestamp: 1345734396
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center /home/username/İndirilenler/nvidia-current-dev_304.32-0ubuntu4_i386.deb
ProcCwd: /home/ozgur
ProcEnviron:
 PATH=(custom, no user)
 LANG=tr_TR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', '/home/username/\xc4\xb0ndirilenler/nvidia-current-dev_304.32-0ubuntu4_i386.deb']
SourcePackage: software-center
Title: software-center crashed with TypeError in call_async(): Don't know which D-Bus type to use to encode type "NoneType"
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Ozgur Kucuktekin (ozgurktekin) wrote :
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

I can reproduce this with:
$ mkdir /tmp/ää
$ cd /tmp/ää
$ apt-get download 2vcard
$ software-center /tmp/ää/2vcard*.deb
this will also give me a crash.

visibility: private → public
Igor Zubarev (igor.zubarev) wrote :

I can't install Google Chrome amd 64 deb if I place it in Desktop folder. I think problem with cyrillic name of Desktop folder as "Рабочий стол". If I remove deb file to home directory it installs ok.

Igor Zubarev (igor.zubarev) wrote :

I tryed to install google-chrome-beta_current_amd64.deb

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
sisou666 (sisou666) wrote :

j'ai besoin de skype pour pouvoir continué a beneficié des avantage de la liaison entre famille par tous dans le monde

John Kim (kotux) wrote :

커롬이 잘 안도라가내...

boivin (yboivin1) on 2012-10-02
Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Gary Lasker (gary-lasker) wrote :

This one's not actually fixed released as it is still appearing on errors.ubuntu.com.

Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
Nicolas Delvaux (malizor) wrote :

There are actually 2 bugs.

- LP: #1058038 installation of a def file inside a unicode-named folder crash
- This bug : when double clicking on a deb file inside of a unicode-named folder *when software-center is already launched*, an error appears (before even clicking on install)

description: updated
walterclozet (walterclozet-u) wrote :

I can't install Google Chrome amd 64 deb if I place it in Desktop folder. I think problem with cyrillic name of Desktop folder as "桌面".

Michael Vogt (mvo) wrote :

I can reproduce this with:
$ mkdir /tmp/äää
$ (cd /tmp/äää ; apt-get download 2vcard)
$ software-center /tmp/äää/2vcard*.deb

click on "install" and authenticate:

2012-10-08 10:21:14,318 - softwarecenter.backend - ERROR - error in _on_trans_finished 'Error: An unhandled error occured
There seems to be a programming error in aptdaemon. This is the software that allows you to install/remove software and to perform other package management related tasks.

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/aptdaemon/worker.py", line 1181, in _simulate
    trans.unauthenticated, trans.high_trust_packages = self.__simulate(trans)
  File "/usr/lib/python3/dist-packages/aptdaemon/worker.py", line 1239, in __simulate
    deb = self.install_file(trans, simulate=True, **trans.kwargs)
  File "/usr/lib/python3/dist-packages/aptdaemon/worker.py", line 740, in install_file
    deb = self._check_deb_file(trans, path, force)
  File "/usr/lib/python3/dist-packages/aptdaemon/worker.py", line 1326, in _check_deb_file
    if not os.path.isfile(path):
  File "/usr/lib/python3.2/genericpath.py", line 29, in isfile
    st = os.stat(path)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 5-7: ordinal not in range(128)
'

Nicolas Delvaux (malizor) wrote :

@Michael Vogt: you reproduced LP: #1058038, not this one.

To reproduce this particular bug, launch the software-center and then double click on the deb file you just downloaded in /tmp/äää.

This is not the same bug because the "workaround" I proposed for LP: #1058038 (launching aptd from the command line) does not workaround this one. And backtraces are diffrent.

Michael Vogt (mvo) wrote :

Ignore my previous comment, its for #1058038

To reproduce this one:
$ mkdir /tmp/äää
$ (cd /tmp/äää ; apt-get download 2vcard)
$ software-center
[wait until its open]
[in a different terminal:
$ software-center /tmp/äää/2vcard*.deb

The attached branch lp:~mvo/software-center/lp1043752 fixes this.

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.4.1

---------------
software-center (5.4.1) quantal; urgency=low

  * lp:~mvo/software-center/lp1043752:
    - Fix crash when using a unicode path to open deb file (LP: #1043752)
  * lp:~mvo/software-center/lp1063595:
    - add missing "trans" initializations (LP: #1063595)
 -- Michael Vogt <email address hidden> Tue, 09 Oct 2012 09:12:43 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Matthias Gehre (m-gehre) wrote :

I just encountered this bug today. (At least apport tells me that it is exactly this bug.)
I'm not aware of any unicode issue, though, and I'm running latest raring
with software-center 5.6.0-0ubuntu2.

tags: added: raring
ROCHE (guyroche08-6) wrote :

by installing update of virtualbox version : virtualbox-4.3_4.3.10-93012~Ubuntu~raring_amd64.deb

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers