Software Center shows duplicate packages

Bug #1043159 reported by David Planella on 2012-08-29
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Developer registration portal
Undecided
Unassigned
software-center (Ubuntu)
Medium
Michael Vogt

Bug Description

After clicking the "Ubuntu App Showdown winners" banner currently shown on the Software Center, I would expect it to take me to a page where the 3 winners (lightread, fogger, picsaw) are shown.

However, 6 results are displayed (a duplicate for each winner entry) - see the attached screenshot.

A couple of notes:

- The duplicates go away if I click on the "Hide 3 technical items" link
- All 3 apps have been published to extras.ubuntu.com by the App Review Board (ARB)
- In comparison with commercial apps in MyApps, there is no PPA publishing for ARB apps. Actually, there is in fact, but it's decoupled from MyApps: the source packages are manually uploaded to the ARB PPA, and then they are copied to extras in an hourly cron job
- The ARB PPA is not enabled on my system

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.2.5
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Wed Aug 29 10:46:46 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110319)
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

David Planella (dpm) wrote :
David Planella (dpm) on 2012-08-29
tags: added: arb
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Dave Morley (davmor2) on 2012-08-29
tags: added: ca-escalated
Michael Vogt (mvo) on 2012-09-03
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Anthony Lenton (elachuni) wrote :

Marked as invalid on the server. Looking into this it seems to be a client-side only issue.

Changed in developer-portal:
status: New → Invalid
Michael Vogt (mvo) wrote :

This bug has a similar root cause as #891613 I think.

Michael Vogt (mvo) wrote :

To reproduce this on quantal you will have to add:
$ echo "deb http://extras.ubuntu.com/ubuntu/ precise main" >> /etc/apt/sources.list
$ sudo apt-get update
$ sudo update-apt-xapian-index
$ SOFTWARE_CENTER_DISTRO_CODENAME=precise ./software-center

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.14.3

---------------
software-center (5.3.14.3) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/downloader-fix-race839462-again:
    - fix a race condition in the SimpleFileDownloader when the file
      is downloaded but the signal did not get delivered yet by the
      gtk event loop (LP: #1055441)
  * lp:~mvo/software-center/thumbnail-test-fixes:
    - fix the get_test_screenshot_thumbnail_window() function and
      ensure that its properly used in the automatic test
  * lp:~mvo/software-center/support-multiple-exhibit-images:
    - add support for multiple images in the exhibit banners
      (LP: #920542)
  * lp:~mvo/software-center/robustness-lp1054070:
    - extends the recovery mechanism for corrupted berkeley
      DB files to MemoryErrors as well to catch LP: #1054070
  * lp:~mvo/software-center/whats-new-lp1044033:
    - ensure that there is a fallback xapian value that can be
      used if the apt-xapian-index has not been created
      (LP: #1044033)
  * lp:~mvo/software-center/exact-match-duplication-lp891613:
    - fix the duplication of packages during a search if there
      is an exact pkgname match in the apt-xapian-index and
      also in the software-center-agent (LP: #891613)
  * lp:~mvo/software-center/lp1047494:
    - fix AttributeError crash in _on_reviews_ready_callback()
      (LP: #1047494)
  * lp:~mvo/software-center/de-duplication-multiple-pkgnames-lp1043159:
    - fix duplication for multiple package lists (LP: #1043159)

  [ Stéphane Graber ]
  * lp:~stgraber/software-center/fix-weblive-isinstance:
    - sync weblive_pristine.py to the latest upstream version,
      this includes porting to be pep8 and python 3 ready and
      restores correct weblive operation

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/de-duplication-multiple-pkgnames-lp1043159-tweak
    - pass DB to the recommendations categories
 -- Michael Vogt <email address hidden> Tue, 02 Oct 2012 10:02:51 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers