Ubuntu

software center is not able to find many server packages

Reported by Sasa Paporovic on 2012-07-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

The software center search function is not able to find server related packages.

For example you can give "apache2" to the search field and see that there will come up no hits.
Or try "phpmyadmin" for database administration.

This can be done with all packages that goes in a more administrativ/profesional sector of the system.

So, in moment software-center is for those people not a alternative to synaptic package manager, which has a much more advanced search function, or command line.

You can see this as wish and mark as such.

Stack trace showing a xapian error in the attached SoftwareCenterLog.txt:

Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/database.py", line 183, in _get_new_xapiandb
    softwarecenter.paths.APT_XAPIAN_INDEX_DB_PATH)
  File "/usr/lib/python2.7/dist-packages/xapian/__init__.py", line 3666, in __init__
    _xapian.Database_swiginit(self,_xapian.new_Database(*args))
DatabaseOpeningError: Couldn't stat '/var/lib/apt-xapian-index/index' (No such file or directory)
2012-07-16 13:35:50,377 - softwarecenter.db.database - ERROR - failed to add apt-xapian-index
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/database.py", line 183, in _get_new_xapiandb
    softwarecenter.paths.APT_XAPIAN_INDEX_DB_PATH)
  File "/usr/lib/python2.7/dist-packages/xapian/__init__.py", line 3666, in __init__
    _xapian.Database_swiginit(self,_xapian.new_Database(*args))
DatabaseOpeningError: Couldn't stat '/var/lib/apt-xapian-index/index' (No such file or directory)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: software-center 5.3.4
ProcVersionSignature: Ubuntu 3.5.0-4.4-generic 3.5.0-rc6
Uname: Linux 3.5.0-4-generic x86_64
ApportVersion: 2.3-0ubuntu4
Architecture: amd64
Date: Mon Jul 16 13:40:47 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120715.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no username)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Sasa Paporovic (melchiaros) wrote :
Gary Lasker (gary-lasker) wrote :

Hello mechaiaros, and thank you for your report. I actually just tried this myself and I cannot reproduce what you are seeing. For both search cases, I see the correct result appear in the list.

However, looking at your attached SoftwareCenterLog.txt, I can see the following error reported. This would explain why searching for software items will not work correctly. Does the problem persist after you stop and restart Software Center?

Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/database.py", line 183, in _get_new_xapiandb
    softwarecenter.paths.APT_XAPIAN_INDEX_DB_PATH)
  File "/usr/lib/python2.7/dist-packages/xapian/__init__.py", line 3666, in __init__
    _xapian.Database_swiginit(self,_xapian.new_Database(*args))
DatabaseOpeningError: Couldn't stat '/var/lib/apt-xapian-index/index' (No such file or directory)
2012-07-16 13:35:50,377 - softwarecenter.db.database - ERROR - failed to add apt-xapian-index
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/database.py", line 183, in _get_new_xapiandb
    softwarecenter.paths.APT_XAPIAN_INDEX_DB_PATH)
  File "/usr/lib/python2.7/dist-packages/xapian/__init__.py", line 3666, in __init__
    _xapian.Database_swiginit(self,_xapian.new_Database(*args))
DatabaseOpeningError: Couldn't stat '/var/lib/apt-xapian-index/index' (No such file or directory)

description: updated
Changed in software-center (Ubuntu):
status: New → Incomplete
summary: - software center is not able to find many server packages
+ software center is not able to find many server packages -
+ DatabaseOpeningError: Couldn't stat '/var/lib/apt-xapian-index/index'
+ (No such file or directory)

Hi Gary,

I have already retested it with the latest updates yesterday evening. The apache search was working, the phpmyadmin not.

Today both are working.

So the problem itself seems to be gone.

I bring the system now to the latest upgrade level and retry it one more time to be sure.

Anyway, the search function is still not so advanced as with synaptics and it would be beneficial to get some improvements on.

Sasa Paporovic (melchiaros) wrote :

Have retested in with the upgraded system.

For phpmyadmin it is completely gone.

Apache is different.

When I use the phrase "apache" Software-Center is not able to find the apache server.

When I use the phrase "apache2" it is able to find the server.

This is overspecific for a search function.

I have failed on this also in the past. Who would think of the 2 at the end of apache?!

Changed in software-center (Ubuntu):
status: Incomplete → New
Gary Lasker (gary-lasker) wrote :

Hi again melchiaros, and thank you for reporting back. I still cannot reproduce this on my Quantal install. In both searches, the correct results are returned. By your comments as well, it seems that this isn't a consistent issue. Possibly this is a result of early development cycle archive churn. I think we close this and then revisit this situation around beta time to see if this has settled out, and if it has not we can reopen this then or just write a new report.

Thanks very much for your help!
Gary

Changed in software-center (Ubuntu):
status: New → Invalid
Sasa Paporovic (melchiaros) wrote :

o.K then. Late beta. I will keep in mind(I hope).

Changed in software-center (Ubuntu):
status: Invalid → New
Sasa Paporovic (melchiaros) wrote :

Hi Gary,

a little late(have forgotten to recheck).

The think with the "apache" is persistant.

Also some other software is not easy to find with software-center as the latest tries has shown( e.g as non server packages "LiVE", which should point to "LiVES", but do not - in first place).

So, the search functionality of SoftwareCenter is still ... "not so good as it could be".
------------------------------------------------

The stacktrace listed above seems not be related to the topic of this report, but by accident I have runned in report:

https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1066539

where this trace occures.

summary: - software center is not able to find many server packages -
- DatabaseOpeningError: Couldn't stat '/var/lib/apt-xapian-index/index'
- (No such file or directory)
+ software center is not able to find many server packages
tags: added: precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions