software-center crashed with AttributeError in _on_show_exhibits(): 'FeaturedExhibit' object has no attribute 'click_url'

Bug #1023777 reported by Hendrik Knackstedt on 2012-07-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

Did do nothing special. Just clicked on it I think.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: software-center 5.3.4
ProcVersionSignature: Ubuntu 3.5.0-4.4-generic 3.5.0-rc6
Uname: Linux 3.5.0-4-generic i686
ApportVersion: 2.3-0ubuntu4
Architecture: i386
Date: Thu Jul 12 10:06:42 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120629)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in _on_show_exhibits(): 'FeaturedExhibit' object has no attribute 'click_url'
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/ui/gtk3/views/catview_gtk.py", line 332, in _on_show_exhibits
     url = exhibit.click_url
 AttributeError: 'FeaturedExhibit' object has no attribute 'click_url'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Revision history for this message
Hendrik Knackstedt (hennekn) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Revision history for this message
Gary Lasker (gary-lasker) wrote :

Hi Hendrik, and thanks for your report! I have been trying to find a way to reproduce this, but cannot. It seems maybe you clicked on a banner very soon after startup of Software Center. Is that correct?

Could you please try again and see if this problem is persisting for you? If anything, it should be only transient, but if it persists that would be very useful to know as well.

Thank you very much for your help!
Gary

Changed in software-center (Ubuntu):
status: New → Incomplete
Revision history for this message
Gary Lasker (gary-lasker) wrote :

Meanwhile I'll attach a branch that should fix the issue should it be needed. Thanks again!

Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
importance: Undecided → Low
status: Incomplete → In Progress
Revision history for this message
Hendrik Knackstedt (hennekn) wrote :

Hm … I got the crash again, doing the following: Running software updater, opening USC, clicking on banner for "star apps", clicking on "History", clicking on "Installed" -> Error Message says USC crashed

However, this time and last time, USC's window actually wasn't closed but only the error message appears. USC works properly without any restrictions and without restarting it.

I think first time it crashed I was also running software updater but I'm not sure.

Michael Vogt (mvo) on 2012-07-13
Changed in software-center (Ubuntu):
importance: Low → Medium
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
nameremoved (errorwhywhywhy-deactivatedaccount) wrote :

I have experenced this bug. The software centre does this also without activity.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.5

---------------
software-center (5.3.5) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/hopefully-fix-lp1008229:
    - fix crash that can happen if there is an error while
      opening a deb file (LP: #1008229)
  * lp:~mvo/software-center/fix-lp1023777:
    - initialize the 'click_url' attribute to fix a crash when
      clicking on the default 'featured' exhibit (LP: #1023777)
  * merge in the 5.2.5 fixes from stable

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-lp1023336:
   - fix spelling error in the hardware requirements detection
     message for an attached mouse (LP: #1023336)
 -- Michael Vogt <email address hidden> Fri, 20 Jul 2012 08:19:51 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers