software-center crashed with AttributeError in do_draw(): 'PackageStatusBar' object has no attribute '_border_width'

Bug #1021308 reported by bk on 2012-07-05
84
This bug affects 18 people
Affects Status Importance Assigned to Milestone
oxygen-gtk3 (Ubuntu)
Undecided
Unassigned
software-center (Ubuntu)
High
Gary Lasker

Bug Description

Ubuntu 12.10 beta

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: software-center 5.3.1
ProcVersionSignature: Ubuntu 3.5.0-1.1-generic 3.5.0-rc3
Uname: Linux 3.5.0-1-generic i686
ApportVersion: 2.2.5-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Thu Jul 5 16:41:52 2012
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120606.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center yorick-cubeview/Cubeview
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
PythonArgs: ['/usr/bin/software-center', 'yorick-cubeview/Cubeview']
SourcePackage: software-center
Title: software-center crashed with AttributeError in do_draw(): 'PackageStatusBar' object has no attribute '_border_width'
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py", line 116, in do_draw
     width = self._border_width
 AttributeError: 'PackageStatusBar' object has no attribute '_border_width'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

bk (kurlowiczbogu) wrote :
tags: removed: need-duplicate-check
Gary Lasker (gary-lasker) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

Thanks!

visibility: private → public
Changed in software-center (Ubuntu):
status: New → Incomplete
Soren Mogensen (soren-mogensen) wrote :

This just happened for me as well, but cannot necessarily reproduce. In the past hour I have:

1) Created new KVM image from daily build of 12.10
2) Used software center to search for xfce
3) Used terminal to install xfce4 xfce4-goodies and xvce4-power-manager
4) Logged out and back in
5) Opened software center and searched for myth
6) Clicked on myth-backend, and the software center crashed with this error

(KVM image with 2GB ram, 1 cpu, and 12GB disk assigned)

Xavier Besnard (xavier-besnard) wrote :

Same problem with Kubuntu 12.10 Quantal alpha 3 including KDE 4.9. Dayly udate.

No trace available. Sorry

Ilja (mushketer888-gmail) wrote :

I have the same error with Kubuntu 12.10
And also packages(programs) information is diplayed not right (too much free space between top of page and start of information about package- like a gap space)

Patrick O'Dea (paddyo2) wrote :

do not know what happened.

Xavier Besnard (xavier-besnard) wrote :

Bug observed under Kubuntu 12.10 alpha 3.

Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Mark (nanite) wrote :

I had the same in Lubuntu 12.10 (History: Freshly installed Ubuntu 12.04 today, dist-upgrade to 12.10, then installed the Lubuntu packages). I noticed that it looked funny before it crashed (screenshot attached).

I tried to repeat it but it doesn't crash any more. Now, after double-clicking on the flash plugin entry it looks weird as well -- the description is missing unless I select it, and there is no Install button.

Changed in software-center (Ubuntu):
importance: Undecided → High
tags: added: ca-escalated
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

I can reproduce this in a kubuntu VM.

The root of the problem appears to be that there is no initial "style-update" signal on kubuntu send on the oxygen-gtk3
style theme. This appears to be caused by commit:
http://permalink.gmane.org/gmane.comp.kde.cvs/1125401

Now this affects more than just the crash, the other effect is e.g. the listview problem described in comment #8
and maybe more. We need to look at all places that call "style-updated". One workaround could be to use the old
"style-set" signal which is still delivered on kde4, not sure about the xfce engine, but I suspect its a similar issue.

Michael Vogt (mvo) wrote :

To reproduce on a standard ubuntu machine, install "gtk3-engines-oxygen" and set org.gnome.desktop.interface.gtk-theme to "oxygen-gtk" and run e.g. "software-center search:myth".

Infastyles (infastyles) wrote :

I accidentally double-clicked the icon in the unity bar and opened two instances.

Could that have something to do with it?

Michael Vogt (mvo) wrote :

Adding a gtk3-engines-oxygen task as I think it needs to send a styled-updated signal as the initial signal as well (not just the now deprecated style-set).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.4

---------------
software-center (5.4) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp1044141:
    - fix unicode error crash on a transaction error
      (LP: #1044141)
  * lp:~mvo/software-center/fix-size-calc-race:
    - fix crash due to a race in the size calculation code
      in the details view (LP: #1041004)
  * lp:~mvo/software-center/fix-crash-1048886:
    - No longer call GLib.init_threads() as this will cause
      LP: #1048886 later. Many thanks to Albert Astals Cid
  * lp:~mvo/software-center/dbus-idle-timeout:
    - stop the dbus data provider after 5min of inactivity
      (LP: #1058567)
  * lp:~mvo/software-center/lp1051829:
    - Do not report deb packages with lintian errors via the
      recoverable errors mechanism. This removes 97 out of 104
      instances of my sample of the recoverable error report
      for LP: #1051829. Other types of failures will still be
      reported as recoverable failures though (as we do want
      to know about them).

  [ Gary Lakser ]
  * lp:~gary-lasker/software-center/lp1041004:
    - ensure that app_details is valid before using it (LP: #1041004)
  * lp:~gary-lasker/software-center/fix-crash-lp1021308:
    - send synthetic "style-updated" signals to ensure that the signal
      handlers are called on themes that do not send this signal (like
      oxygen-gtk3). This fixes a crash and broken drawing LP: #1021308

  [ Nicolas Delvaux ]
  * lp:~malizor/software-center/fix-lp1050036:
    - fix crash in get_label() (LP: #1050036) and drop the i18n for the
      yes/no symbols that were not translated in any language (as a result
      test_regression_lp1047281.py can also be dropped)
 -- Michael Vogt <email address hidden> Fri, 05 Oct 2012 10:58:20 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Michael Vogt (mvo) on 2012-10-15
tags: removed: ca-escalated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oxygen-gtk3 (Ubuntu):
status: New → Confirmed
piotr zimoch (ebytyes) on 2013-05-25
Changed in oxygen-gtk3 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers