Graphical corruption in software center

Bug #1015216 reported by madbiologist on 2012-06-19
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Launching software-center shows graphical corruption on the toolbar icons. This comes and goes when mousing over the icons. Also, as soon as you begin to mouse over the text on the left-hand side it corrupts and so does the text on the right-hand side, without even needing to mlouse over the texgt on the right-hand side. Mousing over the same text again or using the scroll-wheel will cause the corruption to disappear but it simultaneously appears in a different spot.

I have attached a screenshot of the corrupted icons.

NOTE: This issue seems to affect text display as well, please refer to additional screenshots and info in the duplicates for this bug.

This does not occur in Firefox or LibreOffice Writer, nor in System Settings.

This still occurs after updating mesa to 8.0.3-0ubuntu1. Graphics hardware as reported by lspci is:

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6310] [1002:9802] (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device [103c:3577]

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: software-center 5.3.0
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic i686
ApportVersion: 2.1.1-0ubuntu2
Architecture: i386
CasperVersion: 1.317
Date: Wed Jun 20 03:22:29 2012
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120606.2)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

madbiologist (me-again) wrote :
Gary Lasker (gary-lasker) wrote :

Hello madbiologist, and thanks for your bug report! I cannot reproduce this problem on my Quantal installation with the latest updates as of tonight. Could you please try updating your system and then see if you are still getting this graphical corruption in the toolbar?

Please let us know, and thanks for your help!
Gary

Changed in software-center (Ubuntu):
status: New → Incomplete
Gary Lasker (gary-lasker) wrote :

We have another report of this, now marked as a duplicate bug 1015986, so I will set this as confirmed and we will investigate what might be going on here.

Many thanks all!
Gary

Gary Lasker (gary-lasker) wrote :

Further info from James Page in duplicate bug :

"I'm not sure that this is actually a bug on software-center; but it certainly seems to be worst affected and triggers a similar issue in xchat-gnome and the apport-bug collection window."

Changed in software-center (Ubuntu):
importance: Undecided → Low
status: Incomplete → Confirmed
Gary Lasker (gary-lasker) wrote :

Hi madbiologist or anyone else affected by this issue. Are you still seeing these issues after updating to the latest software in Quantal? It seems this was/is an issue in a driver or possibly a related library outside Software Center. Please let us know if you still have this problem, or if it is now resolved.

Many thanks!

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
James Page (james-page) wrote :

Hi Gary

I'm no longer seeing this issue (as of today).

Gary Lasker (gary-lasker) wrote :

Thanks, James! Ok, that is great news. I've heard other reports of this being temporary as well, so I will close this one now, based on your comment. If anyone is still encountering this issue, please feel free to reopen this and comment here.

Many thanks, all!

Changed in software-center (Ubuntu):
status: Incomplete → Invalid
madbiologist (me-again) wrote :

Sorry for the delay. I was waiting for alpha 2, and then had to wait for a friend to burn it onto a DVD.

I can no longer reproduce this issue on the above hardware when using Ubuntu 12.10 alpha 2.

Gary Lasker (gary-lasker) wrote :

Hi madbiologist, and thanks for reporting back! Even though the problem appears resolved for you, I am going to reopen this to track it as we seem to be getting additional duplicates of this bug.

It's unlikely that this is a bug in Software Center itself, but rather in one of the graphics libraries, etc., but for tracking I will keep this open. Thank you again, all!

Changed in software-center (Ubuntu):
status: Invalid → Confirmed
importance: Low → Medium
Gary Lasker (gary-lasker) wrote :

Please disregard my previous comment. The other issues that I mentioned are about graphical corruption in fonts and listviews, so it may indeed be a separate issue. I'll reclose this one as it is specifically about the toolbar icons, and this specific problem has reported to be resolved now, per the comments above.

Thanks again!

Gary Lasker (gary-lasker) wrote :

In the words of the immortal Willie Wonka: "Wait a minute. Strike that. Reverse it."

It does seem to be affecting more people, so I will keep this as the master bug for this issue.

Changed in software-center (Ubuntu):
status: Confirmed → Invalid
importance: Medium → Low
status: Invalid → Confirmed
importance: Low → Medium
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1015216

tags: added: iso-testing
madbiologist (me-again) wrote :

Yeah, I was also getting corruption of fonts in software centre, but not anymore in alpha 2.

Nicholas Allam (njallam) wrote :

I had this problem on my 12.10 install with an NVIDA GT440 graphics card. This problem occurred as soon as I enabled the NVIDIA binary drivers in Additional Drivers. The solution for me was to switch back to the X.org X server drivers (restart) then to switch back to the NVIDIA binary drivers. The problem hasn't occurred since.

Walter Ribeiro (wribeirojr) wrote :

Probably dupe of bug 568492

dino99 (9d9) wrote :

That version is no more maintained

Changed in software-center (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers