Add F1 for help for Firefox, Ubuntu Software Center

Bug #1011567 reported by Mozaic on 2012-06-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Won't Fix
Medium
software-center (Ubuntu)
Low
Robert Roth

Bug Description

In Firefox 13 we could not use F1 to call help'page. But in Thunderbird we could.
List of software don't have F1:
- Firefox
- Ubuntu Software Center
- Screenshot
- Start up Disk Creator
- Update manager

Screenshot and Update manager could be see like tool of Ubuntu. But i don't see Ubuntu Software Center like tool

Expected: Add F1 for all softwares in Ubuntu

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 13.0+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gris 2036 F.... pulseaudio
BuildID: 20120601175215
CRDA:
 country EC:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 20), (3, 17)
  (5250 - 5330 @ 20), (3, 23), DFS
  (5735 - 5835 @ 20), (3, 30)
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8800000 irq 43'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0272,15580771,00100001 HDA:80862804,80860101,00100000'
   Controls : 44
   Simple ctrls : 17
Channel: release
Date: Mon Jun 11 13:19:22 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
IpRoute:
 default via 192.168.0.154 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.4 metric 2
MostRecentCrashID: bp-5749877c-8842-45b7-8436-a602d2120512
Profiles: Profile0 (Default) - LastVersion=13.0/20120601175215 (In use)
RelatedPackageVersions:
 icedtea-6-plugin 1.2-2ubuntu1
 rhythmbox-mozilla 2.96-0ubuntu4
 totem-mozilla 3.0.1-0ubuntu21
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/05/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: CALPELLACRB.86C.0000.X.0000000000
dmi.board.asset.tag: Tag 12345
dmi.board.name: W760C
dmi.board.vendor: CLEVO Co.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: CLEVO
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrCALPELLACRB.86C.0000.X.0000000000:bd05/05/2010:svnCLEVOCo.:pnW76OC:pvrNotApplicable:rvnCLEVOCo.:rnW760C:rvrNotApplicable:cvnCLEVO:ct9:cvrN/A:
dmi.product.name: W76OC
dmi.product.version: Not Applicable
dmi.sys.vendor: CLEVO Co.

Related branches

Mozaic (mozaic) on 2012-06-11
Changed in firefox (Ubuntu):
status: New → Opinion
status: Opinion → New
Robert Roth (evfool) on 2012-06-11
Changed in software-center (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in gnome-screenshot (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Robert Roth (evfool) on 2012-06-11
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Robert Roth (evfool)
Mozaic (mozaic) on 2012-06-11
description: updated
Robert Roth (evfool) on 2012-06-11
Changed in firefox (Ubuntu):
status: New → Confirmed
Micah Gersten (micahg) wrote :

Please don't add tasks where the fix isn't related. If this is an issue, please file a new bug for firefox.

no longer affects: firefox (Ubuntu)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601175215

Steps to reproduce:

I press F1 and it's don't launch Firefox's help

Actual results:

Nothing

Expected results:

Launch help (exactly the help in on web pages, so it should open a new tab of support.mozilla.org

Mozaic (mozaic) wrote :
affects: software-center → firefox
Changed in firefox:
importance: Unknown → Medium
status: Unknown → New

The shortcut got removed with bug 519137 so this is on purpose

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed

Why F1 works in Thunderbird 13, but not in Firefox 13 ??
If press F1 is an accident, why it keep in Thunderbird? Mozilla is not logic.

(In reply to vulcain from comment #4)
Look here also..
https://bugzilla.mozilla.org/show_bug.cgi?id=519137
its not a BUG, ist a bad Feature... :-(

Im using the Addon userchromejs
http://userchromejs.mozdev.org/
and the Script SupportMozilla
https://github.com/ardiman/userChrome.js/tree/af08dd941f0340e2d3d3054e217ff185c6a8f8b2/supportmozilla
Its a German Script and a German ReadMe!!
https://github.com/ardiman/userChrome.js#
It works..
More Scripts..
http://www.camp-firefox.de/forum/viewtopic.php?p=729763#p729763

Changed in firefox:
status: New → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.1

---------------
software-center (5.3.1) quantal; urgency=low

  [ Robert Roth ]
  * lp:~evfool/software-center/lp752376:
    - Updated the code to also work with file:// style deb filenames
      (LP: LP #752376)
  * lp:~evfool/software-center/lp1011605:
    - update copyright date in the About window (LP: #1011605)
  * lp:~evfool/software-center/lp1011567:
    - add F1 key as accelerator for opening Help (LP: #1011567)

  [ Gary Lasker ]
  * debian/control:
    - remove recommends for gir1.2-launchpad-integration-3.0 as it is no
      longer needed (many thanks Robert Ancell)

  [ Natalia Bidart ]
  * lp:~nataliabidart/software-center/the-organizer:
    + Tests cleanup:
      - Renamed test/ dir to tests/.
      - Moved the testutils module to tests/utils.py.
      - Removed all unnecessary logging setup per test file.
      - Removed all unnecessary shebangs in test files.
      - Isolated test code into tests/ directory, including moving all the
        get_test_window_foo from the gtk3 production modules to
        tests/gtk3/windows.py module.
      - Removed all the calls to Gtk.main() in gtk3 tests since that blocks the
        execution of the suite.
      - Pep8 and pyflakes fixes in the files already modified in this branch.
      - Minor bug fix in the softwarecenter/log.py module when trying to
        create a log dir with proper perms.
  * lp:~nataliabidart/software-center/cant-stop-the-music.trunk:
    - Stop the video if user navigates away from an app details page
      (LP: #1003954).
    - Refactored ViewManager so page displaying calls a leave_page before
      changing a page, and a enter_page when navigating into a page.

  [ Adam Conrad ]
  * xz-lzma has been rolled into xz-utils, as of 5.1.1alpha+20120614-1

  [ Michael Vogt ]
  * lp:~mvo/software-center/python-apt-0.8 :
    - fix some leftover python-apt 0.7 API usage that will get removed
      in quantal
  * lp:~mvo/software-center/add-profile-cmdline
    - add new --profile option to the app that writes out a cProfile
      logfile
    - add new dbus method com.ubuntu.SoftwarecenterIFace.writeMemoryDump
      to write meliae memory dump for analyizing memleaks/cycles
  * lp:~mvo/software-center/more-performance-measurement:
    - add more fine grained data in --measure-startup-time and
      suppresses times <0.1s in the output
 -- Michael Vogt <email address hidden> Thu, 21 Jun 2012 08:44:02 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2013-03-28
no longer affects: gnome-screenshot (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.