Clicking on "Reinstall previous purchase" twice shows endless spinner

Bug #1011522 reported by Michael Vogt on 2012-06-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Michael Vogt
Precise
Medium
Michael Vogt

Bug Description

[TEST CASE]
1. Launch the current Ubuntu Software Center in Precise.
2. Choose menu item "File"->"Reinstall Previous Purchases" and wait for the list to be displayed.
3. Repeat step 2.
4. Notice that the spinner is displayed, and it remains indefinitely.
5. Close Ubuntu Software Center.
6. Update to the latest version of software-center in precise-proposed.
7. Repeat steps 1 through 3.
8. Verify that the list is now displayed correctly the second time (that is, the spinner, if it appears, does not remain).

[REGRESSION POTENTIAL]
This is a very straightforward fix and as such the risk of regression is extremely low. Look for the resulting list not displayed as expected.

---

Test case:

1. open software-center
2. click on "File/Reinstall previous purchase"
3. wait until the list is displayed
4. repeat (2)
5. verify that there is a spinner visible that never goes away

Related branches

Michael Vogt (mvo) wrote :

The debug output:

2012-06-11 11:46:47,354 - softwarecenter.ui.gtk3.app - DEBUG - on_menu_file_activate
2012-06-11 11:46:50,604 - softwarecenter.ui.gtk3.panes.softwarepane - DEBUG - show_appview_spinner
2012-06-11 11:46:50,605 - softwarecenter.ui.gtk3.panes.availablepane - DEBUG - on_previous_purchases_activated with query: Xapian::Query(AHfor-pay-needs-reinstall)
2012-06-11 11:46:50,606 - softwarecenter.ui.gtk3.session.navhistory - DEBUG - appending: 'GetSof:2 None None "" None * SoftwareChannel
  name: Previous Purchases
  origin: software-center-agent
  component: None
  display_name: Previous Purchases
  iconname: unknown-channel
  query: Xapian::Query(AHfor-pay-needs-reinstall)
  sort_mode: 1
  installed_only: False'
2012-06-11 11:46:50,606 - softwarecenter.ui.gtk3.session.navhistory - DEBUG - A:[GetSof:0 None None "" None None, GetSof:2 None None "" None * SoftwareChannel
  name: Previous Purchases
  origin: software-center-agent
  component: None
  display_name: Previous Purchases
  iconname: unknown-channel
  query: Xapian::Query(AHfor-pay-needs-reinstall)
  sort_mode: 1
  installed_only: False, ]
2012-06-11 11:46:50,607 - softwarecenter.ui.gtk3.panes.softwarepane - DEBUG - refresh_apps
2012-06-11 11:46:50,607 - softwarecenter.ui.gtk3.panes.softwarepane - DEBUG - show_appview_spinner
2012-06-11 11:46:50,608 - softwarecenter.ui.gtk3.panes.softwarepane - DEBUG - softwarepane query: [Xapian::Query((AHfor-pay-needs-reinstall AND <alldocuments>))]
2012-06-11 11:46:50,608 - softwarecenter.db.enquire - DEBUG - initial query: 'Xapian::Query((AHfor-pay-needs-reinstall AND <alldocuments>))'
2012-06-11 11:46:50,609 - softwarecenter.performance - DEBUG - calculate nr_apps and nr_pkgs: : 0.000637054443359
2012-06-11 11:46:50,609 - softwarecenter.db.enquire - DEBUG - nearly completely filtered query: 'Xapian::Query((AHfor-pay-needs-reinstall AND <alldocuments>))'
2012-06-11 11:46:50,611 - softwarecenter.db.enquire - DEBUG - found ~11 matches
2012-06-11 11:46:50,611 - softwarecenter.performance - DEBUG - append new matches to existing ones:: 0.000160217285156
2012-06-11 11:46:50,674 - softwarecenter.ui.gtk3.panes.availablepane - DEBUG - applist-changed <AvailablePane object at 0x31805a0 (softwarecenter+ui+gtk3+panes+availablepane+AvailablePane at 0x3019680)> 11
2012-06-11 11:46:50,674 - softwarecenter.ui.gtk3.models.appstore2 - DEBUG - set_from_matches len(matches)='11'
2012-06-11 11:46:50,677 - softwarecenter.performance - DEBUG - store.append_initial: 0.00243282318115
2012-06-11 11:46:50,678 - softwarecenter.ui.gtk3.panes.softwarepane - DEBUG - hide_appview_spinner
2012-06-11 11:46:50,678 - softwarecenter.performance - DEBUG - populate model from query: 'Xapian::Query((AHfor-pay-needs-reinstall AND <alldocuments>))' (threaded: True): 0.0704529285431
2012-06-11 11:46:50,679 - softwarecenter.performance - DEBUG - enquirer.set_query(): 0.0707421302795

It looks like the spinner tab is simply not returning to the content page here, when running with SOFTWARE_CENTER_DEBUG_TABS=1 I can see the content just fine.

Michael Vogt (mvo) on 2012-06-11
Changed in software-center (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Michael Vogt (mvo)
Michael Vogt (mvo) wrote :

The attached branch should fix the bug.

Michael Vogt (mvo) on 2012-06-27
Changed in software-center (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Medium
Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.4

---------------
software-center (5.3.4) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/fix-lp1009039:
    - fix treeview selection background (LP: #1009039)
  * lp:~mvo/software-center/fix-lp1011522:
    - fix bug where clicking on "Reinstall previous purchases" twice
      shows endless spinner (LP: #1011522)
  * lp:~mvo/software-center/click_url:
    - adds support for a "click_url" from the exhibits banner to
      support banners for things like the humble-bundle where we
      don't have packages but URLs (LP: #1020205)
  * lp:~mvo/software-center/webkit-http-debug:
    - enable full http output debugging for webkit
  * lp:~mvo/software-center/fix-get-set-gobject-data:
    - fixes a leftover use of "GObject.{get,set}_data()" that is
      no longer supported by python-gi in quantal

  [ Natalia Bidart ]
  * lp:~nataliabidart/software-center/winged-migration:
    - merged gtk sso login code to ensure we have a consistent UI
      when ubuntu-sso-client drops its gtk version
 -- Michael Vogt <email address hidden> Tue, 10 Jul 2012 14:27:14 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
description: updated
Stéphane Graber (stgraber) wrote :

Reverting the precise task to In Porogress, Fix Commited is for packages that are in the -proposed pocket, this package is still in the Unapproved queue.

Changed in software-center (Ubuntu Precise):
status: Fix Committed → In Progress
Changed in software-center (Ubuntu Precise):
assignee: nobody → Michael Vogt (mvo)

Hello Michael, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.2.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Gary Lasker (gary-lasker) wrote :

I have verified that software-center version 5.2.5 in precise-proposed fixes this bug per the test case given in the description.

Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.5

---------------
software-center (5.2.5) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/fix-lp1009039:
    - fix treeview selection background (LP: #1009039)
  * lp:~mvo/software-center/fix-lp1011522:
    - fix bug where clicking on "Reinstall previous purchases" twice
      shows endless spinner (LP: #1011522)
  * lp:~mvo/software-center/click_url:
    - adds support for a "click_url" from the exhibits banner to
      support banners for things like the humble-bundle where we
      don't have packages but URLs (LP: #1020205)
  * lp:~mvo/software-center/hopefully-fix-lp1008229:
    - fix crash that can happen if there is an error while
      opening a deb file (LP: #1008229)
  * lp:~mvo/software-center/lp1026494:
    - typo fix in the hw description code (LP: #1026494)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/unity-launcher-integration-fixes:
    - fix bug where for-purchase items are not being added to the Unity
      launcher (LP: #925014)
    - fix bug where the Unity launcher item for an application incorrectly
      points to its app-install-data desktop file rather than its installed
      desktop file (LP: #999427)
    - fix bug where an application's icon remains in the Unity launcher after
      the corresponding application has been uninstalled (LP: #981488)
    - fix bug where the Unity launcher fails to auto-hide after installation
      of a for-purchase item (LP: #1002440)
    - fix bug where items in the "Independent" section are not being added
      to the Unity launcher (LP: #1012877)
  * lp:~gary-lasker/software-center/tech-items-to-launcher-fix-lp1006483:
    - don't add an item to the launcher if its desktop file specifies
      NoDisplay=true (LP: #1006483)
  * lp:~gary-lasker/software-center/launcher-integration-unit-tests:
   - additional unit tests to round out the suite for the Unity
     launcher integration feature
  * lp:~gary-lasker/software-center/fix-lp969907-for-5.2:
    - fix race condition in _app_activated_cb() (LP: #969907)
 -- Michael Vogt <email address hidden> Mon, 23 Jul 2012 16:38:04 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers