update-software-center-agent initial delay too long

Bug #1007521 reported by Michael Vogt on 2012-06-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt
Precise
High
Unassigned

Bug Description

The is pretty urgent as it affects the user experience of all humble-hundle buyers.

For people clicking on a apt link (e.g. apt:limbo from the humble bundle download page) the current delay to query the software-center-agent for new titles of 30s is too long. The user experience is that the user gets a "Not found" message for 30s+query_time_software_center_agent.

TEST CASE:
1. rm -rf ~/.cache/software-center/
2. software-center apt:limbo
3. see "Not found"
4. wait for 30+ seconds before its found

5. install version from precise-proposed
6. repeat 1,2,3
7. verify that the "not found" is substancially quicker this time

Michael Vogt (mvo) wrote :

In the future this should show a "wait for data" text when its not found before hte software-center-agent refreshed.

Changed in software-center (Ubuntu):
status: New → In Progress
importance: Undecided → High
Changed in software-center (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
Michael Vogt (mvo) on 2012-06-01
description: updated
description: updated
Michael Vogt (mvo) wrote :

Fixed in quantal with the 5.3.0 upload

Changed in software-center (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: In Progress → Fix Released
Michael Vogt (mvo) wrote :
Download full text (4.6 KiB)

Full 5.3 changelog:

software-center (5.3.0) quantal; urgency=low

  [ Robert Roth ]
  * lp:~evfool/software-center/lp872760:
    - Updated the category name for the RasterGraphics subcategory
      from Painting & Editing to Painting (LP: #872760)
  * lp:~evfool/software-center/lp927426:
    - Changed the reference to store to Software Center, as requested in
      bug LP: #927426
  * lp:~evfool/software-center/specs-update:
    - Moved the recommended applications section after the package details
    - Moved the addon status bar after the addons list
    - Aligned the star ratings widget vertically with the titles
    - Added some vertical padding before the star ratings widget to look
       bette
  * lp:~evfool/software-center/history-enhancements:
    - display text-sized icons in history, not double-sized ones
    - use padding between the icon and the package name
    - right-align the time of the history action
    - display the action +time (installed/updated/removed) if the
      filter is all changes, otherwise only display the time
    - removed markup from the translatable string, to avoid translation
      mistakes with markup

  [ Sebastian Heinlein ]
  * lp:~glatzor/software-center/remove-workaround-747172:
    - remove old workaround that should be no longer needed (LP: #747172)

  [ Robert Ancell ]
  * lp:~robert-ancell/software-center/no-lpi:
    - Drop Launchpad integration

  [ Michael Vogt ]
  * lp:~mvo/software-center/piston-generic-helper-offline-mode:
    - add support for offline mode to the generic helper just like
      for piston_get_reviews_helper.py

 -- Michael Vogt <email address hidden> Fri, 01 Jun 2012 19:54:38 +0200

software-center (5.2.3) UNRELEASEDprecise-proposed; urgency=low

  [ Robert Roth ]
  * lp:~evfool/software-center/lp987801:
    - Only show the version label once for each version in
      reviews (LP: #987801)
  * lp:~evfool/software-center/lp874430:
    - display tooltips for package titles in the application
      tiles of the lobby view (LP: #874430)
  * lp:~evfool/software-center/lp983831:
    - Avoid merging two words while normalizing description (LP: #983831)
  * lp:~evfool/software-center/lp822625:
    - Set default value for reviewstats histogram (LP: #822625)
  * lp:~evfool/software-center/lp875874:
    - Set word wrap with fallback to char wrapping for the review
      text label (LP: #875874)

  [ Gabor Kelemen ]
  * lp:~kelemeng/software-center/bug1001746:
    - merge i18n fix (LP: #1001746)

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp872760-for-5.2:
    - fix translations for certain category names (LP: #872760)
  * lp:~mvo/software-center/lp987321:
    - fix dependency to ensure that we have humanity-icon-theme
      as we need it for the history view icons (LP: #987321)
  * lp:~mvo/software-center/test-catview-cleanup:
    - refactor unit tests for the catview
  * lp:~mvo/software-center/lp1002271:
    - fix regresion in 5.2.2 (LP: #1002271) for empty descriptions
  * lp:~mvo/software-center/lp1005104:
    - fix regression in 5.2.2 (LP: #1005104) in initial navigation
      history
  * lp:~mvo/software-center/client-lp1004417:
    - client side fix for...

Read more...

Hello Michael, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: In Progress → Fix Committed
Gary Lasker (gary-lasker) wrote :

I have verified this bug is fixed in software-center version 5.2.2.2 in precise-proposed, per the provided test case.

Please, anyone, feel free to provide additional verifies.

Many thanks, all!

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.2.2

---------------
software-center (5.2.2.2) precise-proposed; urgency=low

  * tweak timeout for the software-center-agent for the HIB
    (LP: #1007521)
 -- Michael Vogt <email address hidden> Fri, 01 Jun 2012 19:08:25 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

Given the narrow scope of the change and the impact this is having on users currently due to the Humble Bundle activity, I've gone ahead and pushed to precise-updates based on Gary's verification as there doesn't seem to be real danger of regression here.

Gary Lasker (gary-lasker) wrote :

Thank you very much, Steve!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers