add iso3166 enforced whitelist

Bug #1006570 reported by Michael Vogt on 2012-05-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Software Center Agent
Medium
Danny Tamez
software-center (Ubuntu)
Medium
Michael Vogt
Precise
Undecided
Unassigned

Bug Description

The current way to restrict by region is the blacklist-iso3166:: tag. If a developer wants to restrict to a specific country only (e.g. US) this is not ideal. We need "restrict-to-iso3166::" or something similar there too.

TEST CASE:
1. use precise in a non-spanish speaking country (like germany or the UK)
2. run software-center search:Comentarios
3. verify that it exists
4. install software-center from precise-proposed
5. repeat (2) and verify that its no longer found (may need some seconds to clean the result)

REGRESSION POTENTIAL: low as its a new feature and in the worst case the whitelist does not work and therefore the user sees all apps which is exactly the current behavior.

Related branches

Michael Vogt (mvo) on 2012-05-30
Changed in software-center (Ubuntu):
milestone: none → ubuntu-12.10
status: New → Triaged
importance: Undecided → Medium
Changed in software-center (Ubuntu):
status: Triaged → Confirmed
Danny Tamez (zematynnad) on 2012-06-01
Changed in software-center-agent:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Danny Tamez (zematynnad)
Danny Tamez (zematynnad) on 2012-06-19
Changed in software-center-agent:
status: In Progress → Fix Committed
Dave Morley (davmor2) on 2012-07-13
Changed in software-center-agent:
status: Fix Committed → Fix Released
Dave Morley (davmor2) on 2012-07-13
Changed in software-center-agent:
milestone: none → 12.07
Michael Vogt (mvo) wrote :

This is targeted for 12.10 so I add a ca-escalated tag now as we are getting late.

tags: added: ca-escalated
Michael Vogt (mvo) wrote :

This is a real issue now with swiftcrypt.

Michael Vogt (mvo) on 2012-09-10
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Changed in software-center (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.12

---------------
software-center (5.3.12) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/inspect-memleak:
    - fix two memory leaks when the cache is re-opened after
      a package has been installed/removed (LP: #1003466), add
      memory usage test/monitoring utilities and a set of new
      unit tests
  * lp:~mvo/software-center/lp1047281:
    - fix crashing bug due to a unicode decode error and add
      a regression unit test (LP: #1047281)
  * lp:~mvo/software-center/region-whitelist-lp1006570:
    - fix missing region whitelist support that is used by
      the software-center-agent (LP: #1006570)
  * debian/test/run-tests:
    - unset TMPDIR and do not run with sh -x, thanks to Martin Pitt
    - fix when run from the binary Package, thanks to
      Jean-Baptiste Lallement

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/recommender-test-fix:
    - update the recommender feedback unit test to work on systems
      that are not opted-in
 -- Michael Vogt <email address hidden> Tue, 11 Sep 2012 14:37:43 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Clint Byrum (clint-fewbar) wrote :

This is missing a test case, and so can't be approved for SRU.

Clint Byrum (clint-fewbar) wrote :

<BUMP> Still waiting for a test case here!

Chris Halse Rogers (raof) wrote :

I've rejected the software-center SRU from the precise-proposed queue, as bug #1006570 and bug #1042279 have been waiting for test cases and regression potential for over a month now.

Once these bugs have the necessary information for an SRU, please ping me or another an SRU team member in #ubuntu-release and we can fish it out of the rejected queue.

Michael Vogt (mvo) on 2012-11-21
description: updated
description: updated

Hello Michael, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.2.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Disappeared as should after updating to the -proposed version.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.7

---------------
software-center (5.2.7) precise-proposed; urgency=low

  * lp:~mvo/software-center/oem-descriptor-in-user-agent-5.2:
    - include the oem-channel descriptor in the custom user agent
      string (LP: #1042749)
  * lp:~mvo/software-center/auto-fill-email-for-login:
    - allow auto-fill of the email in login.ubuntu.com if
      we have it (LP: #1042279)
  * lp:~mvo/software-center/fix-memleak-5.2:
    - fix two memory leaks when the cache is re-opened after
      a package has been installed/removed (LP: #1003466)
  * lp:~mvo/software-center/region-whitelist-5.2:
    - fix missing region whitelist support that is used by
      the software-center-agent (LP: #1006570)
  * lp:~mvo/software-center/downloader-fix-race839462-again-5.2:
    - fix a race condition in the SimpleFileDownloader when the file
      is downloaded but the signal did not get delivered yet by the
      gtk event loop (LP: #1055441)
 -- Michael Vogt <email address hidden> Wed, 26 Sep 2012 09:39:43 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers