video keeps playing when navigating away from the details page

Bug #1003954 reported by Michael Vogt on 2012-05-24
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Natalia Bidart
Nominated for Quantal by Natalia Bidart
Precise
Medium
Unassigned

Bug Description

The video keeps playing when navigating away from the details page.

[TEST CASE]
1. Launch the current version of software-center in precise.
2. Open software-center and search for "Journey Down".
3. Select the item for "The Journey Down: Chapter One" and click the "More Info" button to view its details.
4. Find the video panel below the screenshots and click the start button to start it playing. Make sure the sound is up so that you can hear the pleasant sounds of the video.
5. Navigate back to the list view using the back navigation button at the top left of the Software Center window.
6. Note that even though you are viewing the list view now, you can still hear the sounds of the video playing in the background.
7. Click the forward navigation button to return to the details view and note that the video is still playing there.
8. Close Software Center.
9. Install the new version of software-center in -proposed.
10. Repeat steps 1 through 5 for the new version of Software Center.
11. Verify that now when you navigate away from the details view the sound of the video stops, and when you navigate back, verify that the video is no longer playing.

[REGRESSION POTENTIAL]
Risk is very low as the fix for this SRU simply stops the video playback upon leaving the details page. To check for regressions simply nagivate to and from the details page to check that the video reappears and plays/stops as expected. Note also that this fix includes a nice set of unit tests to verify the functionality overall.

---

1. run "software-center journeydown-one"
2. click on "play" in the video
3. click on "all software"
4. verify that the video keeps playing

What should happen:
4. the video should top or pause

Related branches

Changed in software-center (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Natalia Bidart (nataliabidart)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.1

---------------
software-center (5.3.1) quantal; urgency=low

  [ Robert Roth ]
  * lp:~evfool/software-center/lp752376:
    - Updated the code to also work with file:// style deb filenames
      (LP: LP #752376)
  * lp:~evfool/software-center/lp1011605:
    - update copyright date in the About window (LP: #1011605)
  * lp:~evfool/software-center/lp1011567:
    - add F1 key as accelerator for opening Help (LP: #1011567)

  [ Gary Lasker ]
  * debian/control:
    - remove recommends for gir1.2-launchpad-integration-3.0 as it is no
      longer needed (many thanks Robert Ancell)

  [ Natalia Bidart ]
  * lp:~nataliabidart/software-center/the-organizer:
    + Tests cleanup:
      - Renamed test/ dir to tests/.
      - Moved the testutils module to tests/utils.py.
      - Removed all unnecessary logging setup per test file.
      - Removed all unnecessary shebangs in test files.
      - Isolated test code into tests/ directory, including moving all the
        get_test_window_foo from the gtk3 production modules to
        tests/gtk3/windows.py module.
      - Removed all the calls to Gtk.main() in gtk3 tests since that blocks the
        execution of the suite.
      - Pep8 and pyflakes fixes in the files already modified in this branch.
      - Minor bug fix in the softwarecenter/log.py module when trying to
        create a log dir with proper perms.
  * lp:~nataliabidart/software-center/cant-stop-the-music.trunk:
    - Stop the video if user navigates away from an app details page
      (LP: #1003954).
    - Refactored ViewManager so page displaying calls a leave_page before
      changing a page, and a enter_page when navigating into a page.

  [ Adam Conrad ]
  * xz-lzma has been rolled into xz-utils, as of 5.1.1alpha+20120614-1

  [ Michael Vogt ]
  * lp:~mvo/software-center/python-apt-0.8 :
    - fix some leftover python-apt 0.7 API usage that will get removed
      in quantal
  * lp:~mvo/software-center/add-profile-cmdline
    - add new --profile option to the app that writes out a cProfile
      logfile
    - add new dbus method com.ubuntu.SoftwarecenterIFace.writeMemoryDump
      to write meliae memory dump for analyizing memleaks/cycles
  * lp:~mvo/software-center/more-performance-measurement:
    - add more fine grained data in --measure-startup-time and
      suppresses times <0.1s in the output
 -- Michael Vogt <email address hidden> Thu, 21 Jun 2012 08:44:02 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Michael Vogt (mvo) on 2012-06-26
Changed in software-center (Ubuntu Precise):
status: New → Fix Released
importance: Undecided → Medium

Hello Michael, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-center/5.2.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
description: updated
Gary Lasker (gary-lasker) wrote :

I have verified that software-center version 5.2.4 in precise-proposed fixes this bug per the test case given in the description.

Thanks!

tags: added: verification-done
removed: verification-needed
Changed in software-center (Ubuntu Precise):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.4

---------------
software-center (5.2.4) precise-proposed; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp970627:
    - fix intermittent crash when expunging the cache (LP: #970627)
  * lp:~mvo/software-center/lp971776:
    - fix crash when a downloaded image is invalid for whatever
      reason (network issues, proxy issues, pay-wall in between)
      (LP: #971776)
  * lp:~mvo/software-center/lp967036-2:
    - fix unicode error crash for people running with the
      LANGUAGE=zh_CN.UTF-8 or zh_TW.UTF-8 (LP: #967036)
  * lp:~mvo/software-center/cookie-jar:
    - fix paypal support in the purchases window (LP: #1018347)

  [ Gary Lasker ]
  * debian/control:
    - update vcs link to point to the 5.2 branch
  * lp:~gary-lasker/software-center/previous-purchase-sorting-lp873104:
    - return correct results when sorting the list of previous
      purchases (LP: #873104)
  * lp:~gary-lasker/software-center/recommendations-string-change-lp986437-for-5.2:
    - switch to the updated recommendations opt-in string now that the
      corresponding language pack updates are released and available
      (LP: #986437)
  * lp:~gary-lasker/software-center/fix-lp920741:
    - fix UnicodeDecodeError when a commercial app's title contains
      a unicode character (LP: #920741)

  [ Natalia Bidart ]
  * lp:~nataliabidart/software-center/cant-stop-the-music:
    - Stop the video if user navigates away from an app details page
      (LP: #1003954).
 -- Michael Vogt <email address hidden> Thu, 28 Jun 2012 10:35:55 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers