Software-Center crashes on starting

Bug #1000238 reported by userdce on 2012-05-16
202
This bug affects 37 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Gary Lasker
Precise
Undecided
Unassigned

Bug Description

Note for Precise SRU:

This change has no effect in Precise. It is a simple removal of a single line that was an obsolete workaround for an old bug long since fixed. This line caused a crash in Quantal and so was removed there, and as it is dead code in Precise we removed it from here as well.

Regression Potential:
None.

Software-center crashes when started
Ubuntu is fully updated with Quantal
logs on starting software-center:

2012-05-16 09:52:15,840 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-05-16 09:52:15,844 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-05-16 09:52:16,105 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-05-16 09:52:16,713 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
Traceback (most recent call last):
  File "/usr/bin/software-center-gtk3", line 176, in <module>
    app.run(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1343, in run
    self.show_available_packages(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1273, in show_available_packages
    self.view_manager.set_active_view(ViewPages.AVAILABLE)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/viewmanager.py", line 149, in set_active_view
    view_widget.init_view()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/availablepane.py", line 133, in init_view
    SoftwarePane.init_view(self)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/softwarepane.py", line 233, in init_view
    self.datadir)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py", line 886, in __init__
    self._layout_page()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py", line 1185, in _layout_page
    self.pkg_statusbar = PackageStatusBar(self)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py", line 176, in __init__
    self.progress.set_data("transparent-bg-hint", True)
AttributeError: 'ProgressBar' object has no attribute 'set_data'

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: software-center 5.2.1
ProcVersionSignature: Ubuntu 3.4.0-1.3-generic 3.4.0-rc5
Uname: Linux 3.4.0-1-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Wed May 16 09:52:46 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120510)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

userdce (userdce) wrote :
Mohamed Alaa (m-alaa8) on 2012-05-16
Changed in software-center (Ubuntu):
status: New → Confirmed
Gary Lasker (gary-lasker) wrote :

Hmm, this seems to only be happening on Quantal? I can find no reports of this one in Precise to this point.

I'm creating a Quantal VM to test with.

Gary Lasker (gary-lasker) wrote :

Yes, I can verify that this crash occurs in my Quantal VM, today's build.

Changed in software-center (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
status: Triaged → In Progress
tags: added: ca-escalated

Looks like line 176 of /usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py is trying to call Gtk.ProgressBar.set_data(), which doesn't appear to be a valid method from what I see in the docs at http://www.pygtk.org/docs/pygtk/class-gtkprogressbar.html.

Forgot to add: Commented out line 176 and it works fine, though I didn't go look to see if the visual bug 606942 was reintroduced.

Gary Lasker (gary-lasker) wrote :

Hi 3vi1, and thanks for your comment. Indeed, that is the offending line and its removal is the fix waiting for merge in my attached branch. Indeed, this line was an old workaround for a bug in the light-themes package that has long since been fixed, so it is perfectly safe to remove. There is no visual glitch or difference at all when the line is removed.

We will try to get this fix merged and the fix released in Quantal ASAP.

Thanks again!

Phil Dobbin (bukowskiscat) wrote :

I can confirm this also happens in 12.04 AMD64. Software Centre (excuse the British English) tries to install then hangs & has to be force quit.

Bug reporter didn't work either.

This is on a brand new, clean install from Live CD on a HP du7200 2 x 2.8 GHz Intels with 2 GB's of RAM. I have another exact same machine running 11.10 AMD64 & there's no problem.

Michael Vogt (mvo) on 2012-05-30
Changed in software-center (Ubuntu):
milestone: none → quantal-alpha-1
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu Precise):
status: New → Confirmed
Michael Vogt (mvo) on 2012-06-04
Changed in software-center (Ubuntu Precise):
status: Confirmed → Invalid
Changed in software-center (Ubuntu):
status: In Progress → Fix Released
description: updated

Hello userdce, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Gary Lasker (gary-lasker) wrote :

I have verified that software-center version 5.2.3 in precise-proposed causes no regressions and everything works as expected.

Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.3

---------------
software-center (5.2.3) precise-proposed; urgency=low

  [ Robert Roth ]
  * lp:~evfool/software-center/lp987801:
    - Only show the version label once for each version in
      reviews (LP: #987801)
  * lp:~evfool/software-center/lp874430:
    - display tooltips for package titles in the application
      tiles of the lobby view (LP: #874430)
  * lp:~evfool/software-center/lp983831:
    - Avoid merging two words while normalizing description (LP: #983831)
  * lp:~evfool/software-center/lp822625:
    - Set default value for reviewstats histogram (LP: #822625)
  * lp:~evfool/software-center/lp875874:
    - Set word wrap with fallback to char wrapping for the review
      text label (LP: #875874)

  [ Gabor Kelemen ]
  * lp:~kelemeng/software-center/bug1001746:
    - merge i18n fix (LP: #1001746)

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp872760-for-5.2:
    - fix translations for certain category names (LP: #872760)
  * lp:~mvo/software-center/lp987321:
    - fix dependency to ensure that we have humanity-icon-theme
      as we need it for the history view icons (LP: #987321)
  * lp:~mvo/software-center/test-catview-cleanup:
    - refactor unit tests for the catview
  * lp:~mvo/software-center/lp1002271:
    - fix regresion in 5.2.2 (LP: #1002271) for empty descriptions
  * lp:~mvo/software-center/lp1005104:
    - fix regression in 5.2.2 (LP: #1005104) in initial navigation
      history
  * lp:~mvo/software-center/client-lp1004417:
    - client side fix for when exhibit package names contain
      extra whitespace (LP: #1004417)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-crash-lp1000238:
    - remove obsolete workaround for an old bug that has long since
      been fixed, this fixes a hard crash on Quantal (LP: #1000238)
  * lp:~gary-lasker/software-center/toolbar-buttons-insensitive-during-startup:
    - re-enable the fix for LP: #999486, LP: #994341 that was inadvertently
      disabled in the 5.2.2 release

  [ Natalia Bidart ]
  * lp:~nataliabidart/software-center/fix-977931:
    - Unified package string parsing into a single method that will be
      used from either the command line arguments, or from the dbus method
      'bringToFront'. This way, search will be consistent between all
      entry points. LP: #977931
    - Also added proper test suites for the above.
  * lp:~nataliabidart/software-center/fix-965093:
    - Fixed the SpinnerNtebook show_spinner method so the spinner page is
      not shown until the configured threshold is reached (250ms since
      this branch). Plus proper test suite was added.
  * lp:~nataliabidart/software-center/fix-986563:
    - Filtered out those exhibits that do not their packages available
      in the db (LP: #986563)
 -- Michael Vogt <email address hidden> Mon, 04 Jun 2012 08:53:25 +0200

Changed in software-center (Ubuntu Precise):
status: Invalid → Fix Released
swaroopbigboy (swaroopbigboy) wrote :

im Using elementory os Luna & The Same Bug is Making Me Mad is There Any Fix for This one ..?

Changed in software-center (Ubuntu):
assignee: Gary Lasker (gary-lasker) → swaroopbigboy (swaroopbigboy)
Matthew Paul Thomas (mpt) wrote :

swaroopbigboy, this bug was fixed three years ago. If USC crashes for you, please report that bug separately.

Changed in software-center (Ubuntu):
assignee: swaroopbigboy (swaroopbigboy) → Gary Lasker (gary-lasker)
milestone: quantal-alpha-1 → none

 I encountered this when I tried to load ubuntu software center from command prompt,

 please what can I do to fix this?

koha@ubuntu:~$ software-center
2015-10-05 20:55:47,167 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2015-10-05 20:55:47,237 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2015-10-05 20:55:48,423 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2015-10-05 20:55:48,634 - softwarecenter.ui.gtk3.app - INFO - show_available_packages: search_text is '', app is None.
2015-10-05 20:55:48,647 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
Traceback (most recent call last):
  File "/usr/bin/software-center", line 176, in <module>
    app.run(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1422, in run
    self.show_available_packages(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1352, in show_available_packages
    self.view_manager.set_active_view(ViewPages.AVAILABLE)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/viewmanager.py", line 154, in set_active_view
    view_widget.init_view()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/availablepane.py", line 136, in init_view
    SoftwarePane.init_view(self)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/softwarepane.py", line 234, in init_view
    self.datadir)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py", line 883, in __init__
    self._layout_page()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py", line 1182, in _layout_page
    self.pkg_statusbar = PackageStatusBar(self)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py", line 181, in __init__
    self.hbox.pack_end(self.progress, False, False, 0)
AttributeError: 'PackageStatusBar' object has no attribute 'progress'
koha@ubuntu:~$

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers