contact: information not available in "Try Ubuntu" environment

Bug #1979845 reported by Brian Murray
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
snap-store-desktop
New
Undecided
Unassigned
ubuntu-desktop-installer
Triaged
Undecided
Unassigned
livecd-rootfs (Ubuntu)
Invalid
Undecided
Unassigned
Jammy
Invalid
Undecided
Unassigned
snapd (Ubuntu)
Invalid
Undecided
Unassigned
Jammy
Invalid
Undecided
Unassigned
subiquity (Ubuntu)
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Undecided
Dan Bungert

Bug Description

snap info snap-store will show the contact info for the snap-store snap on an installed Ubuntu 22.04 system e.g. contact: https://bugs.launchpad.net/snap-store/. However, when I used the same command on an Ubuntu 22.10 “Kinetic Kudu” image dated 20220608 (in the Try Ubuntu environment) the contact: information was not visible.

The Ubuntu 22.04 system has snapd version 2.55.5+22.04 installed and the live system has snapd version 2.56+22.10 installed.

The contact: information is important because it is used by apport to determine where to file bug reports about the snap.

I also tried an Ubuntu 22.04 LTS final image and contact: information was also missing in the live environment.

Revision history for this message
Brian Murray (brian-murray) wrote :

This also prevents bug reporting about the new desktop installer (with snap name ubuntu-desktop-installer) which may prevent the Ubuntu Desktop team from getting useful feedback about failures to install.

description: updated
Changed in snapd (Ubuntu):
milestone: none → ubuntu-22.10-beta
tags: added: rls-kk-incoming
Alberto Mardegan (mardy)
Changed in snapd (Ubuntu):
status: New → Confirmed
Revision history for this message
Alberto Mardegan (mardy) wrote :

Hi Brian! I do confirm this bug, however it's not clear to me that this an issue in snapd, or what we can do about it. On the live 22.04 system, the installed version of the snap-store snap is 41.3-59, which does not have this info (you might also have noticed that the description is different). If you run

    suso snap refresh snap-store

in the live system, the snap will be updated and will show the contact information. It's simply missing from the older snaps.

I think we need to update the snap-store shipped with the live system, but I'm not sure what launchpad project is the right one. Can you please move it, so that the people who can update the images will be aware of it?

Revision history for this message
Sebastien Bacher (seb128) wrote :

@mardy, you are sure it's the issue? when previous discussed mvo replied

> the contact comes from the store as a "sideinfo" thing, so snapd never talked to the store contacts would be unset

you can try on http://cdimage.ubuntu.com/daily-canary/current/ using ubuntu-desktop-installer which isn't an old revision but matching the current store version

Revision history for this message
Alberto Mardegan (mardy) wrote (last edit ):

Still, even on the latest daily image, the contact information is not there: if you run unsquashfs on /var/lib/snapd/snaps/snap-store_582.snap you will see that there is no contact information in its meta/snap.yaml file.

In the conversation you pointed me to, Sergio from the snapcraft team suggested trying adding the contact information to the "links" section, as documented here: https://forum.snapcraft.io/t/snapcraft-metadata-links/25425

Revision history for this message
Brian Murray (brian-murray) wrote (last edit ):

I didn't mention that this is true of other snaps include on the Ubuntu installer images e.g. firefox and ubuntu-desktop-installer. Given that and what @mardy said perhaps it is something with the image build process stripping the contact information out of the snap.

Additionally, a snap refresh of ubuntu-desktop-installer will make the contact information become available.

Revision history for this message
Paride Legovini (paride) wrote :

This is also the case in the Ubuntu Server installer: no 'contact' field in snap info.

Revision history for this message
Brian Murray (brian-murray) wrote (last edit ):

I also tried installing snap-store version 3.38.0-66-gbd5b8f7 from channel latest/stable (which displays contact information on my installed Jammy system but does not contain a contact url in the snap.yaml file) on a Kinetic daily build dated 20220630 and running `snap info snap-store` still did not display a contact url.

And I installed snap-store version 41.3-60-gfe4703a from channel latest/stable on my Jammy installed system and contact information appears after running `snap info snap-store` but again there is not a contact url in the snap.yaml file on disk. Additionally, on an Ubuntu 22.04 daily build dated 20220701 the live environment does not show contact information after running `snap info snap-store`.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

this entirely due to how free-form preseeded snaps yaml file is generated.

when using snapd tooling to create one, contact-info is extracted and stored inside seed.yaml.

when livecd-rootfs creates preseeding file itself, it doesn't encode such information in the seed.yaml, but it should.

if one doesn't have network connectivity / didn't refresh snaps in the live system, the contact details will not be avaiable.

please fix livecd-rootfs to populate more complete seed.yaml with contact info details. (specifically _snap_preseed function).

Unofortunately, snpad preseed tooling doesn't support incremental add/remove/append snaps to seed.yaml. Hence at the moment it is not possible to replace manual seed.yaml creation in livecd-rootfs with the one provided by snapd tooling. See https://github.com/snapcore/snapd/pull/8791

Revision history for this message
Brian Murray (brian-murray) wrote :

I don't think this is an issue with livecd-rootfs rather as comment #4 indicates the snap is missing contact information in the links session. I convinced myself of that by booting an Ubuntu 22.04 live server image and checking the lxd snap which does have a "contact" section in "links" and ubuntu-bug did use that data to return information.

The attached screenshot contains more details.

Revision history for this message
Brian Murray (brian-murray) wrote (last edit ):

I worked with Dan Bungert to get the subiquity snap updated to include contact information - https://github.com/canonical/subiquity/pull/1365/files . After that he published a new version of subiquity snap and I rebuilt the kinetic live server amd64 image. Booting that image I was then able to use 'ubuntu-bug subiquity' successfully so I think it is up to the maintainers of individual snaps to resolve this issue.

Changed in subiquity (Ubuntu):
status: New → Fix Released
Changed in subiquity (Ubuntu Jammy):
milestone: none → ubuntu-22.04.1
status: New → In Progress
assignee: nobody → Dan Bungert (dbungert)
Changed in livecd-rootfs (Ubuntu):
status: New → Invalid
Changed in livecd-rootfs (Ubuntu Jammy):
status: New → Invalid
Changed in snapd (Ubuntu):
status: Confirmed → Invalid
Changed in snapd (Ubuntu Jammy):
status: New → Invalid
Dan Bungert (dbungert)
Changed in subiquity (Ubuntu Jammy):
status: In Progress → Fix Committed
Dan Bungert (dbungert)
Changed in subiquity (Ubuntu Jammy):
status: Fix Committed → Fix Released
Changed in ubuntu-desktop-installer:
status: New → Triaged
tags: added: rls-ll-incoming
removed: rls-kk-incoming
Revision history for this message
Brian Murray (brian-murray) wrote :

I created an upstream pull request for this https://github.com/canonical/ubuntu-desktop-installer/pull/1236

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers