Snap-store fails to launch - libgtk-3.so.0: undefined symbol: atk_plug_set_child

Bug #1931380 reported by borillionstar
106
This bug affects 22 people
Affects Status Importance Assigned to Milestone
snap-store-desktop
High
Unassigned
snapd (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Software - snap store fails to open

Error shown on terminal:
/snap/snap-store/518/usr/bin/snap-store: symbol lookup error: /snap/snap-store/518/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3.so.0: undefined symbol: atk_plug_set_child

Steps to reproduce:
Click to open snap store from Gnome Activities menu

Correct behavior:
Ubuntu Software (snap-store) should open without any error

Pertinent system info:

Snap-Store Info
snap info snap-store
name: snap-store
summary: Snap Store
publisher: Canonical✓
store-url: https://snapcraft.io/snap-store
license: unset
description: |
  Snap Store allows you to find and install new applications and remove
  existing installed applications.

  Snap Store showcases featured and popular applications with useful
  descriptions and multiple screenshots per application.
  Applications can be found either through browsing the list of categories
  or by searching.
commands:
  - snap-store
  - snap-store.ubuntu-software
  - snap-store.ubuntu-software-local-file
snap-id: gjf3IPXoRiipCu9K0kVu52f0H56fIksg
tracking: latest/stable/ubuntu-21.04
refresh-date: yesterday at 20:34 PDT
channels:
  latest/stable: 3.38.0-59-g494f078 2021-04-20 (518) 53MB -
  latest/candidate: 3.31.1+git189.991d1d1d 2021-04-20 (539) 45MB -
  latest/beta: 3.38.0-62-g77ca0c1 2021-04-20 (538) 53MB -
  latest/edge: 3.38.0-55-geb45541 2021-04-20 (498) 53MB -
installed: 3.38.0-59-g494f078 (518) 53MB -

Output from ldd /snap/bin/snap-store

 linux-vdso.so.1 (0x00007ffe3e1e0000)
 libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f78b3219000)
 libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f78b302d000)
 /lib64/ld-linux-x86-64.so.2 (0x00007f78b3250000)

Output from `uname -a`
Linux bbox 5.11.0-18-generic #19-Ubuntu SMP Fri May 7 14:22:03 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Output from `lsb_release -a`
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 21.04
Release: 21.04
Codename: hirsute

Revision history for this message
borillionstar (babakrezai) wrote :
affects: software-center (Ubuntu) → snap (Ubuntu)
Dylan Aïssi (daissi)
affects: snap (Ubuntu) → snapd (Ubuntu)
Revision history for this message
Norbert (nrbrtx) wrote :

Also seen on https://askubuntu.com/questions/1344650/cant-open-snap-store/1344697 .

The solution is downgrade by:

```
snap remove snap-store
snap install snap-store --candidate
```

tags: added: bionic focal groovy hirsute impish
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in snapd (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx)
Changed in snap-store-desktop:
status: New → Confirmed
Revision history for this message
mevsme (mevsme) wrote :

I have this issue too

````
user@user-MS-7817:~$ snap-store
/snap/snap-store/518/usr/bin/snap-store: symbol lookup error: /snap/snap-store/518/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3.so.0: undefined symbol: atk_plug_set_child
````

Revision history for this message
Qin (qyu) wrote :

Me too, reinstalling doesn't solve the issue:
```
$ snap-store
/snap/snap-store/518/usr/bin/snap-store: symbol lookup error: /snap/snap-store/518/gnome-platform/usr/lib/x86_64-linux-gnu/libgtk-3.so.0: undefined symbol: atk_plug_set_child
```

Revision history for this message
Ian Johnson (anonymouse67) wrote :

This was discussed on Mattermost, and the cause of this is not related to snapd, it is an issue with the snap-store snap.

Changed in snapd (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Ian Johnson (anonymouse67) wrote :

A fix for this is in the beta channel AIUI, you can refresh to try out the fix with:

```
snap refresh snap-store --beta --ignore-running
```

You can omit the --ignore-running if you do not have refresh app awareness enabled.

Revision history for this message
Ian Johnson (anonymouse67) wrote :

As per Ken's comment on the associated forum post, this is actually now on stable, being phased out. You should automatically get the stable refresh within 24 hours, if you don't see it automatically, please wait 24 hours and then try again.

Revision history for this message
iononsbalgiomai (iononsbalgiomai) wrote (last edit ):

I'm on Ubuntu 20.04.2.

Yestarday I've solved the problem by downgrading the Snap Store, as suggested by Norbert.

Today I've reinstalled the stable version and it works well:
```
snap remove snap-store
snap install snap-store

```

The candidate version number was 3.31.2. The stable version number, that I've just installed, is 3.38.1.
The name and icon are that of Ubuntu Software. It runs (no error in the terminal) and works properly.

Revision history for this message
Claudio Corvino (claud81) wrote :

Same as last comment of user iononsbalgiomai for me.
Thanks

Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue has been resolved in stable as well now

Changed in snap-store-desktop:
importance: Undecided → High
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers