[SRU] 2.42.1

Bug #1846181 reported by Michael Vogt on 2019-10-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

This is a new version of snapd.

The changelog is available here https://github.com/snapcore/snapd/blob/2.42.1/packaging/ubuntu-16.04/changelog, the raw git changelog is available here: https://github.com/snapcore/snapd/commits/2.42.1 (note that the debian changelog is auto-generated from the merges of the git commits so there is usually no need to look at the raw git commits).

The travis logs for 2.42.1 can be found here: https://travis-ci.org/snapcore/snapd/branches

The snappy team released a new release that we want SRU into xenial. The new process described in https://wiki.ubuntu.com/SnapdUpdates was used and we have done integration-tests on the snappy images, autopkgtests on classic and unit tests.

TEST CASE (packaging changes):
1. install "old" snapd
2. create /etc/apparmor.d/usr.lib.snapd.snap-confine
3. install the snapd from *-proposed
4. verify that /etc/apparmor.d/usr.lib.snapd.snap-confine got renamed to /etc/apparmor.d/usr.lib.snapd.snap-confine.dpkg-bak

TEST CASE (systemd generator):
1. install the new snapd
2. reboot
3. check that PATH contains /usr/local/bin *and* /snap/bin

The systemd generator is re-enabled in the following PR:
https://github.com/snapcore/snapd/pull/7031/files
This is (spread) tested in https://github.com/snapcore/snapd/blob/2.42.1/tests/main/snap-system-env/task.yaml#L17 - i.e. we ensure the full PATH including local is available and works.

Michael Vogt (mvo) on 2019-10-30
summary: - [SRU] 2.42
+ [SRU] 2.42.1
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.42.1+20.04

---------------
snapd (2.42.1+20.04) focal; urgency=medium

  * New upstream release, LP: #1846181
    - interfaces: de-duplicate emitted update-ns profiles
    - packaging: tweak handling of usr.lib.snapd.snap-confine
    - interfaces: allow introspecting network-manager on core
    - tests/main/interfaces-contacts-service: disable on openSUSE
      Tumbleweed
    - tests/lib/lxd-snapfuse: restore mount changes introduced by LXD
    - snap: fix default-provider in seed validation
    - tests: update system-usernames test now that opensuse-15.1 works
    - overlord: set fake sertial in TestRemodelSwitchToDifferentKernel
    - gadget: rename "boot{select,img}" -> system-boot-{select,image}
    - tests: listing test, make accepted snapd/core versions consistent

 -- Michael Vogt <email address hidden> Wed, 30 Oct 2019 13:17:43 +0100

Changed in snapd (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

My comment from https://bugs.launchpad.net/ubuntu/+source/snapd/+bug/1840740/comments/3 still applies to 2.42: there is now documentation in the changelog, but it still needs a test case.

Changed in snapd (Ubuntu Bionic):
status: New → Incomplete
Changed in snapd (Ubuntu Disco):
status: New → Incomplete
Steve Langasek (vorlon) wrote :

(that refers to the packaging changes for the snap-confine apparmor fixes)

Michael Vogt (mvo) wrote :

Thanks Steve, I added a testcase now.

description: updated
Changed in snapd (Ubuntu Bionic):
status: Incomplete → New
Changed in snapd (Ubuntu Disco):
status: Incomplete → New

Hello Michael, or anyone else affected,

Accepted snapd into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.42.1+19.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in snapd (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
Michael Vogt (mvo) on 2019-11-16
description: updated
Steve Langasek (vorlon) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.42.1+18.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in snapd (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
tags: added: verification-done verification-done-bionic verification-done-disco
removed: verification-needed verification-needed-bionic verification-needed-disco
Timo Aaltonen (tjaalton) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.42.1+19.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in snapd (Ubuntu Eoan):
status: New → Fix Committed
tags: added: verification-needed verification-needed-eoan
removed: verification-done
Timo Aaltonen (tjaalton) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.42.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in snapd (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial

All autopkgtests for the newly accepted snapd (2.42.1+19.10) for eoan have finished running.
The following regressions have been reported in tests triggered by the package:

snapd/2.42.1+19.10 (i386)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/eoan/update_excuses.html#snapd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Steve Langasek (vorlon) wrote :

Marking this incomplete, because I cannot tell from the linked trello card that the additional manual tests for the packaging changes, called out in the bug description, have been completed for this SRU. Sergio, can you please confirm that you've run these tests?

Changed in snapd (Ubuntu Bionic):
status: Fix Committed → Incomplete
Changed in snapd (Ubuntu Disco):
status: Fix Committed → Incomplete

The validation has been completed for bionic and disco.

Tests described on description have been executed and passed.

Tests resutls here: https://trello.com/c/MyxWGYAE/23-snapd-16-2421

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) on 2019-11-26
Changed in snapd (Ubuntu Bionic):
status: Incomplete → Fix Committed
Changed in snapd (Ubuntu Disco):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.42.1+18.04

---------------
snapd (2.42.1+18.04) bionic; urgency=medium

  * New upstream release, LP: #1846181
    - interfaces: de-duplicate emitted update-ns profiles
    - packaging: tweak handling of usr.lib.snapd.snap-confine
    - interfaces: allow introspecting network-manager on core
    - tests/main/interfaces-contacts-service: disable on openSUSE
      Tumbleweed
    - tests/lib/lxd-snapfuse: restore mount changes introduced by LXD
    - snap: fix default-provider in seed validation
    - tests: update system-usernames test now that opensuse-15.1 works
    - overlord: set fake sertial in TestRemodelSwitchToDifferentKernel
    - gadget: rename "boot{select,img}" -> system-boot-{select,image}
    - tests: listing test, make accepted snapd/core versions consistent

 -- Michael Vogt <email address hidden> Wed, 30 Oct 2019 13:17:43 +0100

Changed in snapd (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for snapd has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.42.1+19.04

---------------
snapd (2.42.1+19.04) disco; urgency=medium

  * New upstream release, LP: #1846181
    - interfaces: de-duplicate emitted update-ns profiles
    - packaging: tweak handling of usr.lib.snapd.snap-confine
    - interfaces: allow introspecting network-manager on core
    - tests/main/interfaces-contacts-service: disable on openSUSE
      Tumbleweed
    - tests/lib/lxd-snapfuse: restore mount changes introduced by LXD
    - snap: fix default-provider in seed validation
    - tests: update system-usernames test now that opensuse-15.1 works
    - overlord: set fake sertial in TestRemodelSwitchToDifferentKernel
    - gadget: rename "boot{select,img}" -> system-boot-{select,image}
    - tests: listing test, make accepted snapd/core versions consistent

 -- Michael Vogt <email address hidden> Wed, 30 Oct 2019 13:17:43 +0100

Changed in snapd (Ubuntu Disco):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers