[SRU] 2.35

Bug #1786438 reported by Michael Vogt on 2018-08-10
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
snapd (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

This is a new version of snapd.

The changelog is available here https://github.com/snapcore/snapd/blob/2.35/packaging/ubuntu-16.04/changelog, the raw git changelog is available here: https://github.com/snapcore/snapd/commits/2.35 (note that the debian changelog is auto-generated from the merges of the git commits so there is usually no need to look at the raw git commits).

The travis logs for 2.35 can be found here: https://travis-ci.org/snapcore/snapd/branches

We currently have no autopkgtest logs before snapd hits -proposed because we got asked to disable our autopkgtest integration as it was using too many resources from the autopkgtest infrastructure.

The snappy team released a new release that we want SRU into xenial. The new process described in https://wiki.ubuntu.com/SnapdUpdates was used and we have done integration-tests on the snappy images, autopkgtests on classic and unit tests.

Julian Andres Klode (juliank) wrote :

This release causes a lot of warnings on apt, as it expects the packages array to be an array of strings, but it's an array of package objects.

Julian Andres Klode (juliank) wrote :

(the ~pre1)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.35~pre3+18.10.5

---------------
snapd (2.35~pre3+18.10.5) cosmic; urgency=medium

  * tests: fix autopkgtest errors

 -- Michael Vogt <email address hidden> Thu, 16 Aug 2018 09:39:53 +0200

Changed in snapd (Ubuntu):
status: New → Fix Released
Łukasz Zemczak (sil2100) wrote :

Are snapd SRU bugs always only with 'placeholder' description? It's hard to review this way. The SnapdUpdates exception page [1] mentions that the description should include results of automated test results + manual ones. Pushing back until the required information is filled in.

[1] https://wiki.ubuntu.com/SnapdUpdates

Michael Vogt (mvo) wrote :

@sil2100 sorry for that, I updated the description now.

description: updated
Steve Langasek (vorlon) wrote :

> We currently have no autopkgtest logs before snapd hits -proposed
> because we got asked to disable our autopkgtest integration as it
> was using too many resources from the autopkgtest infrastructure.

Since upstream's CI no longer includes checking against Ubuntu as a baseline, this increases the risk that the SRU will stall due to failed autopkgtests in -proposed. However, this is not a blocker for accepting the SRU, it is only a blocker for it being released, so this is an assumed risk.

Changed in snapd (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

Hello Michael, or anyone else affected,

Accepted snapd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.35.1+18.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in snapd (Ubuntu Trusty):
status: New → Confirmed
Changed in snapd (Ubuntu Xenial):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers