[SRU] 2.34.2

Bug #1779403 reported by Michael Vogt on 2018-06-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

This is a new version of snapd.

The changelog is available here https://github.com/snapcore/snapd/blob/2.34.2/packaging/ubuntu-16.04/changelog, the raw git changelog is available here: https://github.com/snapcore/snapd/commits/2.34.2 (note that the debian changelog is auto-generated from the merges of the git commits so there is usually no need to look at the raw git commits).

The travis logs for 2.34.2 can be found here: https://travis-ci.org/snapcore/snapd/branches

We currently have no autopkgtest logs before snapd hits -proposed because we got asked to disable our autopkgtest integration as it was using too many resources from the autopkgtest infrastructure.

The snappy team released a new release that we want SRU into xenial. The new process described in https://wiki.ubuntu.com/SnapdUpdates was used and we have done integration-tests on the snappy images, autopkgtests on classic and unit tests.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.34~pre1+18.10.2

---------------
snapd (2.34~pre1+18.10.2) cosmic; urgency=medium

  * New git snapshot to fix autopkgtest failures

 -- Michael Vogt <email address hidden> Thu, 05 Jul 2018 15:36:59 +0200

Changed in snapd (Ubuntu):
status: New → Fix Released
Michael Vogt (mvo) on 2018-07-18
description: updated

Hello Michael, or anyone else affected,

Accepted snapd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.34.2+18.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in snapd (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in snapd (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Andy Whitcroft (apw) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.34.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in snapd (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed-trusty
Andy Whitcroft (apw) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.34.2~14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Michael Vogt (mvo) on 2018-07-20
summary: - [SRU] 2.34
+ [SRU] 2.34.2
description: updated
tags: added: verification-done verification-done-bionic verification-done-trusty verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-trusty verification-needed-xenial

The verification of the Stable Release Update for snapd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :
Download full text (13.2 KiB)

This bug was fixed in the package snapd - 2.34.2+18.04

---------------
snapd (2.34.2+18.04) bionic; urgency=medium

  * New upstream release, LP: #1779403
    - packaging: fix bogus date in fedora snapd.spec
    - tests: fix tests expecting old email address

snapd (2.34.1) xenial; urgency=medium

  * New upstream release, LP: #1779403
    - tests: cherry-pick test fixes from master for 2.34
    - coreconfig: add support for `snap set system network.disable-
      ipv6`
    - debian: do not ship snapd.apparmor.service on ubuntu
    - overlord/snapstate: dedupe default content providers
    - interfaces/builtin: create can-bus interface

snapd (2.34) xenial; urgency=medium

  * New upstream release, LP: #1779403
    - store, daemon, client, cmd/snap: expose "scope", default to wide*
    - tests: fix arch tests
    - snapstate: make sure all *link-*snap tasks carry a snap type and
      further hints
    - snapstate: allow setting "refresh.timer=managed"
    - cmd/snap: display a link to data privacy notice for interactive
      snap login
    - devicestate: fix race when refreshing a snap with snapd-control
    - tests: skip interfaces-framebuffer when no /dev/fb0 is found
    - tests: run interfaces-contacts-service only where test-snapd-eds
      is available
    - many: expose publisher's validation throughout the API
    - many: use extra "releases" information on store "revision-not-
      found" errors to produce better errors
    - dirs: improve distro detection for Antegros
    - Revert "dirs: improve identification of Arch Linux like systems"
    - devicestate: fix panic in firstboot code when no snaps are seeded
    - i18n: use xgettext-go --files-from to avoid running into cmdline
      size limits
    - interfaces: move ValidateName helper to utils
    - snapstate,ifstate: wait for pending restarts before auto-
      connecting
    - snap: account for parallel installs in wrappers, place info and
      tests
    - configcore: fix incorrect handling of keys with numbers (like
      gpu_mem_512)
    - tests: fix tests when no keyboard input detected
    - overlord/configstate: add watchdog options
    - snap-mgmt: fix for non-existent dbus system policy dir,
      shellchecks
    - tests/main/snapd-notify: use systemd's service properties rater
      than the journal
    - snapstate: allow removal of snap.TypeOS when using a model with a
      base
    - interfaces: make findSnapdPath smarter
    - tests: run "arp" tests only if arp is available
    - spread: increase the number of auto retries for package downloads
      in opensuse
    - cmd/snap-confine: fix nvidia support under lxd
    - corecfg: added experimental.hotplug feature flag
    - image: block installation of parallel snap instances
    - interfaces: moved normalize method to interfaces/utils and made it
      public
    - api/snapctl: allow -h and --help for regular users.
    - interfaces/udisks2: also implement implicit classic slot
    - cmd/snap-confine: include CUDA runtime libraries
    - tests: disable auto-refresh test on core18
    - many: switch to account validation: unproven|verified
    - overlord/ifacestate: get/set connection state only via helpers
   ...

Changed in snapd (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (13.1 KiB)

This bug was fixed in the package snapd - 2.34.2

---------------
snapd (2.34.2) xenial; urgency=medium

  * New upstream release, LP: #1779403
    - packaging: fix bogus date in fedora snapd.spec
    - tests: fix tests expecting old email address

snapd (2.34.1) xenial; urgency=medium

  * New upstream release, LP: #1779403
    - tests: cherry-pick test fixes from master for 2.34
    - coreconfig: add support for `snap set system network.disable-
      ipv6`
    - debian: do not ship snapd.apparmor.service on ubuntu
    - overlord/snapstate: dedupe default content providers
    - interfaces/builtin: create can-bus interface

snapd (2.34) xenial; urgency=medium

  * New upstream release, LP: #1779403
    - store, daemon, client, cmd/snap: expose "scope", default to wide*
    - tests: fix arch tests
    - snapstate: make sure all *link-*snap tasks carry a snap type and
      further hints
    - snapstate: allow setting "refresh.timer=managed"
    - cmd/snap: display a link to data privacy notice for interactive
      snap login
    - devicestate: fix race when refreshing a snap with snapd-control
    - tests: skip interfaces-framebuffer when no /dev/fb0 is found
    - tests: run interfaces-contacts-service only where test-snapd-eds
      is available
    - many: expose publisher's validation throughout the API
    - many: use extra "releases" information on store "revision-not-
      found" errors to produce better errors
    - dirs: improve distro detection for Antegros
    - Revert "dirs: improve identification of Arch Linux like systems"
    - devicestate: fix panic in firstboot code when no snaps are seeded
    - i18n: use xgettext-go --files-from to avoid running into cmdline
      size limits
    - interfaces: move ValidateName helper to utils
    - snapstate,ifstate: wait for pending restarts before auto-
      connecting
    - snap: account for parallel installs in wrappers, place info and
      tests
    - configcore: fix incorrect handling of keys with numbers (like
      gpu_mem_512)
    - tests: fix tests when no keyboard input detected
    - overlord/configstate: add watchdog options
    - snap-mgmt: fix for non-existent dbus system policy dir,
      shellchecks
    - tests/main/snapd-notify: use systemd's service properties rater
      than the journal
    - snapstate: allow removal of snap.TypeOS when using a model with a
      base
    - interfaces: make findSnapdPath smarter
    - tests: run "arp" tests only if arp is available
    - spread: increase the number of auto retries for package downloads
      in opensuse
    - cmd/snap-confine: fix nvidia support under lxd
    - corecfg: added experimental.hotplug feature flag
    - image: block installation of parallel snap instances
    - interfaces: moved normalize method to interfaces/utils and made it
      public
    - api/snapctl: allow -h and --help for regular users.
    - interfaces/udisks2: also implement implicit classic slot
    - cmd/snap-confine: include CUDA runtime libraries
    - tests: disable auto-refresh test on core18
    - many: switch to account validation: unproven|verified
    - overlord/ifacestate: get/set connection state only via helpers
    - tests: ad...

Changed in snapd (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (13.2 KiB)

This bug was fixed in the package snapd - 2.34.2~14.04

---------------
snapd (2.34.2~14.04) trusty; urgency=medium

  * New upstream release, LP: #1779403
    - packaging: fix bogus date in fedora snapd.spec
    - tests: fix tests expecting old email address

snapd (2.34.1~14.04) trusty; urgency=medium

  * New upstream release, LP: #1779403
    - tests: cherry-pick test fixes from master for 2.34
    - coreconfig: add support for `snap set system network.disable-
      ipv6`
    - debian: do not ship snapd.apparmor.service on ubuntu
    - overlord/snapstate: dedupe default content providers
    - interfaces/builtin: create can-bus interface

snapd (2.34~14.04) trusty; urgency=medium

  * New upstream release, LP: #1779403
    - store, daemon, client, cmd/snap: expose "scope", default to wide*
    - tests: fix arch tests
    - snapstate: make sure all *link-*snap tasks carry a snap type and
      further hints
    - snapstate: allow setting "refresh.timer=managed"
    - cmd/snap: display a link to data privacy notice for interactive
      snap login
    - devicestate: fix race when refreshing a snap with snapd-control
    - tests: skip interfaces-framebuffer when no /dev/fb0 is found
    - tests: run interfaces-contacts-service only where test-snapd-eds
      is available
    - many: expose publisher's validation throughout the API
    - many: use extra "releases" information on store "revision-not-
      found" errors to produce better errors
    - dirs: improve distro detection for Antegros
    - Revert "dirs: improve identification of Arch Linux like systems"
    - devicestate: fix panic in firstboot code when no snaps are seeded
    - i18n: use xgettext-go --files-from to avoid running into cmdline
      size limits
    - interfaces: move ValidateName helper to utils
    - snapstate,ifstate: wait for pending restarts before auto-
      connecting
    - snap: account for parallel installs in wrappers, place info and
      tests
    - configcore: fix incorrect handling of keys with numbers (like
      gpu_mem_512)
    - tests: fix tests when no keyboard input detected
    - overlord/configstate: add watchdog options
    - snap-mgmt: fix for non-existent dbus system policy dir,
      shellchecks
    - tests/main/snapd-notify: use systemd's service properties rater
      than the journal
    - snapstate: allow removal of snap.TypeOS when using a model with a
      base
    - interfaces: make findSnapdPath smarter
    - tests: run "arp" tests only if arp is available
    - spread: increase the number of auto retries for package downloads
      in opensuse
    - cmd/snap-confine: fix nvidia support under lxd
    - corecfg: added experimental.hotplug feature flag
    - image: block installation of parallel snap instances
    - interfaces: moved normalize method to interfaces/utils and made it
      public
    - api/snapctl: allow -h and --help for regular users.
    - interfaces/udisks2: also implement implicit classic slot
    - cmd/snap-confine: include CUDA runtime libraries
    - tests: disable auto-refresh test on core18
    - many: switch to account validation: unproven|verified
    - overlord/ifacestate: get/set connection state only via...

Changed in snapd (Ubuntu Trusty):
status: Fix Committed → Fix Released

Hello Michael, or anyone else affected,

Accepted snapd into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.35.2~14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in snapd (Ubuntu Trusty):
status: Fix Released → Fix Committed
tags: added: verification-needed verification-needed-trusty
removed: verification-done verification-done-trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers