some snaps fail on vulkan/icd.d permission error

Bug #1758888 reported by Sam Van den Eynde on 2018-03-26
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
snapd (Ubuntu)
Undecided
Maciej Borzecki

Bug Description

Ubuntu Artful, fully upgraded, standard flavor.

Error when running telegram or hello-world snap:

"failed to create prefix path: /tmp/snap.rootfs_xUQUrs/var/lib/snapd/lib/vulkan/icd.d: Permission denied"

Relevant entry appearing in dmesg:

[ 1212.813285] audit: type=1400 audit(1522065269.155:123): apparmor="DENIED" operation="capable" profile="/snap/core/4308/usr/lib/snapd/snap-confine" pid=8454 comm="snap-confine" capability=2 capname="dac_read_search"
[ 1212.816079] audit: type=1400 audit(1522065269.158:124): apparmor="DENIED" operation="open" profile="/snap/core/4308/usr/lib/snapd/snap-confine" name="/tmp/snap.rootfs_ztvKAh/" pid=8454 comm="snap-confine" requested_mask="r" denied_mask="r" fsuid=0 ouid=0

I found a similar error for filebot:

http://forum.ubuntu-fr.org/viewtopic.php?id=2024056

I used Telegram snap on this system before. Skype is now working, as is Slack. Last week or so Skype was broken, but Telegram worked.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: snapd 2.29.4.2+17.10 [modified: lib/systemd/system/snapd.service usr/share/dbus-1/services/io.snapcraft.Launcher.service]
ProcVersionSignature: Ubuntu 4.13.0-37.42-generic 4.13.13
Uname: Linux 4.13.0-37-generic x86_64
NonfreeKernelModules: nvidia_uvm zfs zunicode zavl zcommon znvpair nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Mar 26 13:48:13 2018
JournalErrors:
 Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] failed with exit code 1: Failed to search journal ACL: Operation not supported
 No journal files were opened due to insufficient permissions.
SourcePackage: snapd
UpgradeStatus: Upgraded to artful on 2017-09-03 (203 days ago)

Sam Van den Eynde (samvde) wrote :
Changed in snapd (Ubuntu):
status: New → In Progress
assignee: nobody → Maciej Borzecki (maciek-borzecki)
Changed in snapd (Ubuntu):
status: In Progress → Fix Committed

The bug occurs in Ubuntu 18.04 Bionic Beaver with the obs-studio and simply-fortran packages

Krish De Souza (kd913) on 2018-04-03
Changed in snapd (Ubuntu):
status: Fix Committed → Fix Released
Krish De Souza (kd913) wrote :

Sorry I didn't mean to reassign the bug, that was an accidental click.

Jonatan Ayllón (jonatanayllon) wrote :

I try to execute: gnome-system-monitor
And this is the result
failed to create prefix path: /tmp/snap.rootfs_4qMMlN/var/lib/snapd/lib/vulkan/icd.d: Permission denied

Jonatan Ayllón (jonatanayllon) wrote :

After a recent update the problem is solved

The problem is still in Ubuntu 18.04

Dylan Taylor (dylanmtaylor) wrote :

I am having this issue right now with the GitKraken snap in 18.04

Dylan Taylor (dylanmtaylor) wrote :

dtaylor@Dylan-Precision-5510:~$ gitkraken
failed to create prefix path: /tmp/snap.rootfs_5CVsL3/var/lib/snapd/lib/vulkan/icd.d: Permission denied

I get it with the circleci snap.

$ snap --version
snap 2.32+18.04
snapd 2.32+18.04
series 16
ubuntu 18.04
kernel 4.15.0-13-generic

You need to do `snap refresh --beta core` for now. Hopefully it's not long before it's in the stable channel.

Works for me

Richard van Liessum (rliessum) wrote :

Works for me to on Bionic proposed.

Luke B. (duke7553) wrote :

The 'snap refresh --beta core' command resolves this bug.

Luke B. (duke7553) wrote :

My problem was with the Spotify snap.

Dustin Krysak (bashfulrobot) wrote :

I just had this as well on 18.04 - Daily build as of yesterday. Both the Spotify snap and the telegram snap. The proposed beta refresh did resolve the issue.

The 'snap refresh --beta core' command resolves this bug.

work here too. ty guys.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers