mounts should hint ignore

Bug #1714941 reported by Harald Sitter
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
snapd
Undecided
Unassigned
snapd (Ubuntu)
Undecided
Unassigned

Bug Description

$ qdbus --system org.freedesktop.UDisks2 /org/freedesktop/UDisks2/block_devices/loop9 org.freedesktop.UDisks2.Block.HintIgnore
false

Currently, the loopback mounts of the snaps are not properly marked as ignore for udisks2 which results in them being listed in various UIs listing volumes from udisks.

One would expect them to have the HintIgnore property set to true [1] which is set via the UDISKS_IGNORE property in udev [2], supposedly snapd should come with it is own udev rule to set that property.

[1] http://storaged.org/doc/udisks2-api/latest/gdbus-org.freedesktop.UDisks2.Block.html#gdbus-property-org-freedesktop-UDisks2-Block.HintIgnore
[2] http://storaged.org/doc/udisks2-api/latest/udisks.8.html

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in snapcraft (Ubuntu):
status: New → Confirmed
affects: snapcraft (Ubuntu) → snapd (Ubuntu)
Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Dear reporter.

The mount and loopback device is created by libmount, through systemd. Do you know if there's a way for snapd to indicate that the loop device should be created with that attribute?

Revision history for this message
Maciej Borzecki (maciek-borzecki) wrote :

AFAIU this bug is already fixed. Snapd adds x-gdu.hide to mount options for snaps, and they are no longer visible in gnome disks utility.

Not sure why, but with udisks 2.9.2 I still see HintIgnore as false in my system. However, the `udisksctl status` only shows the actual disks so maybe it's handled elsewhere.

Please reopen if this is still a problem.

Changed in snapd (Ubuntu):
status: Confirmed → Fix Released
Changed in snapd:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers