SRU tracker 2.22.6

Bug #1667105 reported by Zygmunt Krynicki on 2017-02-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

New bugfix release of snapd 2.22.

[Impact]
* There are a small number systems in the wild that misbehave on upgrades. To track down the root cause we added better debugging and support to report errors to errrors.ubuntu.com

[Test case]
* A test for regressions is sufficient. The full testsuite with >100 integration tests is run automatically.

[Regression potential]
* little, pretty much all changes happen in code that is already a failure condition

Michael Vogt (mvo) on 2017-02-23
description: updated
Brian Murray (brian-murray) wrote :

2.22.26 is still in -proposed for Zesty at this point in time.

Hello Zygmunt, or anyone else affected,

Accepted snapd into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.22.6+16.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in snapd (Ubuntu Yakkety):
status: New → Fix Committed
tags: added: verification-needed
Andy Whitcroft (apw) wrote :

The version in zesty is stuck for bug: #1666897. This bug is very possibly a kernel regression. To allow this to be diagnosed it is helpful to test this same snapd against the kernel in another series. For this reason I am letting it into yakkety-proposed for this testing. We need to confirm it gets out of zesty-proposed before allowing it to be released.

Andy Whitcroft (apw) wrote :

Ok it is confirmed that the issue is an expected change in the kernel in zesty. This is coming to kernels in all series real soon. That said the issue will affect the current snapd as much as the one in unapproved therefore we can accept those.

Changed in snapd (Ubuntu Xenial):
status: New → Fix Committed
Andy Whitcroft (apw) wrote :

Hello Zygmunt, or anyone else affected,

Accepted snapd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.22.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in snapd (Ubuntu):
status: New → Incomplete
status: Incomplete → Fix Committed
Changed in snapd (Ubuntu Trusty):
status: New → Fix Committed
Andy Whitcroft (apw) wrote :

Hello Zygmunt, or anyone else affected,

Accepted snapd into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.22.6~14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.22.7+17.04

---------------
snapd (2.22.7+17.04) zesty; urgency=medium

  * New upstream release:
    - errtracker,overlord/snapstate: more info in errtracker reports
    - interfaces/apparmor: compensate for kernel behavior change

 -- Michael Vogt <email address hidden> Fri, 24 Feb 2017 19:24:11 +0100

Changed in snapd (Ubuntu):
status: Fix Committed → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

verification done on xenial and yakkety. The following configuration have been tested:
- snapd from updates + core from candidate
- snapd upgraded from updates to proposed + core from stable
- snapd upgraded from updates to proposed + core from candidate

Spread tests have been executed successfully after upgrade to proposed on kvm i386 and amd64.

verification done for xenial and yakkety.

tags: added: verification-done-xenial verification-done-yakkety
Jean-Baptiste Lallement (jibel) wrote :

Tests of linux-meta-hwe/4.8.0.40.11 are failing because of snapd 2.22.6 [1]. It's probably better to upload and test 2.22.7 instead.

[1] http://autopkgtest.ubuntu.com/packages/snapd/xenial/amd64

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.22.6+16.10

---------------
snapd (2.22.6+16.10) yakkety; urgency=medium

  * New upstream release, LP: #1667105
    - overlord/ifacestate: don't fail if affected snap is gone
    - revert #2910: osutil: add package for reading Build-ID (#2918)
    - errtracker: include the build-id of host and core snapd (#2912)
    - errtracker: include the number of ubuntu-core -> core retries
      (#2915)
    - snapstate: retry ubuntu-core -> core transition every 6h (#2914)
    - osutil: add package for reading Build-ID (#2910)
    - errtracker: include kernel version in error reports (#2905)
    - release: return "unknown" if uname fails
    - many: rebased uname branch for 2.22
    - errtracker: include snapd version in err reports
    - overlord/ifacestate: don't unconditionally retry stuff (#2906)
    - snapstate: fix incorrect cut of the timestamps for the error
      reports (#2908)
    - tests: update listing test for latest core snap version update

snapd (2.22.5) xenial; urgency=medium

  * Fix FTBFS due to machine-id file

snapd (2.22.4) xenial; urgency=medium

  * New bugfix release:
    - errtracker: add support for error reporting via daisy.ubuntu.com
    - snapstate: allow for 6 retries for the core transition
    - httputils: ensure User-Agent works across redirects

 -- Zygmunt Krynicki <email address hidden> Wed, 22 Feb 2017 23:34:23 +0100

Changed in snapd (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.22.6

---------------
snapd (2.22.6) xenial; urgency=medium

  * New upstream release, LP: #1667105
    - overlord/ifacestate: don't fail if affected snap is gone
    - revert #2910: osutil: add package for reading Build-ID (#2918)
    - errtracker: include the build-id of host and core snapd (#2912)
    - errtracker: include the number of ubuntu-core -> core retries
      (#2915)
    - snapstate: retry ubuntu-core -> core transition every 6h (#2914)
    - osutil: add package for reading Build-ID (#2910)
    - errtracker: include kernel version in error reports (#2905)
    - release: return "unknown" if uname fails
    - many: rebased uname branch for 2.22
    - errtracker: include snapd version in err reports
    - overlord/ifacestate: don't unconditionally retry stuff (#2906)
    - snapstate: fix incorrect cut of the timestamps for the error
      reports (#2908)
    - tests: update listing test for latest core snap version update

snapd (2.22.5) xenial; urgency=medium

  * Fix FTBFS due to machine-id file

snapd (2.22.4) xenial; urgency=medium

  * New bugfix release:
    - errtracker: add support for error reporting via daisy.ubuntu.com
    - snapstate: allow for 6 retries for the core transition
    - httputils: ensure User-Agent works across redirects

 -- Zygmunt Krynicki <email address hidden> Wed, 22 Feb 2017 23:34:23 +0100

Changed in snapd (Ubuntu Xenial):
status: Fix Committed → Fix Released

Verified on trusty too. autopkgtest fails but spread tests alone pass. Upgrading from 2.22.3 to 2.22.6 in proposed then running spread tests passes too.

verification-done

tags: added: verification-done
removed: verification-done-xenial verification-done-yakkety verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.22.6~14.04

---------------
snapd (2.22.6~14.04) trusty; urgency=medium

  * New upstream release, LP: #1667105
    - overlord/ifacestate: don't fail if affected snap is gone
    - revert #2910: osutil: add package for reading Build-ID (#2918)
    - errtracker: include the build-id of host and core snapd (#2912)
    - errtracker: include the number of ubuntu-core -> core retries
      (#2915)
    - snapstate: retry ubuntu-core -> core transition every 6h (#2914)
    - osutil: add package for reading Build-ID (#2910)
    - errtracker: include kernel version in error reports (#2905)
    - release: return "unknown" if uname fails
    - many: rebased uname branch for 2.22
    - errtracker: include snapd version in err reports
    - overlord/ifacestate: don't unconditionally retry stuff (#2906)
    - snapstate: fix incorrect cut of the timestamps for the error
      reports (#2908)
    - tests: update listing test for latest core snap version update

snapd (2.22.5~14.04) trusty; urgency=medium

  * Fix FTBFS due to machine-id file

snapd (2.22.4~14.04) trusty; urgency=medium

  * New bugfix release:
    - errtracker: add support for error reporting via daisy.ubuntu.com
    - snapstate: allow for 6 retries for the core transition
    - httputils: ensure User-Agent works across redirects

 -- Zygmunt Krynicki <email address hidden> Wed, 22 Feb 2017 23:34:23 +0100

Changed in snapd (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for snapd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers