Comment 8 for bug 1592696

For the workaround, simply use:
$ sudo apparmor_parser -r /etc/apparmor.d/usr.bin.ubuntu-core-launcher

No need to reboot and no need to install apparmor-utils.

As for the timing of the fix-- the snappy team is making some fairly large changes to the launcher which is why the fix for this is not present yet in 16.04. The fix is queued though and I'm told the launcher changes will land with snapd 2.0.9 or possibly 2.0.10 (ie, either the next SRU or the one immediately following).