Add support for epoch property

Bug #1583298 reported by Kyle Fazzari on 2016-05-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
click-reviewers-tools (Ubuntu)
Undecided
Jamie Strandboge
Xenial
Undecided
Jamie Strandboge
Yakkety
Undecided
Jamie Strandboge
snapd (Ubuntu)
Wishlist
Kyle Fazzari
Xenial
Undecided
Unassigned
Yakkety
Wishlist
Kyle Fazzari

Bug Description

In order to support step upgrades, snaps need to be able to specify upgrade paths. The method decided upon to specify said upgrade paths is an optional "epoch" property. Valid values consist of positive integers and an asterisk (e.g. 1 is epoch 1, 1* is the upgrade path from 1 to 2, and 2 is epoch 2). If the epoch is not specified, it should implicitly be 0.

Example YAML:

    name: foo
    version: 1
    description: foo
    summary: foo
    epoch: 1*

Note that the API for providing this to the store does not yet exist, so this bug only covers the parsing of this information from the `snap.yaml`.

Kyle Fazzari (kyrofa) wrote :

Note that this is closely related to https://bugs.launchpad.net/snapcraft/+bug/1581113 for snapcraft. They're kept separate to make the SRUs easier to test.

Kyle Fazzari (kyrofa) on 2016-05-18
description: updated
Kyle Fazzari (kyrofa) wrote :
Changed in snapd (Ubuntu):
assignee: nobody → Kyle Fazzari (kyrofa)
status: New → In Progress
importance: Undecided → Wishlist
Kyle Fazzari (kyrofa) on 2016-05-19
description: updated
Kyle Fazzari (kyrofa) on 2016-05-24
Changed in snapd (Ubuntu):
status: In Progress → Fix Committed

Hello Kyle, or anyone else affected,

Accepted click-reviewers-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/click-reviewers-tools/0.43~14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Jamie Strandboge (jdstrand) wrote :

$ click-review -v /tmp/foo_1.0_amd64.snap
...
 - lint-snap-v2:epoch_valid
 OK

$ cat meta/snap.yaml
apps:
  bar:
    command: bin/bar
architectures:
- amd64
description: 'stuff here'
name: foo
plugs:
  opengl: null
  pulseaudio: null
  unity7: null
summary: stuff
version: 1.0
epoch: 2

tags: added: verification-done
removed: verification-needed
Changed in click-reviewers-tools (Ubuntu Yakkety):
status: New → Fix Released
Changed in click-reviewers-tools (Ubuntu Xenial):
status: New → Fix Committed
Changed in click-reviewers-tools (Ubuntu Yakkety):
assignee: nobody → Jamie Strandboge (jdstrand)
Changed in click-reviewers-tools (Ubuntu Xenial):
assignee: nobody → Jamie Strandboge (jdstrand)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package click-reviewers-tools - 0.43~14.04.1

---------------
click-reviewers-tools (0.43~14.04.1) xenial-proposed; urgency=medium

  [ Jamie Strandboge ]
  * sr_lint.py:
    - kernel snaps may have external symlinks
    - handle top-level plugs and slots with yaml data as 'null' (LP: #1579201)
    - add epoch checks (LP: #1583298)
    - .pyc are arch-independent, so don't complain about them
    - add confinement checks (LP: #1580819)
  * data/apparmor-easyprof-ubuntu.json:
    - add opengl interface as 'common' (LP: #1572140)
    - add reserved bluez, network-manager and location-observe interfaces
  * sr_security.py:
    - remove last reference to 'cap'
    - turn resquash test into info for now until the squashfs-tools bugs are
      fixed and this is a reliable check
  * when 'confinement' is 'devmode', override the result type to 'info'
    - common.py: add override_result_type to allow in support of 'confinement'
      overrides
    - sr_common.py: add _devmode_override()
    - sr_security.py: use override_result_type if in devmode
    - LP: #1584231

 -- Jamie Strandboge <email address hidden> Fri, 20 May 2016 16:06:55 -0500

Changed in click-reviewers-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for click-reviewers-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Michael Vogt (mvo) on 2017-01-27
Changed in snapd (Ubuntu Xenial):
status: New → Fix Released
Changed in snapd (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Changed in snapd (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers