Name unversioned data directories

Bug #1577549 reported by Kyle Fazzari on 2016-05-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
snapd (Ubuntu)
Wishlist
Kyle Fazzari

Bug Description

Snappy recently added support for data directories that were common across all versions of a given snap. Two of these directories are supported, one system-wide (similar to SNAP_DATA) and one user-specific (similar to SNAP_USER_DATA). These directories are located at $SNAP_DATA/../common and $SNAP_USER_DATA/../common, respectively. However, these directories are as yet unnamed, and need to be represented by environment variables in the launchers (both the binary wrappers and the systemd .service files).

Kyle Fazzari (kyrofa) on 2016-05-02
affects: ubuntu-core-launcher → snappy
Kyle Fazzari (kyrofa) on 2016-06-09
affects: snappy → snapd (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in snapd (Ubuntu):
status: New → Confirmed
Kyle Fazzari (kyrofa) wrote :

Ping? This would be quite easy now that snapenv has been refactored, we just need a name.

Kyle Fazzari (kyrofa) wrote :

Hmm... how would you put those alongside SNAP_DATA and SNAP_USER_DATA? SNAP_UNMANAGED_DATA and SNAP_USER_UNMANAGED_DATA?

Kyle Fazzari (kyrofa) wrote :

Other options:

SNAP_COMMON_DATA/SNAP_USER_COMMON_DATA (makes sense given the directory is named "common")
SNAP_UNVERSIONED_DATA/SNAP_USER_UNVERSIONED_DATA

Bruno Nova (brunonova) wrote :

(Not an Ubuntu Developer)
Why not "unversioned"? SNAP_UNVERSIONED_DATA and SNAP_USER_UNVERSIONED_DATA?
Or "common".

Bruno Nova (brunonova) wrote :

Oh, we were writing a comment at the same time... :)

Manik Taneja (manik) wrote :

SNAP_SHARED_DATA/SNAP_USER_SHARED_DATA?

Kyle Fazzari (kyrofa) wrote :

Gustavo has requested SNAP_COMMON/SNAP_USER_COMMON. Implemented here: https://github.com/snapcore/snapd/pull/1396

Changed in snapd (Ubuntu):
importance: Undecided → Wishlist
assignee: nobody → Kyle Fazzari (kyrofa)
status: Confirmed → In Progress
Kyle Fazzari (kyrofa) on 2016-06-23
Changed in snapd (Ubuntu):
status: In Progress → Fix Committed
Mark Shuttleworth (sabdfl) wrote :

Great choice, thank you.

Michael Vogt (mvo) on 2017-01-27
Changed in snapd (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers