"Ubuntu Core Snappy AutoUpdate" service failed with "error: the required argument `<snap>` was not provided"

Bug #1577228 reported by V字龍(Vdragon)
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Snappy
High
Unassigned
snapd (Ubuntu)
High
Unassigned

Bug Description

I noticed that the snappy-autopilot service failed in `systemctl list-units` with the following status, that's all I know.

`````
● snappy-autopilot.service - Ubuntu Core Snappy AutoUpdate
   Loaded: loaded (/lib/systemd/system/snappy-autopilot.service; static; vendor preset: enabled)
   Active: failed (Result: exit-code) since 一 2016-05-02 02:12:14 CST; 46min ago
 Main PID: 1242 (code=exited, status=1/FAILURE)

 5月 02 02:12:13 buo-ren-ssda systemd[1]: Started Ubuntu Core Snappy AutoUpdate.
 5月 02 02:12:14 buo-ren-ssda snap[1242]: error: the required argument `<snap>` was not provided
 5月 02 02:12:14 buo-ren-ssda systemd[1]: snappy-autopilot.service: Main process exited, code=exited, status=1/FAILURE
 5月 02 02:12:14 buo-ren-ssda systemd[1]: snappy-autopilot.service: Unit entered failed state.
 5月 02 02:12:14 buo-ren-ssda systemd[1]: snappy-autopilot.service: Failed with result 'exit-code'.

`````

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: snapd 2.0.2
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Mon May 2 02:59:27 2016
InstallationDate: Installed on 2016-01-07 (114 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: snapd
UpgradeStatus: Upgraded to xenial on 2016-04-07 (24 days ago)

Revision history for this message
V字龍(Vdragon) (vdragon) wrote :
Michael Vogt (mvo)
Changed in snappy:
status: New → Triaged
importance: Undecided → High
milestone: none → sru-2
Changed in snapd (Ubuntu):
status: New → Triaged
importance: Undecided → High
summary: - "Ubuntu Core Snappy AutoUpdate" service failed with
+ "Ubuntu Core Snappy AutoUpdate" service failed with "error: the required
+ argument `<snap>` was not provided"
Revision history for this message
Terupo Teuri (terupoteuri) wrote :

Hi, I'm having problem trying to install snappy-debug and many other programs, due to incorrect email or password.
error: the required argument `<email>` was not provided

Revision history for this message
Michael Vogt (mvo) wrote :

This if fixed in ubuntu core 16

Changed in snapd (Ubuntu):
status: Triaged → Fix Released
Changed in snappy:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers