change finished in status "Hold" with no error message

Bug #1572175 reported by Daniel Holbach
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Snappy
Undecided
Unassigned
snapd (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

daniel@daydream:/tmp/2048.qml$ sudo snap install 2048-qml_1_amd64.snap

error: change finished in status "Hold" with no error message
daniel@daydream:/tmp/2048.qml$ cat snapcraft.yaml
name: 2048-qml
version: 1
summary: 2048 clone written in pure QML. No C++ wrappers needed.
description: |
  To do:
  Animations kinda suck
  Rewrite the horrible horrible mess in move function
  Scores

parts:
  code:
    plugin: copy
    source: https://github.com/MartinBriza/2048.qml
    source-type: git
    files:
      2048.qml: 2048.qml
    stage-packages:
      - qmlscene
daniel@daydream:/tmp/2048.qml$

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: snapd 2.0.1
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Apr 19 16:32:32 2016
InstallationDate: Installed on 2015-04-30 (354 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: snapd
SystemImageInfo:
 current build number: 0
 device name:
 channel: daily
 last update: 2015-07-02 09:27:08
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Daniel Holbach (dholbach) wrote :
Revision history for this message
Daniel Holbach (dholbach) wrote :
tags: added: sdoc
Revision history for this message
Daniel Holbach (dholbach) wrote :

Still an issue with snapd 2.0.2 and ubuntu-core version 16.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in snapd (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo)
Changed in snapd (Ubuntu):
importance: Undecided → High
Michael Vogt (mvo)
Changed in snappy:
milestone: none → sru-1
status: New → Fix Committed
Changed in snapd (Ubuntu):
status: Confirmed → Fix Committed
Changed in snapd (Ubuntu Xenial):
status: Confirmed → Fix Committed
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

I closed the tasks as Fix Released. Probably the bot missed them, or there were no LP numbers in the changelogs.

Changed in snapd (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in snapd (Ubuntu):
status: Fix Committed → Fix Released
Changed in snappy:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers