Update to 1.49

Bug #1836691 reported by Robert Ancell on 2019-07-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd-glib (Ubuntu)
Medium
Robert Ancell
Xenial
Medium
Robert Ancell
Bionic
Medium
Robert Ancell
Disco
Medium
Robert Ancell
Eoan
Medium
Robert Ancell

Bug Description

[Impact]
A newer snapd-glib is available that adds support for new features in snapd. snapd-glib has an SRU exception as per https://wiki.ubuntu.com/SnapdGlibUpdates

[Test Case]
The reverse depends of snapd-glib should continue to function, this is currently:
- gnome-software
- gnome-initial-setup
- pulseaudio

[Regression Potential]
Any new release has a risk of introducing bugs, this is mitigated by automatic regression tests.

Changed in snapd-glib (Ubuntu Xenial):
importance: Undecided → Medium
Changed in snapd-glib (Ubuntu Bionic):
importance: Undecided → Medium
Changed in snapd-glib (Ubuntu Disco):
importance: Undecided → Medium
Changed in snapd-glib (Ubuntu Eoan):
importance: Undecided → Medium
status: New → Triaged
Changed in snapd-glib (Ubuntu Disco):
status: New → Triaged
Changed in snapd-glib (Ubuntu Bionic):
status: New → Triaged
Changed in snapd-glib (Ubuntu Xenial):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd-glib - 1.49-0ubuntu1

---------------
snapd-glib (1.49-0ubuntu1) eoan; urgency=medium

  * New upstream release (LP: #1836691)
    - New API:
      - snapd_client_get_connections2_async
      - snapd_client_get_connections2_finish
      - snapd_client_get_connections2_sync
      - SnapdGetConnectionsFlags
    - Deprecated API:
      - snapd_client_get_connections_async
      - snapd_client_get_connections_finish
      - snapd_client_get_connections_sync
    - Fix memory leaks
    - Add snapd_client_get_connections2 to add missing filter fields from
      snapd_client_get_connections
    - Use C99 variable style
  * debian/libsnapd-glib1.symbols:
  * debian/libsnapd-qt1.symbols:
    - Updated

 -- Robert Ancell <email address hidden> Tue, 16 Jul 2019 16:28:10 +1200

Changed in snapd-glib (Ubuntu Eoan):
status: Triaged → Fix Released
Changed in snapd-glib (Ubuntu Eoan):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in snapd-glib (Ubuntu Disco):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in snapd-glib (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in snapd-glib (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in snapd-glib (Ubuntu Eoan):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in snapd-glib (Ubuntu Disco):
status: Triaged → Fix Committed
Changed in snapd-glib (Ubuntu Bionic):
status: Triaged → Fix Committed
Changed in snapd-glib (Ubuntu Xenial):
status: Triaged → Fix Committed
Changed in snapd-glib (Ubuntu Eoan):
assignee: nobody → Robert Ancell (robert-ancell)

Hello Robert, or anyone else affected,

Accepted snapd-glib into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd-glib/1.49-0ubuntu0.19.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-disco
Brian Murray (brian-murray) wrote :

Hello Robert, or anyone else affected,

Accepted snapd-glib into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd-glib/1.49-0ubuntu0.18.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Robert, or anyone else affected,

Accepted snapd-glib into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd-glib/1.49-0ubuntu0.16.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed-xenial
Robert Ancell (robert-ancell) wrote :

Tested snapd-glib 1.49-0ubuntu0.19.04.0 in Ubuntu 19.04 (disco). GNOME software able to install/remove/launch snaps (moon-buggy tested), pulse audio still working, gnome-initial-setup showing promoted snaps.

tags: added: verification-done-disco
removed: verification-needed-disco
Robert Ancell (robert-ancell) wrote :

Tested snapd-glib 1.49-0ubuntu0.18.04.0 in Ubuntu 18.04 LTS (bionic). GNOME software able to install/remove/launch snaps (moon-buggy tested), pulse audio still working, gnome-initial-setup showing promoted snaps.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Robert Ancell (robert-ancell) wrote :

Tested snapd-glib 1.49-0ubuntu0.16.04.0 in Ubuntu 16.04 LTS (xenial). GNOME software able to install/remove/launch snaps (moon-buggy tested), pulse audio still working, gnome-initial-setup not in the archive.

tags: added: verification-done-xenial
removed: verification-needed-xenial
tags: removed: verification-needed
Łukasz Zemczak (sil2100) wrote :

Since this is a very specific project I guess I would be willing to accept the verification (especially that the SRU has been accepted by another SRU member), but I do have one formal thing I'd like clarification on. The bug mentions snapd-glib having an SRU exception, but I do not see one 'approved' in https://wiki.ubuntu.com/StableReleaseUpdates#Documentation_for_Special_Cases . Who approved the SRU exception? Each exception needs to be approved by at least one SRU member and documented (along with the date) on the policy page IIRC.

Could you answer those questions before we proceed?

Robert Ancell (robert-ancell) wrote :

Brian - I'm pretty sure we finalized this in Malta in February, right? I can't remember the exact details but I have a meeting in my calendar about this then. I guess it never got added to the list.

Łukasz Zemczak (sil2100) wrote :

Ok, we need to resolve this at some point. Every SRU exception needs to be signed-off and documented so that there's no doubt. I mean, it does look that Brian did approve of the exception, especially that he did accept the SRU into proposed!

That being said, this one does look good to go. But let's sort the exception documentation ASAP for the future SRUs.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd-glib - 1.49-0ubuntu0.19.04.0

---------------
snapd-glib (1.49-0ubuntu0.19.04.0) disco; urgency=medium

  * New upstream release (LP: #1836691)

 -- Robert Ancell <email address hidden> Tue, 23 Jul 2019 15:26:11 +1200

Changed in snapd-glib (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for snapd-glib has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd-glib - 1.49-0ubuntu0.18.04.0

---------------
snapd-glib (1.49-0ubuntu0.18.04.0) bionic; urgency=medium

  * New upstream release (LP: #1836691)

 -- Robert Ancell <email address hidden> Tue, 23 Jul 2019 15:29:31 +1200

Changed in snapd-glib (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd-glib - 1.49-0ubuntu0.16.04.0

---------------
snapd-glib (1.49-0ubuntu0.16.04.0) xenial; urgency=medium

  * New upstream release (LP: #1836691)
  * debian/patches/0001-Use-a-fraction-in-Json-tests-with-a-double-value.patch:
    - Fix test case on older version of json-glib

 -- Robert Ancell <email address hidden> Tue, 23 Jul 2019 15:27:07 +1200

Changed in snapd-glib (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers