Support wide scope searches

Bug #1789338 reported by Robert Ancell on 2018-08-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Medium
Robert Ancell
Xenial
Medium
Unassigned
Bionic
Medium
Robert Ancell
Cosmic
Medium
Robert Ancell
snapd-glib (Ubuntu)
Medium
Unassigned
Bionic
Medium
Robert Ancell
Cosmic
Medium
Unassigned

Bug Description

[Impact]
snapd added a new "wide scope" search that finds snaps that do not have stable releases.

[Test Case]
1. Open GNOME Software
2. Search for "Stellarium"

Expected result:
The stellarium-daily snap is shown and is installable (as well as the stellarium-plars snap and the .deb).

Observed result:
Only stellarium-plars and the .deb is shown.

[Regression Potential]
Chance of new parsing code introducing bugs. Change of install code in GNOME Software breaking other install cases.

Changed in snapd-glib (Ubuntu Cosmic):
status: New → Fix Released
importance: Undecided → Medium
Changed in snapd-glib (Ubuntu Bionic):
importance: Undecided → Medium
Changed in snapd-glib (Ubuntu Xenial):
importance: Undecided → Medium
status: New → Triaged
Changed in snapd-glib (Ubuntu Bionic):
status: New → Triaged
no longer affects: snapd-glib (Ubuntu Xenial)
Changed in gnome-software (Ubuntu Cosmic):
status: New → Triaged
Changed in gnome-software (Ubuntu Bionic):
status: New → Triaged
Changed in gnome-software (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Bionic):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Cosmic):
importance: Undecided → Medium
Changed in snapd-glib (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in snapd-glib (Ubuntu Bionic):
status: Triaged → Fix Committed
Changed in gnome-software (Ubuntu Cosmic):
status: Triaged → In Progress
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Cosmic):
status: In Progress → Fix Committed
Changed in gnome-software (Ubuntu Bionic):
status: Triaged → In Progress
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.30.0-0ubuntu1

---------------
gnome-software (3.30.0-0ubuntu1) cosmic; urgency=medium

  * New upstream stable release
  * debian/control:
    - Update build-dependencies on libappstream-glib-dev, libsnapd-glib-dev
  * debian/patches/0011-Support-snap-channels.patch
  * debian/patches/0021-snap-Use-wide-scope-when-searching.patch:
    - Use wide scope searching (LP: #1789338)

 -- Robert Ancell <email address hidden> Wed, 05 Sep 2018 11:00:24 +1200

Changed in gnome-software (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Changed in gnome-software (Ubuntu Bionic):
status: In Progress → Fix Committed

Hello Robert, or anyone else affected,

Accepted snapd-glib into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd-glib/1.43-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Robert, or anyone else affected,

Accepted gnome-software into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.28.1-0ubuntu4.18.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Will Cooke (willcooke) wrote :

Installed on Bionic from proposed:

$ apt-cache policy gnome-software
gnome-software:
  Installed: 3.28.1-0ubuntu4.18.04.4
  Candidate: 3.28.1-0ubuntu4.18.04.4
  Version table:
 *** 3.28.1-0ubuntu4.18.04.4 500
        500 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.28.1-0ubuntu4.18.04.3 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
     3.28.1-0ubuntu4 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Did a search as described and did see the expected results.

Verification done.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Will Cooke (willcooke) wrote :

Hmm. Marking as verification-needed again, because the wide scope searches seems to be returning some strange results.

tags: added: verification-needed-bionic
removed: verification-done-bionic
Robert Ancell (robert-ancell) wrote :

Will, are you still seeing this issue? I don't think it is related to this change (this only adds an additional flag to be sent to snapd and may cause more results to be returned than before).

Will Cooke (willcooke) wrote :

I'm trying to remember how the "strange results" manifest themselves. Today, when I search in G-S for "Stellar" I get good results. From what I can remember in BRU, we were getting additional non-matching results. I dont see anything wrong today.

Marking as done again. I think it's OK now.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd-glib - 1.43-0ubuntu0.18.04.1

---------------
snapd-glib (1.43-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release
    - Support auth cancelled error (LP: #1785240)
    - Support wide scope searches (LP: #1789338)
    - Support publisher information (LP: #1789336)
    - Support refresh information (LP: #1789335)

 -- Robert Ancell <email address hidden> Tue, 28 Aug 2018 16:46:36 +1200

Changed in snapd-glib (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for snapd-glib has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.28.1-0ubuntu4.18.04.4

---------------
gnome-software (3.28.1-0ubuntu4.18.04.4) bionic; urgency=medium

  * debian/control:
    - Bump build-dependency on libsnapd-glib-dev
  * debian/patches/0020-Show-verified-developers.patch:
    - Show verified developers (LP: #1789336)
  * debian/patches/0011-Support-snap-channels.patch:
  * debian/patches/0021-snap-Use-wide-scope-when-searching.patch:
    - Use wide scope searching (LP: #1789338)
  * debian/patches/0022-Delay-startup-of-GNOME-Software-to-allow-the-Shell-t.patch:
    - Delay startup of service to allow the shell to load first (LP: #1756379)

 -- Robert Ancell <email address hidden> Wed, 19 Sep 2018 16:27:38 +0200

Changed in gnome-software (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments