Update to 1.33

Bug #1748289 reported by Robert Ancell on 2018-02-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd-glib (Ubuntu)
Undecided
Unassigned
Xenial
Medium
Unassigned
Artful
Medium
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
Older versions of Ubuntu are running older versions of snapd-glib. There have since been bug fixes and support for newer API that was added to snapd since release.

[Test Case]
1. Delete existing Snap credentials by deleting keys com.ubuntu.UbuntuOne.GnomeSoftware in Seahorse.
2. Start GNOME Software
3. Install a snap (e.g. moon-buggy)

Expected result:
User is prompted for Ubuntu credentials and is able to install snap.

Observed result:
Works as expected (i.e. only looking for regressions).

[Regression Potential]
There is a risk of breaking existing use cases. This is reduced by the regression tests in the package and the newer versions of snapd-glib working in newer releases.

Changed in snapd-glib (Ubuntu Xenial):
status: New → Fix Committed
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

The bionic version will be updated via Debian. It doesn't have any major changes since the current 1.32.

tags: added: upgrade-software-version
Changed in snapd-glib (Ubuntu Artful):
importance: Undecided → Medium
Changed in snapd-glib (Ubuntu Bionic):
status: New → Fix Released
Changed in snapd-glib (Ubuntu Xenial):
status: Fix Committed → New
status: New → Fix Committed
Robert Ancell (robert-ancell) wrote :

Hello Robert, or anyone else affected,

Accepted snapd-glib into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd-glib/1.33-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-xenial
Changed in snapd-glib (Ubuntu Artful):
status: New → Won't Fix
Robert Ancell (robert-ancell) wrote :

Updated a 16.04 LTS machine to the latest updates and was still able to install / remove moon-buggy.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package snapd-glib - 1.33-0ubuntu0.16.04.1

---------------
snapd-glib (1.33-0ubuntu0.16.04.1) xenial; urgency=medium

  * New upstream release: (LP: #1748289)
    * New API:
      - snapd_alias_get_app_auto
      - snapd_alias_get_command
      - snapd_alias_get_app_manual
      - snapd_app_get_active
      - snapd_app_get_desktop_file
      - snapd_app_get_enabled
      - snapd_app_get_snap
      - snapd_change_get_error
      - snapd_channel_get_branch
      - snapd_channel_get_confinement
      - snapd_channel_get_epoch
      - snapd_channel_get_name
      - snapd_channel_get_revision
      - snapd_channel_get_risk
      - snapd_channel_get_size
      - snapd_channel_get_track
      - snapd_channel_get_type
      - snapd_channel_get_version
      - snapd_client_abort_change_async
      - snapd_client_abort_change_finish
      - snapd_client_abort_change_sync
      - snapd_client_get_allow_interaction
      - snapd_client_get_changes_async
      - snapd_client_get_changes_finish
      - snapd_client_get_changes_sync
      - snapd_client_get_change_async
      - snapd_client_get_change_finish
      - snapd_client_get_change_sync
      - snapd_client_get_socket_path
      - snapd_client_login2_async
      - snapd_client_login2_finish
      - snapd_client_login2_sync
      - snapd_client_switch_async
      - snapd_client_switch_finish
      - snapd_client_switch_sync
      - snapd_client_get_users_async
      - snapd_client_get_users_finish
      - snapd_client_get_users_sync
      - snapd_client_alias_async
      - snapd_client_alias_finish
      - snapd_client_alias_sync
      - snapd_client_unalias_async
      - snapd_client_unalias_finish
      - snapd_client_unalias_sync
      - snapd_client_prefer_async
      - snapd_client_prefer_finish
      - snapd_client_prefer_sync
      - snapd_client_get_apps_sync
      - snapd_client_get_apps_finish
      - snapd_client_get_apps_async
      - snapd_client_set_allow_interaction
      - snapd_client_set_socket_path
      - snapd_snap_get_broken
      - snapd_snap_get_channels
      - snapd_snap_get_tracks
      - snapd_snap_get_license
      - snapd_snap_get_title
      - snapd_snap_match_channel
      - snapd_system_information_get_confinement
    * Deprecated API:
      - snapd_app_get_aliases
      - snapd_client_connect_async
      - snapd_client_connect_finish
      - snapd_client_connect_sync
      - snapd_client_disable_aliases_async
      - snapd_client_disable_aliases_finish
      - snapd_client_disable_aliases_sync
      - snapd_client_enable_aliases_async
      - snapd_client_enable_aliases_finish
      - snapd_client_enable_aliases_sync
      - snapd_client_login_async
      - snapd_client_login_finish
      - snapd_client_login_sync
      - snapd_client_reset_aliases_async
      - snapd_client_reset_aliases_finish
      - snapd_client_reset_aliases_sync
    - Fix small memory leaks and crashes
    - Support new error codes from snapd
    - Implement new snapd APIs
    - Fix multiple async operations not working at the same time.
    - Connect to snapd on demand.
    - Add ability to set snapd socket to connect to.
    - Make clients using provided sockets non...

Read more...

Changed in snapd-glib (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for snapd-glib has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers