Add snapd-glib to Ubuntu 14.04 LTS

Bug #1698984 reported by Robert Ancell on 2017-06-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
snapd-glib (Ubuntu)
Wishlist
Robert Ancell

Bug Description

[Impact]
snapd was made available in Ubuntu 14.04 LTS, so we should make snapd-glib available too.

[Test Case]
1. sudo apt-get install libsnapd-glib-dev

Expected result:
It installs!

Observed result:
It doesn't :(

[Regression Potential]
Not currently used by anything, so no chance of regression to existing packages. We need a patch to run snapd-glib on the older version of GLib, so there is a chance of different behaviour. The regression tests complete so this risk is reduced.

Changed in snapd-glib (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Robert Ancell (robert-ancell) wrote :

I had to disable the Qt bindings and the docs as they don't build on Trusty. We could enable them if necessary with some patching (I doubt there is a need for either at the current time).

Robert Ancell (robert-ancell) wrote :

The patch to make this work is in the glib-2-40 branch on GitHub (https://github.com/snapcore/snapd-glib/tree/glib-2-40).

Changed in snapd-glib (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Currently stuck in NEW queue...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers