Adding a scriptlet doesn't mark a part as dirty

Bug #1672407 reported by Didier Roche on 2017-03-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Snapcraft
High
Kyle Fazzari
snapcraft (Ubuntu)
Undecided
Unassigned

Bug Description

1. Take any snapcraft.yaml with one part, like "qt-app"
2. Run snapcraft prime
3. Add an "install: mkdir -p $SNAPCRAFT_PART_INSTALL/foo" line to your part
4. run snapcraft prime
you will see:
Skipping pull qt-app (already ran)
Skipping build qt-app (already ran)
Skipping stage qt-app (already ran)
Skipping prime qt-app (already ran)
-> Your part didn't rebuild, there isn't a "foo" directory in prime/ eitehr.

What should happen:
the qt-app part should be marked as dirty and forced cleaning.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: snapcraft 2.27.1 [modified: usr/lib/python3/dist-packages/snapcraft/_baseplugin.py usr/lib/python3/dist-packages/snapcraft/plugins/python.py]
ProcVersionSignature: Ubuntu 4.4.0-66.87-generic 4.4.44
Uname: Linux 4.4.0-66-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Mar 13 15:09:21 2017
InstallationDate: Installed on 2012-05-28 (1750 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageArchitecture: all
SourcePackage: snapcraft
UpgradeStatus: Upgraded to xenial on 2014-10-31 (864 days ago)

Didier Roche (didrocks) wrote :
Changed in snapcraft:
status: New → Triaged
importance: Undecided → High
tags: added: bitesize
Kyle Fazzari (kyrofa) wrote :
Changed in snapcraft:
status: Triaged → In Progress
assignee: nobody → Kyle Fazzari (kyrofa)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in snapcraft (Ubuntu):
status: New → Confirmed
Changed in snapcraft:
status: In Progress → Fix Committed
Changed in snapcraft (Ubuntu):
status: Confirmed → Fix Committed
Changed in snapcraft:
milestone: none → 2.35
Changed in snapcraft:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers