[SRU] New stable micro release 2.23

Bug #1646993 reported by Sergio Schvezov on 2016-12-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapcraft (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

This is an SRU bug to release 2.23 of snapcraft which follows the guidelines defined in the wiki over at https://wiki.ubuntu.com/SnapcraftUpdates

The list of bugs and features in this release are defined at https://launchpad.net/snapcraft/+milestone/2.23 and https://launchpad.net/snapcraft/+milestone/2.23

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapcraft - 2.23+17.04

---------------
snapcraft (2.23+17.04) zesty; urgency=medium

  [ Sergio Schvezov ]
  * indicators: work with Content-Encoding set (#896)
  * store: download without login (#903)
  * readme: rocket instead of irc (#907)
  * indicators: support TERM=dumb (#906)
  * Update HACKING.md (#910)
  * help: update stage-packages and build-packages (#913)
  * meta: icon is now dedeprecated (#914)
  * cache: cleanup logic to pass project name (#915)
  * sources: missing command instead of package (#916)
  * docs: update GUI related integrations (#919)
  * pluginhandler: source management moved to the core (#923)
  * store: return specific error when already owned (#942)
  * nodejs plugin: install during pull to support npm run (#936)
  * New upstream release 2.22.1 (LP: #1646993)

  [ Parameswaran Sivatharman ]
  * store: login with option to agree to terms of service and human friendly errors (#866)

  [ Bayard Randel ]
  * cache: snap revision caching on 'push'. (#889)
  * deltas: migrate from xdelta to xdelta3. (#934)

  [ Leo Arias ]
  * tools: new script to retry autopktests (#893)
  * tests: remove the outdated all snaps image set up for snaps tests (#911)
  * plugin: add a gradle demo and test (#912)
  * tests: unset the proxies for gradle unit testing (#922)
  * tests: use the connectivity check page to test the downloader snap (#925)
  * tests: add a script to build external snaps (#927)
  * tests: replace coveralls with codecov (#939)
  * tests: replace subTests with TestScenarios (#943)

  [ Marco Trevisan ]
  * repo: apt-mark new build-packages as automatically installed (#891)
  * sources: add ftp support (#900)
  * parser: support remote dependencies (#930)
  * sources: add current dir to ignore list if we're iterating on parent (#926)

  [ Kelvin Li ]
  * cache: enable prune for snap cache. (#905)
  * deltas: initial implementation (#918)

  [ Celso Providelo ]
  * cli: basic 'enable-ci' implementation. (#901)
  * cli: implement `enable-ci travis --refresh` command (#932)

  [ John Lenton ]
  * cli: _filedir takes an extension, not a glob (#933)

  [ Larry Price ]
  * cmake plugin: utilize MakePlugin build logic within CMakePlugin (#935)

  [ Kyle Fazzari ]
  * pluginhandler: incorporate all part properties into state tracking. (#937)

 -- Sergio Schvezov <email address hidden> Fri, 02 Dec 2016 23:44:19 +0000

Changed in snapcraft (Ubuntu Zesty):
status: New → Fix Released
Leo Arias (elopio) wrote :

Before this can land into xenial and yakkety, the following tests need to be executed:

sources:
  - build a snap with the shutter tar.gz as a source, from bug #1611776.
  - try to build snaps without the source commands: bzr, git, hg.
  - build a snap with an ftp source.
  - build the snap from bug #1644350.

plugins:
  - build a kernel snap, check that it doesn't ask for login.
  - build a nodejs snap that requires npm commands, like Augur.
  - build a cmake snap with some options from the make plugin.

meta:
  - build a snap with icon in snapcraft.yaml.

build-packages:
  - call apt auto-remove after building snaps with build-packages.

store:
  - push snaps with DELTA_UPLOADS_EXPERIMENTAL.
  - try to register a snap without the agreement signed.
  - try to register a name already register by the same user.

parser:
  - parse a part that depends on other remote part.

exploratory:
  - with TERM=dumb.
  - build various snaps with different plugins, running all the life cycle commands.
  - try the integration with travis in various projects.

Hello Sergio, or anyone else affected,

Accepted snapcraft into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.23 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in snapcraft (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Changed in snapcraft (Ubuntu Yakkety):
status: New → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Sergio, or anyone else affected,

Accepted snapcraft into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.23+16.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Leo Arias (elopio) wrote :

I installed snapcraft, snapcraft-parser and snapcraft-examples in clean xenial and yakkety virtual machines.
Then I enabled -proposed and upgraded the three packages to 2.23.

I ran the tests mentioned in the comment #2 above, and extensive exploratory in both machines.

I couldn't find any regressions caused by this release, nor any big blocker issues. I hereby pronounce this bug as verified.

I won't change the tag to let Sergio do it when he is ready.

Leo Arias (elopio) on 2016-12-08
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapcraft - 2.23+16.10

---------------
snapcraft (2.23+16.10) yakkety; urgency=medium

  [ Sergio Schvezov ]
  * indicators: work with Content-Encoding set (#896)
  * store: download without login (#903)
  * readme: rocket instead of irc (#907)
  * indicators: support TERM=dumb (#906)
  * Update HACKING.md (#910)
  * help: update stage-packages and build-packages (#913)
  * meta: icon is now dedeprecated (#914)
  * cache: cleanup logic to pass project name (#915)
  * sources: missing command instead of package (#916)
  * docs: update GUI related integrations (#919)
  * pluginhandler: source management moved to the core (#923)
  * store: return specific error when already owned (#942)
  * nodejs plugin: install during pull to support npm run (#936)
  * New upstream release 2.22.1 (LP: #1646993)

  [ Parameswaran Sivatharman ]
  * store: login with option to agree to terms of service and human friendly errors (#866)

  [ Bayard Randel ]
  * cache: snap revision caching on 'push'. (#889)
  * deltas: migrate from xdelta to xdelta3. (#934)

  [ Leo Arias ]
  * tools: new script to retry autopktests (#893)
  * tests: remove the outdated all snaps image set up for snaps tests (#911)
  * plugin: add a gradle demo and test (#912)
  * tests: unset the proxies for gradle unit testing (#922)
  * tests: use the connectivity check page to test the downloader snap (#925)
  * tests: add a script to build external snaps (#927)
  * tests: replace coveralls with codecov (#939)
  * tests: replace subTests with TestScenarios (#943)

  [ Marco Trevisan ]
  * repo: apt-mark new build-packages as automatically installed (#891)
  * sources: add ftp support (#900)
  * parser: support remote dependencies (#930)
  * sources: add current dir to ignore list if we're iterating on parent (#926)

  [ Kelvin Li ]
  * cache: enable prune for snap cache. (#905)
  * deltas: initial implementation (#918)

  [ Celso Providelo ]
  * cli: basic 'enable-ci' implementation. (#901)
  * cli: implement `enable-ci travis --refresh` command (#932)

  [ John Lenton ]
  * cli: _filedir takes an extension, not a glob (#933)

  [ Larry Price ]
  * cmake plugin: utilize MakePlugin build logic within CMakePlugin (#935)

  [ Kyle Fazzari ]
  * pluginhandler: incorporate all part properties into state tracking. (#937)

 -- Sergio Schvezov <email address hidden> Fri, 02 Dec 2016 23:44:19 +0000

Changed in snapcraft (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for snapcraft has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapcraft - 2.23

---------------
snapcraft (2.23) xenial; urgency=medium

  [ Sergio Schvezov ]
  * indicators: work with Content-Encoding set (#896)
  * store: download without login (#903)
  * readme: rocket instead of irc (#907)
  * indicators: support TERM=dumb (#906)
  * Update HACKING.md (#910)
  * help: update stage-packages and build-packages (#913)
  * meta: icon is now dedeprecated (#914)
  * cache: cleanup logic to pass project name (#915)
  * sources: missing command instead of package (#916)
  * docs: update GUI related integrations (#919)
  * pluginhandler: source management moved to the core (#923)
  * store: return specific error when already owned (#942)
  * nodejs plugin: install during pull to support npm run (#936)
  * New upstream release 2.22.1 (LP: #1646993)

  [ Parameswaran Sivatharman ]
  * store: login with option to agree to terms of service and human friendly errors (#866)

  [ Bayard Randel ]
  * cache: snap revision caching on 'push'. (#889)
  * deltas: migrate from xdelta to xdelta3. (#934)

  [ Leo Arias ]
  * tools: new script to retry autopktests (#893)
  * tests: remove the outdated all snaps image set up for snaps tests (#911)
  * plugin: add a gradle demo and test (#912)
  * tests: unset the proxies for gradle unit testing (#922)
  * tests: use the connectivity check page to test the downloader snap (#925)
  * tests: add a script to build external snaps (#927)
  * tests: replace coveralls with codecov (#939)
  * tests: replace subTests with TestScenarios (#943)

  [ Marco Trevisan ]
  * repo: apt-mark new build-packages as automatically installed (#891)
  * sources: add ftp support (#900)
  * parser: support remote dependencies (#930)
  * sources: add current dir to ignore list if we're iterating on parent (#926)

  [ Kelvin Li ]
  * cache: enable prune for snap cache. (#905)
  * deltas: initial implementation (#918)

  [ Celso Providelo ]
  * cli: basic 'enable-ci' implementation. (#901)
  * cli: implement `enable-ci travis --refresh` command (#932)

  [ John Lenton ]
  * cli: _filedir takes an extension, not a glob (#933)

  [ Larry Price ]
  * cmake plugin: utilize MakePlugin build logic within CMakePlugin (#935)

  [ Kyle Fazzari ]
  * pluginhandler: incorporate all part properties into state tracking. (#937)

 -- Sergio Schvezov <email address hidden> Fri, 02 Dec 2016 23:44:19 +0000

Changed in snapcraft (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers