[SRU] New stable micro release 2.22

Bug #1640585 reported by Sergio Schvezov
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapcraft (Ubuntu)
Fix Released
Undecided
Unassigned
Xenial
Fix Released
Undecided
Unassigned
Yakkety
Fix Released
Undecided
Unassigned
Zesty
Fix Released
Undecided
Unassigned

Bug Description

This is an SRU bug to release 2.22 of snapcraft which follows the guidelines defined in the wiki over at https://wiki.ubuntu.com/SnapcraftUpdates

The list of bugs and features in this release are defined at https://launchpad.net/snapcraft/+milestone/2.22 and https://launchpad.net/snapcraft/+milestone/2.22

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Sergio, or anyone else affected,

Accepted snapcraft into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.22+16.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in snapcraft (Ubuntu Zesty):
status: New → Fix Committed
Changed in snapcraft (Ubuntu Yakkety):
status: New → Fix Committed
tags: added: verification-needed
Changed in snapcraft (Ubuntu Xenial):
status: New → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

Hello Sergio, or anyone else affected,

Accepted snapcraft into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.22 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapcraft - 2.22+17.04

---------------
snapcraft (2.22+17.04) zesty; urgency=medium

  [ Sergio Schvezov ]
  * Support for gadget snaps (#886)
  * Remove license concepts (#880)
  * store: send snapcraft version in a header (#894)
  * New upstream release 2.22 (LP: #1640585)

  [ Bayard Randel ]
  * repo: cache apt related files (config, packages) in 'apt' parent
    directory. (#887)

  [ Kyle Fazzari ]
  * catkin plugin: python nodes require gcc/g++ too. (#881)

  [ Neal Gompa ]
  * sources: Add RPM source (#870)

  [ Stéphane Graber ]
  * Always respect go-buildtags (#888)
  * Allow for architecture-specific packages (#876)

 -- Sergio Schvezov <email address hidden> Thu, 10 Nov 2016 01:35:00 +0000

Changed in snapcraft (Ubuntu Zesty):
status: Fix Committed → Fix Released
Revision history for this message
Leo Arias (elopio) wrote :

I tested this in xenial and yakkety:
Install snapcraft, snapcraft-examples and snapcraft parser. Enable -proposed. Upgrade the packages to 2.22.

Then I ran the following tests:

Build a gadget snap.
Run snapcraft --version.
Exploratory on store commands.
Build snaps and check that the cache is stored in $HOME/.cache/snapcraft/apt/
Build snaps again and check that the cache is used.
Build snaps with packages of a specific architecture.
Build a catkin snap and check that gcc and g++ are installed in the snap.
Build a go and check that the build tags are called for all the packages installed.
Build a snap using an rpm source.

I'm marking this as verified. Thanks pitti!

tags: added: verification-done
removed: verification-needed
Revision history for this message
Leo Arias (elopio) wrote :

Marking verification failed because one change of syntax in 2.22 would prevent a new feature that we want to implement for multiarch. 2.22.1 is coming with that change reverted, and a following version will get it back with support for more things.

tags: added: verification-failed
removed: verification-done
Revision history for this message
Steve Langasek (vorlon) wrote :

Hello Sergio, or anyone else affected,

Accepted snapcraft into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.22.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Revision history for this message
Steve Langasek (vorlon) wrote :

Hello Sergio, or anyone else affected,

Accepted snapcraft into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapcraft/2.22.1+16.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Leo Arias (elopio) wrote :

I tested this in xenial and yakkety:
Install snapcraft, snapcraft-examples and snapcraft parser. Enable -proposed. Upgrade the packages to 2.22.1.

Then I checked that the reverted commit from 2.22 was actually removed and it wasn't causing weird problems. I also did a quick exploratory to check that the features already tested for 2.22 were still working.

I'm marking this as verified.
Thanks Steve!

tags: added: verification-donee
removed: verification-needed
tags: added: verification-done
removed: verification-donee
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapcraft - 2.22.1

---------------
snapcraft (2.22.1) xenial; urgency=medium

  * Revert "Allow for architecture-specific packages (#876)" (#898)
  * New upstream release 2.22.1 (LP: #1640585)

 -- Sergio Schvezov <email address hidden> Fri, 11 Nov 2016 19:28:41 +0000

Changed in snapcraft (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote : Update Released

The verification of the Stable Release Update for snapcraft has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapcraft - 2.22.1+16.10

---------------
snapcraft (2.22.1+16.10) yakkety; urgency=medium

  * Revert "Allow for architecture-specific packages (#876)" (#898)
  * New upstream release 2.22.1 (LP: #1640585)

 -- Sergio Schvezov <email address hidden> Fri, 11 Nov 2016 19:28:41 +0000

Changed in snapcraft (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers