error message is unclear when the right side of files is empty

Bug #1587455 reported by ruge@metasmug.com on 2016-05-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Snapcraft
Medium
Kyle Fazzari
snapcraft (Ubuntu)
Undecided
Kyle Fazzari

Bug Description

My snapcraft.yaml file was missing the '.' and the error I got was unclear:

kati@linux:~/Development/OpenSolitaire.Classic$ snapcraft snap
Skipping pull opensolitaire-classic (already ran)
Preparing to build opensolitaire-classic
Building opensolitaire-classic
'NoneType' object has no attribute 'lstrip'

=== snapcraft.yaml ===
name: opensolitaire-classic
version: 0.9.2
summary: Open Solitaire Classic
description: |
    Pass the time with this classic solitaire game (licensed under GPL-3)

apps:
    run:
        command: OpenSolitaire.Classic

parts:
    opensolitaire-classic:
        plugin: copy
        files:
            "*":
=== end snapcraft.yaml ===

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in snapcraft (Ubuntu):
status: New → Confirmed
Leo Arias (elopio) on 2016-06-11
Changed in snapcraft:
status: New → Confirmed
summary: - error message is unclear
+ error message is unclear when the right side of files is empty
Changed in snapcraft:
importance: Undecided → Medium
tags: added: bitesize
Kyle Fazzari (kyrofa) wrote :
Changed in snapcraft:
status: Confirmed → In Progress
Changed in snapcraft (Ubuntu):
status: Confirmed → In Progress
Changed in snapcraft:
assignee: nobody → Kyle Fazzari (kyrofa)
Changed in snapcraft (Ubuntu):
assignee: nobody → Kyle Fazzari (kyrofa)
Changed in snapcraft:
status: In Progress → Fix Committed
milestone: none → 2.27
Changed in snapcraft:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers