Smplayer sometimes shows no video (is transparent)

Bug #507716 reported by Michał Gołębiowski-Owczarek on 2010-01-14
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
smplayer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: smplayer

Smplayer sometimes fails to show video output with xv driver (removal of smplayer and/or mplayer configuration files doesn't help). Mplayer shows video correctly.

Restarting Ubuntu helped me last time (but the problem seems to reoccur after some time...).

Once it happens, smplayer logs are full of this line:
"[00:35:16] MplayerProcess::parseLine: 'X11 error: BadMatch (invalid parameter attributes)'"
mplayer log is then full of this one:
X11 error: BadMatch (invalid parameter attributes)

ProblemType: Bug
Architecture: amd64
Date: Fri Jan 15 00:35:34 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: wl
Package: smplayer 0.6.7-1
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: smplayer
Uname: Linux 2.6.31-17-generic x86_64

description: updated

Hmm... The same problem occurs when I use VLC (I have to check if the problem persist after a reboot). However, Totem works fine.

VLC output (maybe this is another error, I don't know...):
On first try:

$ vlc GCBC_SCR.XviD.avi
VLC media player 1.0.2 Goldeneye
[0x1be4998] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::begin: Paint device returned engine == 0, type: 1
[????????] x11 video output error: X11 request 132.19 failed with error code 8:
 BadMatch (invalid parameter attributes)
X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 132 (XVideo)
  Minor opcode of failed request: 19 ()
  Serial number of failed request: 107
  Current serial number in output stream: 108
// here it failed

On the second try:

$ vlc GCBC_SCR.XviD.avi
VLC media player 1.0.2 Goldeneye
[0x174c998] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::begin: Paint device returned engine == 0, type: 1
X Error: BadMatch (invalid parameter attributes) 8
  Extension: 132 (Uknown extension)
  Minor opcode: 19 (Unknown request)
  Resource id: 0x6c00005
X Error: BadMatch (invalid parameter attributes) 8
  Extension: 132 (Uknown extension)
  Minor opcode: 19 (Unknown request)
  Resource id: 0x6c00005
X Error: BadMatch (invalid parameter attributes) 8
  Extension: 132 (Uknown extension)
  Minor opcode: 19 (Unknown request)
  Resource id: 0x6c00005
// into infinity...

Rup.Xamqon (rupxamqon) wrote :

I have the same problem since I started to use Cairo-Dock.
I found: http://smplayer.berlios.de/forums/viewtopic.php?id=979

Ubuntu Karmic amd64, SmPlayer 0.6.9 (SVN r3447) with Qt 4.5.2

m2ztx (smir253) wrote :

Same problem. Transparent SMPlayer window with xv renderer after running Cairo Dock GL. X11 renderer works.

Ubuntu 10.04 lucid, SMPLayer 0.6.9 (SVN r3447) with Qt 4.6.2, cairo-dock 2.1.3

blacksheep (raj-thebest123) wrote :

Same problem with my sytem. XV renderer doesnt show video but X11 works fine.

System details: Ubuntu 10.04
Smplayer Version: 0.6.8 (SVN r3213)
Using Qt 4.6.2 (compiled with Qt 4.6.0)

kitt (kittkatt0) wrote :

This bug affected me too when I had cairo-dock 2.2.0 enabled and set as a startup application (both with and without OpenGL enabled). As soon as I turned it off, the transparent window was gone.

Smplayer v 0.6.9-1
Ubuntu 10.10

kitt (kittkatt0) on 2010-11-18
Changed in smplayer (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers