smplayer 0.5.62

Bug #175051 reported by Maia Everett on 2007-12-09
4
Affects Status Importance Assigned to Milestone
smplayer (Ubuntu)
Wishlist
Emmet Hikory

Bug Description

Binary package hint: smplayer

A new upstream release is available.

Maia Everett (linneris) on 2007-12-11
Changed in smplayer:
status: New → In Progress
Emmet Hikory (persia) wrote :

Please attach an interdiff for the new version, and subscribe ubuntu universe sponsors to request upload.

Changed in smplayer:
assignee: nobody → sikon
importance: Undecided → Wishlist
Maia Everett (linneris) wrote :

Attaching interdiff.

debian/changelog entry, for convenience:

smplayer (0.5.62-0ubuntu1) hardy; urgency=low

  * New upstream release. (LP: #175051)
  * debian/control:
    - Replaced kdelibs4-dev with libqt4-dev, since the Qt3 version has
      been discontinued and no longer builds.
    - Moved homepage out of the description.
    - Recommend smplayer-themes.
    - Depend on mplayer | mplayer-nogui. (LP: #146783)
    - Split translations into smplayer-translations (big /usr/share).
    - Increased debhelper version to 5.0.51 (for dh_icons).
    - Updated Standards-Version to 3.7.3.
  * debian/rules:
    - Cleaned up by removing dh_make comments.
    - Build against Qt4.
    - Do not ignore make clean errors.
    - Added dh_install.
    - Added dh_icons and dh_desktop.
    - Moved manpage file name from debian/rules to debian/manpages.
  * debian/smplayer.1: updated.
  * debian/smplayer.desktop: removed encoding field.
  * Added debian/menu (with XPM file).
  * Added debian/watch.

 -- Matvey Kozhev <email address hidden> Sun, 09 Dec 2007 14:43:05 +0600

Maia Everett (linneris) on 2007-12-16
Changed in smplayer:
assignee: sikon → nobody
status: In Progress → Confirmed
Emmet Hikory (persia) on 2007-12-16
Changed in smplayer:
assignee: nobody → persia
status: Confirmed → In Progress
Maia Everett (linneris) wrote :

Interdiff without -p1.

Emmet Hikory (persia) wrote :

Thanks for packaging this. Unfortunately, the watch file pulls a tar.bz file, instead of a tar.gz file, and there is no get-orig-source rule for the repack in debian/rules. Please add a get-orig-source rule automating the repack, and resubscribe ubuntu-universe-sponsors to request upload.

Changed in smplayer:
assignee: persia → sikon
Maia Everett (linneris) wrote :

Interdiff with get-orig-source.

Emmet Hikory (persia) wrote :

Uploaded. Thanks.

Changed in smplayer:
assignee: sikon → persia
status: In Progress → Fix Committed
Maia Everett (linneris) wrote :

smplayer (0.5.62-0ubuntu1) hardy; urgency=low

  * New upstream release. (LP: #175051)
  * debian/control:
    - Replaced kdelibs4-dev with libqt4-dev, since the Qt3 version has
      been discontinued and no longer builds.
    - Moved homepage out of the description.
    - Recommend smplayer-themes.
    - Depend on mplayer | mplayer-nogui. (LP: #146783)
    - Split translations into smplayer-translations (big /usr/share).
    - Increased debhelper version to 5.0.51 (for dh_icons).
    - Updated Standards-Version to 3.7.3.
  * debian/rules:
    - Cleaned up by removing dh_make comments.
    - Build against Qt4.
    - Do not ignore make clean errors.
    - Added dh_install.
    - Added dh_icons and dh_desktop.
    - Moved manpage file name from debian/rules to debian/manpages.
    - Added get-orig-source.
  * debian/smplayer.1: updated.
  * debian/smplayer.desktop: removed encoding field.
  * Added debian/menu (with XPM file).
  * Added debian/watch.

 -- Matvey Kozhev <email address hidden> Sun, 09 Dec 2007 14:43:05 +0600

Changed in smplayer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers