Ubuntu

Sync smartmontools 6.1+svn3812-1 (main) from Debian unstable (main)

Reported by Rebecca Menessec on 2012-12-18
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
smartmontools (Debian)
Fix Released
Unknown
smartmontools (Ubuntu)
Undecided
Unassigned

Bug Description

Please sync smartmontools 6.1+svn3812-1 (main) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * New upstream release (LP: #1020562).
  * Update build structure to satisfy Lintian.
I uploaded the Ubuntu-only version of smartmontools, and it's alright to drop that delta, since it was only basically upstream changes.

Changelog entries since current saucy version 5.43-0ubuntu1:

smartmontools (6.1+svn3812-1) unstable; urgency=low

  * [ee38a43] Imported Upstream version 6.1+svn3812 (Closes: #691646)
    - Support for WD MyBook Essential 0x1058:0x0910 (Closes: #633724)
    - Added USB bridge to known IDs (Closes: #643928)
    - Added support for Seagate Expansion Desk external (usb) disks
      (Closes: #621411)
  * [1855d63] Refreshed patches and removed patches applied upstream
  * [d3fc9d1] Remove quilt from depends
  * [841c1a8] CHANGELOG file has been renamed, install Changelog
  * [3502e16] Updated VCS control fields
  * [8f14e44] debian/rules: Provide build-arch and build-indep
  * [0f1c16c] Harden smartmontools binaries
  * [555346e] Bump to 3.9.4 standards version
  * [5ae3fa9] Use /var/lib/smartmontools/drivedb for drivedb.h updates
    (Closes: #706909)
  * [c16ffdc] Create /var/lib/smartmontools/drivedb dir
  * [79a3dc2] Trigger the removal of /etc/init.d/smartd when upgrading
    (Closes: #684617, #704081)
  * [a0a5725] Also remove /etc/init.d/smartd in preinst script
  * [a26a490] Added man page for update-smart-drivedb.
    Thanks to Hannes von Haugwitz (Closes: #708433)

 -- Giuseppe Iuculano <email address hidden> Sun, 02 Jun 2013 11:14:02 +0200

Original Description:
Unless there's a compelling reason not to, most recent smartmontools would be appreciated. Appears to build cleanly on a quantal desktop system, both with default and highly custom flags. Binaries, update script, and manpages (at least) appear to be drop-in replacements. No issues detected with running 6.0 smartd thus far.

(For reference: CFLAGS="-O3 -fomit-frame-pointer -march=corei7 -pipe -fpic -pie -flto -fuse-linker-plugin -findirect-inlining -ftree-switch-conversion -mssse3 -mcx16 -mfpmath=sse -w" CXXFLAGS="-O3 -fomit-frame-pointer -march=corei7 -pipe -fpic -pie -flto -fuse-linker-plugin -findirect-inlining -ftree-switch-conversion -mssse3 -mcx16 -mfpmath=sse -w" LDFLAGS="-Wl,-z,relro,--as-needed,--hash-style=gnu")

Will probably distribute these or similar 6.0 binaries to my other Ubuntu systems later tonight.

tags: added: raring
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in smartmontools (Ubuntu):
status: New → Confirmed
Changed in smartmontools (Debian):
status: Unknown → New
Changed in smartmontools (Debian):
status: New → Fix Released
Logan Rosen (logan) on 2013-06-03
description: updated
summary: - Upgrade smartmontools to 6.0 for raring
+ Sync smartmontools 6.1+svn3812-1 (main) from Debian unstable (main)
James Page (james-page) wrote :

This bug was fixed in the package smartmontools - 6.1+svn3812-1
Sponsored for Logan Rosen (logan)

---------------
smartmontools (6.1+svn3812-1) unstable; urgency=low

  * [ee38a43] Imported Upstream version 6.1+svn3812 (Closes: #691646)
    - Support for WD MyBook Essential 0x1058:0x0910 (Closes: #633724)
    - Added USB bridge to known IDs (Closes: #643928)
    - Added support for Seagate Expansion Desk external (usb) disks
      (Closes: #621411)
  * [1855d63] Refreshed patches and removed patches applied upstream
  * [d3fc9d1] Remove quilt from depends
  * [841c1a8] CHANGELOG file has been renamed, install Changelog
  * [3502e16] Updated VCS control fields
  * [8f14e44] debian/rules: Provide build-arch and build-indep
  * [0f1c16c] Harden smartmontools binaries
  * [555346e] Bump to 3.9.4 standards version
  * [5ae3fa9] Use /var/lib/smartmontools/drivedb for drivedb.h updates
    (Closes: #706909)
  * [c16ffdc] Create /var/lib/smartmontools/drivedb dir
  * [79a3dc2] Trigger the removal of /etc/init.d/smartd when upgrading
    (Closes: #684617, #704081)
  * [a0a5725] Also remove /etc/init.d/smartd in preinst script
  * [a26a490] Added man page for update-smart-drivedb.
    Thanks to Hannes von Haugwitz (Closes: #708433)

 -- Giuseppe Iuculano <email address hidden> Sun, 02 Jun 2013 11:14:02 +0200

Changed in smartmontools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.