Ubuntu

smartd segfaults

Reported by Evan Klitzke on 2007-04-17
2
Affects Status Importance Assigned to Milestone
smartmontools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: smartmontools

Hi, I am running the Feisty pre-release right now and wanted to run smartd. I followed the instructions at http://www.edafe.org/ubuntu/index.html to get smartd up and running. Specifically, the steps I took were to comment out the DEVICESCAN line in /etc/smartd.conf, and add the following two lines:

/dev/sda -a -d ata -n never -o on -S on -s
(L/../../7/04|S/../.././02) -m root -M daily -M test

I also set start_smartd=yes in /etc/default/smartmontools and made no other changes in that file (i.e. everything else in the file is commented out). If I try to /etc/init.d/smartmontools start I get a fail message and indication that there was a segfault. Starting up the daemon from the command line shows a segfault with no other output.

Device manager lists the hard drive as a "82801DBM (ICH4-M) IDE Controller". The kernel is 2.6.20.15.14 and the version of smartmontools is 5.36-8ubuntu2.

Evan Klitzke (eklitzke2) wrote :

Adding the strace output now.

Evan Klitzke (eklitzke2) wrote :

I don't know much about gdb, but if I run smartd through gdb the last two lines (which are the only interesting ones) are:

Program received signal SIGSEGV, Segmentation fault.
0xb7e96c23 in strlen () from /lib/tls/i686/cmov/libc.so.6

Evan Klitzke (eklitzke2) wrote :

I just compiled 5.36 and 5.37 from upstream and had the same problem. Consequently, I subscribed to their mailing list and sent in an email describing the problem (I don't think they have a bug tracking system). I'm also going to attach my smartd.conf file here in case it's helpful.

Hi

Try on one line or with a \

/dev/sda -a -d ata -n never -o on -S on -s
(L/../../7/04|S/../.././02) -m root -M daily -M test

Changed in smartmontools:
status: Unconfirmed → Confirmed
Evan Klitzke (eklitzke2) wrote :

That fixed it, I should have spotted that sooner.

Mathias Gug (mathiaz) on 2007-07-06
Changed in smartmontools:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers